Project

General

Profile

Help with updating TVHeadend on my system

Added by A L about 2 months ago

Hi there.

I am currently running Openmediavault 5 (which is based upon Debian 10/Buster) on an Odroid HC2, which is an ARM-based server.

According to the download page

https://phillw.net/mark/incoming/deb_packages/tvheadend/

4.3-1857 is the latest version of TVH available to me (and I have been using if for years, now).

However, according to this page (see post #20)

https://tvheadend.org/issues/5673#note-3

Nihill Baxter has kindly provided some updated versions that should work on my system.

I tried installing the latest one and have got this message:

[email protected]:~# apt install ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
ffmpeg is already the newest version (7:4.1.6-1~deb10u1).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
tvheadend : Depends: libavcodec58 (>= 10:4.1.6)
Depends: libavformat58 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libavresample4 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libavutil56 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libdvbcsa1 but it is not going to be installed
Depends: libswresample3 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libswscale5 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: liburiparser1 (>= 0.6.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
[email protected]:~# sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
tvheadend
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 22.3 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 65973 files and directories currently installed.)
Removing tvheadend (4.3-1946~gd003145d7~raspbianbuster) ...
Processing triggers for man-db (2.8.5-2) ...
[email protected]:~# apt install ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
ffmpeg is already the newest version (7:4.1.6-1~deb10u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~# dpkg -i tvheadend_4.3-1946_gd003145d7_raspbianbuster_armhf.deb
Selecting previously unselected package tvheadend.
(Reading database ... 61543 files and directories currently installed.)
Preparing to unpack tvheadend_4.3-1946_gd003145d7_raspbianbuster_armhf.deb ...
Unpacking tvheadend (4.3-1946~gd003145d7~raspbianbuster) ...
dpkg: dependency problems prevent configuration of tvheadend:
tvheadend depends on libavcodec58 (>= 10:4.1.6); however:
Version of libavcodec58:armhf on system is 7:4.1.6-1~deb10u1.
tvheadend depends on libavformat58 (>= 10:4.1.6); however:
Version of libavformat58:armhf on system is 7:4.1.6-1~deb10u1.
tvheadend depends on libavresample4 (>= 10:4.1.6); however:
Version of libavresample4:armhf on system is 7:4.1.6-1~deb10u1.
tvheadend depends on libavutil56 (>= 10:4.1.6); however:
Version of libavutil56:armhf on system is 7:4.1.6-1~deb10u1.
tvheadend depends on libdvbcsa1; however:
Package libdvbcsa1 is not installed.
tvheadend depends on libswresample3 (>= 10:4.1.6); however:
Version of libswresample3:armhf on system is 7:4.1.6-1~deb10u1.
tvheadend depends on libswscale5 (>= 10:4.1.6); however:
Version of libswscale5:armhf on system is 7:4.1.6-1~deb10u1.
tvheadend depends on liburiparser1 (>= 0.6.0); however:
Package liburiparser1 is not installed.

dpkg: error processing package tvheadend (--install):
dependency problems - leaving unconfigured
Processing triggers for systemd (241-7~deb10u7) ...
Processing triggers for man-db (2.8.5-2) ...
Errors were encountered while processing:
tvheadend

Any advice on what to do would be very much appreciated


Replies (9)

RE: Help with updating TVHeadend on my system - Added by Hiro Protagonist about 2 months ago

Looks like you need to install libdvbcsa1 and liburiparser1, then try tvheadend again.

RE: Help with updating TVHeadend on my system - Added by Mark Clarkstone about 2 months ago

apt install -f should sort it.

RE: Help with updating TVHeadend on my system - Added by Nihil Baxter about 1 month ago

The following packages have unmet dependencies:
tvheadend : Depends: libavcodec58 (>= 10:4.1.6)
Depends: libavformat58 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libavresample4 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libavutil56 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libdvbcsa1 but it is not going to be installed
Depends: libswresample3 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: libswscale5 (>= 10:4.1.6) but 7:4.1.6-1~deb10u1 is to be installed
Depends: liburiparser1 (>= 0.6.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Seems you have to install the dependencies, maybe use apt-get -t (maybe buster_backports from deb-multimedia.org) to explicit install newer versions.... >> apt-get install -t buster-backports <package>

RE: Help with updating TVHeadend on my system - Added by Radu U about 1 month ago

Hey

I see everyone is so smart but no one helped you. Here's what you need to do:

1.

sudo apt-get -y install apt-transport-https lsb-release ca-certificates curl && sudo wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg && sudo sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list' && sudo sh -c 'echo "deb http://www.deb-multimedia.org buster main non-free" > /etc/apt/sources.list' && wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && sudo dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && sudo rm deb-multimedia-keyring_2016.8.1_all.deb

2.

sudo apt update && sudo apt upgrade -y && sudo apt install liburiparser1 libdvbcsa1 -y

3.

sudo wget https://github.com/armbian/firmware/raw/master/dvb-demod-mn88472-02.fw -P /lib/firmware/

4. download the latest tvheadend deb from https://drive.google.com/drive/folders/1biBHWLb8nm_IKrXqfkUoDTbmT7xJAwrL

5. sudo dpkg -i tvheadend.deb

6. sudo reboot

enjoy!

RE: Help with updating TVHeadend on my system - Added by Radu U about 1 month ago

sure, let's ask new users to read a 20min first post instead of providing them a simple way to get this sheet running

RE: Help with updating TVHeadend on my system - Added by Der Depp vom Dienst about 1 month ago

Radu U wrote:

sure, let's ask new users to read a 20min first post instead of providing them a simple way to get this sheet running

The funny thing is: after you have read SAENACROs link and after you have invested 30 minutes you will recognize that the link has NOTHING to do with the problem....

RE: Help with updating TVHeadend on my system - Added by saen acro about 1 month ago

Radu U wrote:

sure, let's ask new users to read a 20min first post instead of providing them a simple way to get this sheet running

In line 3 of Index is you answear, else only idiot on duty can help you.

RE: Help with updating TVHeadend on my system - Added by Der Depp vom Dienst about 1 month ago

saen acro wrote:

Radu U wrote:

sure, let's ask new users to read a 20min first post instead of providing them a simple way to get this sheet running

In line 3 of Index is you answear, else only idiot on duty can help you.

Try basic logic.

Hey SAEN: I've seen that you are are spending time to edit my username manually to insult me. In another thread you have stated "Ignored Spamer user ".

Are not even capable to insult properly or are you missing persistence and consistency?

Do you need help to insult ?

    (1-9/9)