tvheadend 3.9.2331~gb85ec59~utopic hdhomerun ATSC QAM256

Added by Philip Hempel about 7 years ago

I am what seems to be a bit of a pickle with regards to a couple of issues. I am not sure if these should end up as bug reports yet or not.

1. I am attempting to upgrade my old config with the py script that just fails trying so I gave that up. Here is the error of the output. I have copied my old config to a new machine to do this testing, leaving the production machine untouched.

[email protected]:/home/hts_old# ./ .hts/tvheadend/
Traceback (most recent call last):
File "./", line 533, in <module>
update_dvr(path, chns)
File "./", line 449, in update_dvr
d = json.loads(s)
File "/usr/lib/python2.7/json/", line 338, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/json/", line 369, in decode
raise ValueError(errmsg("Extra data", s, end, len(s)))
ValueError: Extra data: line 11 column 1 - line 11 column 9 (char 175 - 183)

So I then went ahead and did an apt-get source tvheadend and compiled it with hdhomerun libs on my systems so I could forgo using the dvb wrapper.

I went ahead and started configuring my different hdhomerun devices, I have a HDHR3-US and a HDHR3-CC. I first added the HDHR3-US and it did great! For the first time since using tvheadend I was able to see channel names! I mapped the channels, I usually would have had to find the channels myself so this was great!
After the first scan I had restarted it to add in the xmltv config. And I stated to notice duplicate names showing up for channels on different freqs. None of the new channels work.

Ok So I said fine, I will disable them and go on to my cable receiver. So this is an ATSC device QAM256 no cable card in it, only using basic cable and un-encrypted channels and presently am using it with the old tvheadend 3.5.247~g098b7de~saucy, this was done after many argues hours of work mapping testing... etc.

So here is my pickle, I add the ATSC network with the prdefined mux United States: us-Cable-Standard-center-frequencies-QAM256 and I get 0 muxes or channels.

So I go to look at the config for the dvb under tvheadend. Below is what I see.
FREQUENCY = 57000000

So here is a problem and I understand why no muxes are defined. The system I defined is ATSC and not DVBC. So this makes since as to why I can't see the muxes.
So what do you do to have a ATSC cable box running QAM256 to become available in this configuration?

And if I define the system as a DVBC network, well you know, you can't see any US cable defines to chose from for muxes.


BTW, I can upload my old config if needed, I have also tried some other dvb files from the old v3 configs of cable muxes, and that is a mess, very few channels work.

Replies (3)

RE: tvheadend 3.9.2331~gb85ec59~utopic hdhomerun ATSC QAM256 - Added by Philip Hempel about 7 years ago

I have updated the bug reported here => with the above information. Looks like the same problem I have.

Thanks for everyone looking at this.

RE: tvheadend 3.9.2331~gb85ec59~utopic hdhomerun ATSC QAM256 - Added by Philip Hempel about 7 years ago

OK I have tried a couple of hacks to get this working, but am getting bad results. I decided to replace the MUX config file with a version from the "Legacy" of dvb that used the format of:

A 57000000 QAM256

This did not work out well most of the channels could not be started that were found and none of them found any channel names from the cable service. I am beginning to belive that ATSC QAM256 just is not working in the newest versions. I know that at one time they did work with the 3.9 series, just without channel names being added, I would have to add them manually. I would really hate to have 100 channels on cable using this!

I will keep digging to find some work around.

RE: tvheadend 3.9.2331~gb85ec59~utopic hdhomerun ATSC QAM256 - Added by R V almost 7 years ago

Have you had any luck with this issue?