Project

General

Profile

Bug #2514

Unable to add us_cable_standard_Center_frequencies_qam256 to an ATSC adapter

Added by Benjamin Neblett almost 7 years ago. Updated over 6 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Service Mapping
Target version:
-
Start date:
2014-11-28
Due date:
% Done:

0%

Estimated time:
Found in version:
3.9
Affected Versions:

Description

HTS Tvheadend 3.9
Raspberry pi, Openelec 4.95.3

when i try to ad the "DVB Network By location" on a Hauppauge 950Q it allows me to choose us_cable_standard_Center_frequencies_qam256 but then I click "Add DVB Network" it freezes for a couple of seconds and then no muxes added, it always remains in 0 Neither the us_Cable_IRC nor us_Cable_HRC nor us_Cable_EIA work none of them populate the muxes list not a sigle mux added.

History

#1

Updated by Max Ehrlich almost 7 years ago

I'm also having the same issue

#2

Updated by Philip Hempel almost 7 years ago

I am on a different platform "Ubuntu" but the same issue.

I have described it here on the forums => https://tvheadend.org/boards/5/topics/14781

I have placed the text below what is in the forums link above:

I am what seems to be a bit of a pickle with regards to a couple of issues. I am not sure if these should end up as bug reports yet or not.

1. I am attempting to upgrade my old config with the py script that just fails trying so I gave that up. Here is the error of the output. I have copied my old config to a new machine to do this testing, leaving the production machine untouched.

[email protected]:/home/hts_old# ./conf_migrate.py .hts/tvheadend/
Traceback (most recent call last):
File "./conf_migrate.py", line 533, in <module>
update_dvr(path, chns)
File "./conf_migrate.py", line 449, in update_dvr
d = json.loads(s)
File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/json/decoder.py", line 369, in decode
raise ValueError(errmsg("Extra data", s, end, len(s)))
ValueError: Extra data: line 11 column 1 - line 11 column 9 (char 175 - 183)

So I then went ahead and did an apt-get source tvheadend and compiled it with hdhomerun libs on my systems so I could forgo using the dvb wrapper.

I went ahead and started configuring my different hdhomerun devices, I have a HDHR3-US and a HDHR3-CC. I first added the HDHR3-US and it did great! For the first time since using tvheadend I was able to see channel names! I mapped the channels, I usually would have had to find the channels myself so this was great!
After the first scan I had restarted it to add in the xmltv config. And I stated to notice duplicate names showing up for channels on different freqs. None of the new channels work.

Ok So I said fine, I will disable them and go on to my cable receiver. So this is an ATSC device QAM256 no cable card in it, only using basic cable and un-encrypted channels and presently am using it with the old tvheadend 3.5.247~g098b7de~saucy, this was done after many argues hours of work mapping testing... etc.

So here is my pickle, I add the ATSC network with the prdefined mux United States: us-Cable-Standard-center-frequencies-QAM256 and I get 0 muxes or channels.

So I go to look at the config for the dvb under tvheadend. Below is what I see.
[CHANNEL]
DELIVERY_SYSTEM = DVBC/ANNEX_B
FREQUENCY = 57000000
MODULATION = QAM/256
INVERSION = AUTO

So here is a problem and I understand why no muxes are defined. The system I defined is ATSC and not DVBC. So this makes since as to why I can't see the muxes.
So what do you do to have a ATSC cable box running QAM256 to become available in this configuration?

And if I define the system as a DVBC network, well you know, you can't see any US cable defines to chose from for muxes.

Thanks.

BTW, I can upload my old config if needed, I have also tried some other dvb files from the old v3 configs of cable muxes, and that is a mess, very few channels work.

#3

Updated by R V over 6 years ago

I am having the same problem myself. Haupagge WinTV HVR-1800 Ubuntu 14.04.

3.4 would not map my channels. 3.9 will not let set select United States: us-Cable-Standard-center-frequencies-QAM256 at all.

w_scan picks everything up well

Also available in: Atom PDF