Project

General

Profile

Bug #858

Missing audio in recordings and streaming via HTSP.

Added by Søren Bøg almost 10 years ago. Updated over 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-01-29
Due date:
% Done:

0%

Estimated time:
Found in version:
git-fdf89b2
Affected Versions:

Description

When recording from the danish terrestrial MUX1 (specifically "Mux1 kbhv-glx") no audio is recorded in the mkv files, nor is audio available when streaming via HTSP. However streaming from http://localhost:9981/stream/channelid/XXX works flawlessly, providing the audio stream. Upon starting a recording the following is output:

[INFO]:subscription: "DVR: Lyden af universet" subscribing on "DR2", weight: 300, adapter: "Conexant CX22702 DVB-T", network: "Mux1 kbhv-glx", mux: "Mux1 kbhv-glx: 474,000 kHz", provider: "DR", service: "DR2", quality: 100
[INFO]:dvr: DR2-Lyden af universet.2012-01-29.13-51 from adapter: "Conexant CX22702 DVB-T", network: "Mux1 kbhv-glx", mux: "Mux1 kbhv-glx: 474,000 kHz", provider: "DR", service: "DR2" 
[INFO]:dvr:  # type                 lang resolution       samplerate channels
[INFO]:dvr:  1 H264                      704 x 576
[INFO]:dvr:  2 AAC                  dan                   96000      0          <disabled, no valid input>
[INFO]:dvr:  3 TELETEXT
[INFO]:dvr:  4 DVBSUB               dan
[INFO]:dvr:  5 DVBSUB               dan

The related MUX2 ("Mux2 kbhv-glx-jydr") works without any issues.

History

#1

Updated by Mikael Jepsen almost 10 years ago

Same problem here. As a temporary workaround, I record to a ts file instead, which has audio. Would be nice to be able to use mkv though...

Søren Bøg wrote:

When recording from the danish terrestrial MUX1 (specifically "Mux1 kbhv-glx") no audio is recorded in the mkv files, nor is audio available when streaming via HTSP. However streaming from http://localhost:9981/stream/channelid/XXX works flawlessly, providing the audio stream. Upon starting a recording the following is output:

[...]

The related MUX2 ("Mux2 kbhv-glx-jydr") works without any issues.

#2

Updated by Mikael Jepsen almost 10 years ago

Found the reason for the missing audio:
The danish MUX1 channels send HE-AAC with explicit SBR signalling (AudioObjectType 5), which the latm parser does not recognize. In comparison, the danish MUX2 channels also send HE-AAC, but not with explicit SBR (AudioObjectType 2), which is why tvheadend parses the latter correctly.

When recording to a ts file, I believe the audio is not parsed, but simply forwarded without even looking at it, so that works fine as well.

Fix made and pull request sent, see https://github.com/andoma/tvheadend/pull/56

#3

Updated by Mikael Jepsen almost 10 years ago

Andreas has merged the changes (https://github.com/andoma/tvheadend/commit/b8778005b4d9c1cc173f970a67bdfb4f1d7550e8) - could you take a stab at testing them out and close the issue if they work?

Thanks,
Mikael

#4

Updated by Søren Bøg over 9 years ago

Seems to work now, thanks.

#5

Updated by Adam Sutton over 9 years ago

  • Status changed from New to Fixed

Also available in: Atom PDF