Project

General

Profile

Bug #767

Stream freezes temporarily when cwc receives a valid ecm reply within less than (~)220ms after sending the request (Irdeto card)

Added by Dimitris Kazakos about 10 years ago. Updated over 3 years ago.

Status:
Fixed
Priority:
High
Assignee:
Category:
Descrambling
Target version:
Start date:
2011-11-05
Due date:
% Done:

0%

Estimated time:
Found in version:
2.12
Affected Versions:

Description

After days (weeks) of trying to figure out why I get temporary stream freezes every few seconds/minutes, I finally realized that I only get them when the ecm reply arrives faster than (around) 220ms after the request.
I suppose this has something to do with locking, but I cannot figure out where the problem lies (maybe the reply comes before all requests are sent and they both try to access the same object at the same time).
As soon as the replies return to the normal speeds of around 300ms, the stream resumes normally.
Please note that this happens using an irdeto card (multiple ecm channel ids), don't know if it happens with different card types.
Any help would be appreciated, it is killing me!

History

#1

Updated by Dimitris Kazakos about 10 years ago

Just noticed that this does not only apply to Irdeto cards, just happened with an NDS card, too. As soon as a key was received only 130ms after the request, there was a lock until the next key arrived at 3xx ms.

#2

Updated by Dimitris Kazakos about 10 years ago

Please close this issue, I just noticed that all those early-sent keys are invalid (don't know why), and thus the image freeze.

#3

Updated by Hein Rigolo about 10 years ago

  • Status changed from New to Fixed

closed on user request

#4

Updated by navaneeta harsha over 3 years ago

-

Also available in: Atom PDF