Bug #6254

No audio when transcoding to AAC

Added by Di Bo 25 days ago. Updated 24 days ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Found in version:
Affected Versions:



I am using HTS Tvheadend 4.3.0~pre+202302241122-0~built202302241317~gitd1366a066~ubuntu18.04.1 on several root servers.
Due to limited mobile data volume I want to transcode video and audio to a lower bitrate.

Video transcoding is working fine but currently I can only use "copy" for the audio streams.
No matter which codec profiles I want to use for the audio transcoding to AAC 56k (or any other) no sound seems to be transcoded. The audio stream in VLC is empty, using all kinds of different settings. Tried this for different networks and on different servers.
Switching back to "copy" the original audio is working.


2023-03-03 12:34:23.223 spawn: Executing "/usr/bin/ffmpeg"
2023-03-03 12:34:25.339 transcode: 0003: 02:H264: > Using profile SD400neu
2023-03-03 12:34:25.339 transcode: 0003: 01:AAC: > Using profile 64k AAC Audio
2023-03-03 12:34:25.551 libav: AVCodecContext: using SAR=1/1
2023-03-03 12:34:25.551 libav: AVCodecContext: using cpu capabilities: MMX2 SSE2Fast LZCNT SSSE3 SSE4.2 AVX
2023-03-03 12:34:25.552 libav: AVCodecContext: profile High, level 3.0

I know this worked before and I have no clue what causes this behaviour. I have no stream filters applied.
Would be thankful for any help on this.



Updated by Flole Systems 25 days ago

  • Status changed from New to Invalid

Updated by saen acro 25 days ago

@ Di Bo
remove limit of zero audio streams.

Install official version.


Updated by Di Bo 25 days ago

I installed HTS Tvheadend 4.3-2100~gd1366a066 (latest official build?) now on three different machines as described here []. The problem persists. No audio transcoding / empty audio stream on all networks, devices and channels on all servers. Set the limit of zero audio streams (automatic setting) higher. No change. All codecs should be installed. Is this a mistake on my side or can someone reproduce this?


Updated by saen acro 25 days ago

You have "Limited audio tracks = 0"


Updated by Di Bo 24 days ago

What do you mean? The "no limit" standard value is zero, but as I said before even setting to a higher number makes no change. There is still no audio on all machines I tested when the sound is supposed to be transcoded.


Updated by saen acro 24 days ago

Standard value is 1

Also available in: Atom PDF