Bug #6245

Instant recordings randomly fail over API

Added by Shane Angelo 9 months ago. Updated 6 months ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Found in version:
HTS Tvheadend 4.3-2070~g2beb6c9c8
Affected Versions:


I have been seeing an issue on two tvheadend installations using Kodi as the front end for years.

See these forums threads:

Today I came back to this and found that it still fails on latest tvheadend 4.3.2070 and Kodi 19.5 and I also tried the Android App TVHClient and found that it reacts the same.

Up until today I thought this was an issue with Kodi but using a different totally unrelated client that shoes the same error log suggests that its a tvheadend issue. The error returned is "User does not have access" which is not correct, the user does have access and the failure appears random. Triggering recordings will correctly load the timer record, the next in succession will fail.

Kodi reports:
2023-01-05 17:49:25.516 T:106477 ERROR <general>: AddOnLog: pvr.hts: Command addDvrEntry failed: User does not have access
2023-01-05 17:49:25.516 T:106477 ERROR <general>: AddTimer: Add-on 'Tvheadend:' returned an error: server error


tvheadend-1.log (36.8 MB) tvheadend-1.log Shane Angelo, 2023-01-06 00:17
tvheadend-9.log (9.53 MB) tvheadend-9.log Shane Angelo, 2023-01-06 07:02



Updated by Flole Systems 9 months ago

  • Status changed from New to Invalid

No debug logs of Tvheadend provided.


Updated by Shane Angelo 9 months ago

Hi, tried running logging and can see syslog entries. There is literally nothing written to the log when the event happens. I suspect lower level debug is required.

I am okay to do this if advised how to set debug higher. All i can see is running debug builds but not sure how to install one or if I can revert without losing config and setup.


Updated by Shane Angelo 9 months ago

Ok, figured out the debug - this issue is now closed, not sure if I should open a new issue?

In the attached log there are three recordings that work with addDvrEntry. The fourth fails.


Updated by Flole Systems 9 months ago

You turned on a whole lot of unnecessary debug subsystems like all the table stuff or even mpegts... You should focus on the relevant onces, like htsp, htsp-ans, htsp-req, access, dvr. Also you should double-check the settings for that user to make sure those are indeed correct.

The issue can be opened again once all details are provided. However, it doesn't really matter what state this is in as the help you will receive is the same.

You can also use gdb to see where channel_access() does return/refuse the client.


Updated by Shane Angelo 9 months ago

Attached a reduced log of a Kodi and a TVHClient connected that shows the failure

Starts with Kodi's PVR client restarting and doing what looks like grabbing the guide data.

Then Kodi PVR client trying a series of recordings that work until reaching one that does not. Tje failure is program "ABC News Video Lab" on ABC NEWS.

Then connected TVHClient (android software on phone) to record the same program and it failed. Tried from Kodi and TVHClient again and recording failed.

Restarted the Kodi PVR addon.

Tried TVHClient again and recording failed. Tried from Kodi and recording worked.

It took me many attempts to get here because the triggers to it failing are not clear. Restarting the Kodi addon does make an impact but as you can see that two different clients are impacted and only one recovers like the data gets out of sync to a client and causing that client to refresh appears to correct it.


Updated by Flole Systems 9 months ago

  • Status changed from Invalid to New

Then the next step would be to use gdb to see where channel_access() does return/refuse the client. If you make a coredump at the beginning of that function you can continue debugging later on if it becomes necessary, so that's probably a good idea aswell.

Also available in: Atom PDF