Project

General

Profile

Bug #6219

Successful build output contains error: "No package 'libavresample' found"

Added by Sean Warner 11 days ago. Updated 11 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Transcoding
Target version:
-
Start date:
2022-11-21
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-2051~g0ff96106a
Affected Versions:

Description

I can build the latest TVHeadend 4.3-2051~g0ff96106a in Ubuntu 22.04.1 on a Pi 4.

I was not able to install the library: libavresample-dev because it is no longer available for Ubuntu 22.04.1
Instead it has been replaced with libswresample-dev and TvHeadend builds fine with this.
The configure script gives me this information:

checking for pkg libswresample >=2.1.100 ...      ok (detected 3.9.100) 
checking for pkg libavresample >=3.0.0 ...        fail (detected <none>)

However when I use the build option:
--enable-libav

I get ENDLESS error/warning messages in the build output:
Package libavresample was not found in the pkg-config search path.
Perhaps you should add the directory containing `libavresample.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libavresample' found

When I use the build option:
--disable-libav

I don't get ANY of those error/warning messages in the build output:

This situation was reported in 2018...
https://tvheadend.org/issues/5237

Is this something to do with ffmpeg that is still dependant on libavresample and enabling libav is somehow related to ffmpeg?

Is there a way to stop those error/warning messages?

Any help or explanation much appreciated.

Flex

History

#1

Updated by Flole Systems 11 days ago

  • Status changed from New to Invalid

Duplicate of #6084

Also available in: Atom PDF