Project

General

Profile

Bug #6202

Pre-processor command not called when resuming recording after "Source reconfigured"

Added by R M 22 days ago. Updated 21 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2022-09-14
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-2009~g1295dd2be (2022-02-22T04:09:52+0000)
Affected Versions:

Description

Since I use the matroska profile, I'm aware that the stream parameter change leads to a recording interruption. I've also activated the option "Clone scheduled entry on error". After the source reconfiguration a new recording starts as expected and a new file is created. So far so good, but while the recording is resumed, the pre-processor command is not executed again.

Please see the log excerpt for this case:

2022-09-14 13:31:59.777 [ INFO] dvr: "ZDF spezial" on "ZDF HD" recorder starting
2022-09-14 13:31:59.788 [ INFO] spawn: Executing "/home/xbian/.hts/tvheadend/scripts/on-recording-start.sh"
2022-09-14 13:31:59.789 [ INFO] subscription: 01C3: "DVR: ZDF spezial" subscribing on channel "ZDF HD", weight: 300, adapter: "Panasonic MN88472 #0 : DVB-C #0", network: "WGH [DVB-C]", mux: "282MHz", provider: "Television", service: "ZDF HD", profile="matroska", username=""
2022-09-14 13:32:03.931 [WARNING] dvr: Unable to change directory permissions to "775" for "/home/xbian/hdd/recordings/ZDF spezial" (keeping "755")
2022-09-14 13:32:03.935 [ INFO] dvr: /home/xbian/hdd/recordings/ZDF spezial/ZDF spezial.mkv from adapter: "Panasonic MN88472 #0 : DVB-C #0", network: "WGH [DVB-C]", mux: "282MHz", provider: "Television", service: "ZDF HD"
2022-09-14 13:32:03.935 [ INFO] dvr: # type lang resolution aspect ratio sample rate channels
2022-09-14 13:32:03.935 [ INFO] dvr: 1 H264 1280x720 16:9
2022-09-14 13:32:03.935 [ INFO] dvr: 2 AC3 ger 48000 2
2022-09-14 13:32:03.935 [ INFO] dvr: 3 MPEG2AUDIO ger 48000 2
2022-09-14 13:32:03.935 [ INFO] dvr: 5 MPEG2AUDIO mul 48000 2
2022-09-14 13:32:03.935 [ INFO] dvr: 6 DVBSUB ger
2022-09-14 13:32:03.935 [ INFO] dvr: 7 MPEG2AUDIO mis 48000 2
2022-09-14 13:32:03.935 [ INFO] dvr: 8 TEXTSUB ger
[...]
2022-09-14 16:02:00.788 [ INFO] spawn: Executing "/home/xbian/.hts/tvheadend/scripts/on-recording-stop.sh"
2022-09-14 16:02:00.791 [ INFO] dvr: "ZDF spezial" on "ZDF HD": End of program: Source reconfigured
2022-09-14 16:02:00.792 [ INFO] dvr: "ZDF spezial" on "ZDF HD" recorder starting
2022-09-14 16:02:00.794 [ INFO] dvr: /home/xbian/hdd/recordings/ZDF spezial/ZDF spezial-1.mkv from adapter: "Panasonic MN88472 #0 : DVB-C #0", network: "WGH [DVB-C]", mux: "282MHz", provider: "Television", service: "ZDF HD"
2022-09-14 16:02:00.796 [ INFO] dvr: # type lang resolution aspect ratio sample rate channels
2022-09-14 16:02:00.796 [ INFO] dvr: 1 H264 1280x720 16:9
2022-09-14 16:02:00.796 [ INFO] dvr: 2 AC3 ger 48000 2
2022-09-14 16:02:00.796 [ INFO] dvr: 3 MPEG2AUDIO ger 48000 2
2022-09-14 16:02:00.796 [ INFO] dvr: 5 MPEG2AUDIO mul 48000 2
2022-09-14 16:02:00.796 [ INFO] dvr: 6 DVBSUB ger
2022-09-14 16:02:00.796 [ INFO] dvr: 7 MPEG2AUDIO mis 48000 2
2022-09-14 16:02:00.796 [ INFO] dvr: 8 TEXTSUB ger
2022-09-14 16:07:18.515 [ INFO] mpegts: 298MHz in WGH [DVB-C] - tuning on Panasonic MN88472 #2 : DVB-C #0
2022-09-14 16:07:18.549 [ INFO] subscription: 0203: "127.0.0.1 [ | Kodi Media Center ]" subscribing on channel "ProSieben", weight: 150, adapter: "Panasonic MN88472 #2 : DVB-C #0", network: "WGH [DVB-C]", mux: "298MHz", provider: "ProSiebenSat.1", service: "ProSieben", profile="htsp", hostname="127.0.0.1", username="127.0.0.1", client="Kodi Media Center"
[...]
2022-09-14 17:05:00.029 [ INFO] subscription: 01C3: "DVR: ZDF spezial" unsubscribing from "ZDF HD", username=""
2022-09-14 17:05:00.032 [ INFO] spawn: Executing "/home/xbian/.hts/tvheadend/scripts/on-recording-stop.sh"
2022-09-14 17:05:00.046 [ INFO] dvr: "ZDF spezial" on "ZDF HD": End of program: Completed OK

Since I use the scripts to trigger a LED blinking, it stops due to the source reconfiguration and doesn't go on again after the recording was "resumed".

History

#1

Updated by Flole Systems 22 days ago

  • Status changed from New to Invalid

Use latest master when filing issue reports, not some outdated version.

#2

Updated by R M 21 days ago

Flole Systems wrote:

Use latest master when filing issue reports, not some outdated version.

Thank you for the hint. I wasn't aware the version I'm using is not the current one. Unfortunately this is the latest version from a xbian package and I have no means to build one myself from scratch based on the current source base. So if there is no will on your side to reproduce the issue on your end, as far as I'm concerned, please feel free to close this bug report. If the bug is still there, it will simply remain. Maybe someone with the current version will stumble across it and reopen the ticket.

Anyhow, thank you for developing such a great piece of software (no irony intended, really). I've been using it as a daily driver in my STB for a few years and found no better alternative.

Also available in: Atom PDF