Project

General

Profile

Bug #6183

Tvheadend SAT>IP server doesn't start at boot

Added by Retro Fan about 1 month ago. Updated 18 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
SAT>IP
Target version:
-
Start date:
2022-07-03
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3.0 Ubuntu 22.04
Affected Versions:

Description

I'm using the internal SAT>IP Server from TVH, but it doesn't start at boot even though the settings are correct and the UUID is set (port 554). Configuration is RPI4.

I already tried to add 'sleep 15' to /etc/init.d/tvheadend, but no luck. I don't see it as SAT>IP server in other applications. When restarting TVH manually it does work again: sudo service tvheadend restart

Is this a bug?

And please add the option 'Disable fast input switch' just like other SAT>IP servers. Afaik this is the only setting which is missing for internal SAT>IP server of TVH.

Thank you!

History

#1

Updated by Flole Systems about 1 month ago

  • Status changed from New to Invalid

No debug logs and the version information is either incomplete or super old.

#2

Updated by Retro Fan about 1 month ago

O, sorry, it's the latest Ubuntu 22.04 LTS distro of TVH and I thought it was a general bug.
However, with Buster and Bullseye there's no problem.
With Ubuntu 22.04 LTS I fixed it with a workaround adding these lines to /etc/rc.local file:

sleep 15
sudo service tvheadend restart

Topic can be closed ;-)

#3

Updated by Markus Bonet 18 days ago

For ages I have the same problem on Fedora.
systemctl restart tvheadend fixes the problem after reboot but I never had the time to look into it.
Thought it is related to my unit file or setup.
I'm using the current master branch. I can provide more information if needed.

Also available in: Atom PDF