Project

General

Profile

Bug #6172

IPTV M3u list Scanning is Broken

Added by Mark de Leon about 1 month ago. Updated about 1 month ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Configuration
Target version:
-
Start date:
2022-05-25
Due date:
% Done:

0%

Estimated time:
Found in version:
4.2 (Raspberry Pi3 from TVH Repo) and 4.3 (built from source on Raspberry Pi3)
Affected Versions:

Description

Let's face it. M3u playlist scanning is BROKEN. Even the work-around of manually adding a (not automatic) IPTV network mux does not work if it will not scan. If it will; not scan successfully you will never get the required network number. Besides , that is not a fix, it is a work-around for something that is broken and had been broken apparently for a long time.

After having tested MANY PVR software packages over the last several weeks , I can safely say that this is a major factor holding TVHeadend back.

I even believe under the circumstances it is unreasonable to represent TVHeadend as "functional" , as I have seen not a single IPTV source that it will scan reliably and consistently every time. This is the only PVR Back-end software with this problem to such a grave level.

If this is not a bug then the documentation needs to get updated to show how convoluted the process is . The process should not skip steps as it does in the published work-around , it MUST be step by step, complete and concise, or I would still consider this a BUG.

This bug is so bad, that doing a new install with a working configuration has been impossible even after a month of trying.

History

#1

Updated by Flole Systems about 1 month ago

  • Status changed from New to Invalid

No version information provided and can't reproduce and no debug logs provided.

Also Tvheadend is not represented as functional, if you read the license:

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Also available in: Atom PDF