Project

General

Profile

Bug #6170

Deadlock src/dvr/dvr_rec.c:1460 when "End of program: Source reconfigured"

Added by rado 84 20 days ago. Updated 20 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Crashes
Target version:
-
Start date:
2022-05-08
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1958~gfdc3f945f
Affected Versions:

Description

Hey,

I'm running into a reproducible Deadlock Crash of TVH whenever I'm recording and the mpegts stream reconfigures during the recording. My DVR stream profile is set to "matroska".
Since I'm running this instance on a server and it only happens occasionally I'm not able to easily provide a gdb log.

REASON: deadlock (src/tvh_thread.c:513)
mutex 0x564e73323220 locked in: src/dvr/dvr_rec.c:1460 (thread 23194)

Best.


Files

tvh_logs_deadlock.log (13.5 KB) tvh_logs_deadlock.log rado 84, 2022-05-08 23:00

History

#1

Updated by Flole Systems 20 days ago

  • Status changed from New to Invalid

Bug reports for old versions are not accepted. Use latest master.

Also available in: Atom PDF