Project

General

Profile

Bug #6140

"tvheadend --firstrun --abort" exits without saving the configuration

Added by Marius Dinu 10 months ago. Updated 10 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Configuration
Target version:
-
Start date:
2022-02-15
Due date:
% Done:

0%

Estimated time:
Found in version:
>= 4.2.8, incl. master
Affected Versions:

Description

OpenWrt uses this command for the first run after tvheadend package is installed:
tvheadend -c /etc/tvheadend -B -C -A
This command should create initial admin account without password and save it to /etc/tvheadend. It does not. Tvheadend aborts execution before the files are saved to disk.
It was working in tvheadend v4.0.10. After I updated the package to v4.2.8 it's not working anymore. Also not working in current master branch.

To reproduce:
- Install tvheadend
- Remove /etc/tvheadend
- Run the command
- tvheadend shows messages that a new account is created, but /etc/tvheadend remains empty after tvheadend exits.

I am attaching 2 strace files, with and without --abort, showing that --abort (-A) causes tvheadend to exit before configuration files are saved.


Files

tvheadend-first-start-bug.txt (45.1 KB) tvheadend-first-start-bug.txt with --abort Marius Dinu, 2022-02-15 17:03
tvheadend-first-start-bug, no-abort.txt (67.2 KB) tvheadend-first-start-bug, no-abort.txt without --abort Marius Dinu, 2022-02-15 17:03

History

#1

Updated by saen acro 10 months ago

Wondering whot mean for you "Abort"
It's normal when refuse not to do anything.

#2

Updated by Marius Dinu 10 months ago

"-A" (short form) or "--abort" (long form) is a tvheadend switch. As I understand, it should terminate execution after -C switch creates the initial configuration.

Also available in: Atom PDF