Project

General

Profile

Bug #6121

Compile-Error Debian: dh: error: Compatibility levels before 7 are no longer supported (level 5 requested)

Added by Stefan Dietzel 4 months ago. Updated about 1 month ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2022-01-15
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1994~gc7b713edb
Affected Versions:

Description

Hi,

compiling with debian is not possible:

Use the -v/--verbose option for more details.
dpkg-buildpackage: Information: Quellpaket tvheadend
dpkg-buildpackage: Information: Quellversion 4.3-1994~gc7b713edb
dpkg-buildpackage: Information: Quelldistribution unstable
dpkg-buildpackage: Information: Quelle geändert durch Andreas Öman <>
dpkg-buildpackage: Information: Host-Architektur amd64
dpkg-source --before-build .
debian/rules clean
dh clean --with-systemd
dh: error: Compatibility levels before 7 are no longer supported (level 5 requested)
make: *** [debian/rules:6: clean] Fehler 255
dpkg-buildpackage: Fehler: Unterprozess debian/rules clean lieferte Exitstatus 2

History

#1

Updated by Stefan Dietzel 4 months ago

It's not happening during compilation but when building dkpg packages.

Parameters are:

AUTOBUILD_CONFIGURE_EXTRA="--enable-libav --disable-hdhomerun_client --disable-hdhomerun_static --disable-ffmpeg_static --disable-libffmpeg_static --enable-libx264 --enable-libx265 --enable-vaapi --enable-libfdkaac --disable-libx264_static --disable-libx265_static --disable-libfdkaac_static --disable-libvorbis_static --disable-libtheora_static --disable-libvpx_static --disable-libopus_static --enable-libav" ./Autobuild.sh -t debian

#2

Updated by saen acro 4 months ago

No need to say on your Debian that is Debian he already, knows it.

See if there is updates with

apt update && apt upgrade

https://tvheadend.org/boards/4/topics/24116#Automated-build-script

#3

Updated by Stefan Dietzel 4 months ago

no updates avaiable. Its Debian Testing branch.

#4

Updated by Stefan Dietzel 4 months ago

Problem is that new dpkg is not supporting the requested package Version.

Compatibility levels before 7 are no longer supported (level 5 requested)

This happens during.deb creation.

#5

Updated by Stefan Dietzel 4 months ago

Problem fixed localy for me.

In file debian/compat version is set to 5.
This needs to be upgraded to 7 and it works.

#6

Updated by Stefan Dietzel 4 months ago

Created a pull request in github for this (#1439).
This pull request also includes a small change for my former pull request regarding vappi h264/hevc transcoding (a few years ago). Buffer size needed to be increased to get better quality results.

#7

Updated by Flole Systems about 1 month ago

  • Status changed from New to Fixed

Also available in: Atom PDF