Project

General

Profile

Bug #6109

Autobuild.sh not working on Ubuntu 20.04 VM

Added by Kae TuuN 6 months ago. Updated about 1 month ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Packaging
Target version:
-
Start date:
2021-12-13
Due date:
% Done:

0%

Estimated time:
Found in version:
Origin Master from 2021-12-13T20:30
Affected Versions:

Description

Tried to use Autobuild.sh on a fresh Ubuntu 20.04 VM.
Installed the following packages and there Dependencies after VM Installation:
  • build-essential
  • debhelper
  • pkg-config
  • gettext
  • libavahi-client-dev
  • libssl-dev
  • zlib1g-dev
  • liburiparser-dev
  • cmake
  • libpcre3-dev
  • libdvbcsa-dev

then rebootet and started "./Autobuild.sh -t focal-amd64" as root. The build Process failed.

I found somme noteable Log Entries:
"checking for pkg libpcre2-8 ... fail (detected <none>)"
-> libpcre2-8-0:amd64 is installed

"checking for pkg libva >=0.38.0 ... fail (detected <none>)"
-> If it is needed, why it is not listed a dependency?

"DOWNLOAD misc/staticlib/Ubuntu 20.04/x86_64/ffmpeg-6560a298f2cb58523e4d60dd9832e87248206d70.tgz / kZ54ee7ZUvsSYmb9VGSpnmoVzcAUhpBXLq8k
/usr/bin/env: ‘python’: No such file or directory
...
OpenSSL.SSL.Error: [('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')]"
-> Errors like this appear multiple Times.

Dozens of deprecated Warnings. Some examples:
"dh: warning: Compatibility levels before 9 are deprecated (level 5 in use)"

"WARNING: Building with deprecated library libavresample"

"libavfilter/avfiltergraph.c:135:5: warning: ‘resample_lavr_opts’ is deprecated [-Wdeprecated-declarations]
135 | av_freep(&(*graph)->resample_lavr_opts); | ^~~~~~"

"libavresample/internal.h:63:10: warning: ‘AVMixCoeffType’ is deprecated [-Wdeprecated-declarations]
63 | enum AVMixCoeffType mix_coeff_type; /**< mixing coefficient type */ | ^~~~~~~~~~~~"

I don't know what exactly leads to the failed Build Process and I hope some one can help me.
If there is an easy but maybe time intensive Way to get rid of the Deprecated Warnings, please tell me and I will do my best tp support TVHeadend.

Greetings KaeTuuN


Files

Autobuild.log (297 KB) Autobuild.log Build Process Output. Kae TuuN, 2021-12-13 21:35

History

#2

Updated by Kae TuuN 6 months ago

Big thanks for the fast reply!
Worked with some tweaks. I will post them tomorrow.

Greetings KaeTuuN

#3

Updated by Flole Systems 6 months ago

The deprecation warnings are from ffmpeg, so nothing we can do about them.

#4

Updated by Flole Systems about 1 month ago

  • Status changed from New to Invalid

Also available in: Atom PDF