Project

General

Profile

Bug #6075

Services 'Parent Disabled' in combination with SAT>IP client

Added by Ernie Bert over 1 year ago. Updated 5 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
SAT>IP
Target version:
-
Start date:
2021-07-19
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1967~geb59284b8
Affected Versions:

Description

Similar to Ticket #6041 I also have 'parent disabled' services, but here in combination with SAT>IP client
TVH is 4.3-1967~geb59284b8.
Changing Maximum PIDs from 32 to 20 lets me map some more channels, but lots of them stay "parent disabled".
Restarting TVH and rescanning (initial scan) many times also brought me a few more channels that where mapable.
My equipment: SAT>IP-Server (SATPI) on E2-Box with 8x FBC DVB-C-Tuner. When I activate DVB-C tuners on box for direct reception all transponders have good results for SNR (almost every t has 90%), AGC (every t has under 60%) and every t has BER 0. Direct TV reception als well as SAT>IP transmission to other SAT>IP-Client (other E2-Box) is without image- and sound disturbances. SAT>IP-Client on other E2-Box finds all channels.

I reproduced same issues on 2 different setups. 1st is Ubuntu Workstation x64-20.04 LTS on VirtualBox client on Win10 x64 host and 2nd is Ubuntu Server x64-20.04 LTS on VMware vm
On both setups tvh was installed via

sudo add-apt-repository 'deb https://apt.tvheadend.org/unstable bionic main' 
I always used standard configuration. Excpections: 'Maximum PIDs' 32 (standard) is down to 20, 'pass specinv' is on and 'network discovery' is 'new muxes and changed muxes'

When some channels can be found tvh logs

2021-07-19 14:46:14.322 mpegts: 546MHz in Vodafone-E2 scan complete

2021-07-19 14:46:14.322 subscription: 052B: "scan" unsubscribing

But a lot of channels cannot be mapped, they stay 'parent disabled"

When no channels can be found tvh logs

2021-07-19 14:48:31.522 mpegts: 594MHz in Vodafone-E2 - tuning on SAT>IP DVB-C Tuner #6 ([email protected])

2021-07-19 14:48:31.522 subscription: 0537: "scan" subscribing to mux "594MHz", weight: 6, adapter: "SAT>IP DVB-C Tuner #6 ([email protected])", network: "Vodafone-E2", service: "Raw PID Subscription" 

2021-07-19 14:48:36.521 mpegts: 594MHz in Vodafone-E2 - scan no data, failed

A similar procedure to "Restarting TVH and rescanning (initial scan) many times" is to reset failed muxes to scan status 'ACTIVE'. This also brought a few mapable channels at the begining of my channel search.

Thanks for help


Files

tvh-screenshot.pdf (72.8 KB) tvh-screenshot.pdf Ernie Bert, 2022-03-24 22:55
capture.tcpdump (6.07 MB) capture.tcpdump traffic capture between TvHeadend and SatPI Marc Postema, 2022-04-01 20:40

History

#1

Updated by Flole Systems over 1 year ago

Are there any transport errors or continuity errors?

#2

Updated by Flole Systems over 1 year ago

  • Status changed from New to Invalid

I just looked at this again:

Ernie Bert wrote:

2021-07-19 14:48:36.521 mpegts: 594MHz in Vodafone-E2 - scan no data, failed

Your server is simply not providing data to Tvheadend, so Tvheadend does exactly what it is supposed to do: Detect that the frequency is unavailable and disable it. Not a Tvheadend bug most likely, unless you can show that the data is actually sent to Tvheadend and it doesn't pick it up (which is possible but unlikely).

#3

Updated by Ernie Bert over 1 year ago

Flole Systems wrote:

Are there any transport errors or continuity errors?

Errors are neglectible: only a few every two hours

Flole Systems wrote:
Detect that the frequency is unavailable and disable it. Not a Tvheadend bug most likely, unless you can show that the data is actually sent to Tvheadend and it doesn't pick it up (which is possible but unlikely).

I think, SAT>IP-client of Tvheadend behaves buggy, because other SAT>IP-client (other E2-Box) is able to find all channels and receive streams without errors from SAT>IP-server.

To proof that behaviour, I would like to publish here detailed log of SAT>IP-server (SatPI) and at the same time (same time slot) detailed log of tvheadend. Please tell me which debug parameters to choose in order to catch precious information. Thank you

#4

Updated by Flole Systems over 1 year ago

Logs alone won't help, what would be needed is a capture of the traffic with the log, if there's no traffic after Tvheadend sent a request then it's not a Tvheadend issue.

#5

Updated by Ernie Bert over 1 year ago

Flole Systems wrote:

what would be needed is a capture of the traffic with the log

Wireshark?

#6

Updated by Flole Systems over 1 year ago

Yes, Wireshark could be used for that.

#7

Updated by D B about 1 year ago

@Ernie Bert

Did you ever get to the cause of 'Parent disabled' ?

#8

Updated by Marc Postema 8 months ago

Probably you need to increase the adapter parameters 'Tuning Timeout' in Tvheadend

#9

Updated by Ernie Bert 8 months ago

@Marc Postema
Please tell me where to change the "Tuning Timeout" parameters. Here are my settings.
As I said already: Changing Maximum PIDs from 32 to 20 lets me map some more channels, but lots of them stay "parent disabled".

By the way: Manufaturer of SatPI Server on my E2-Box is YOU !

#10

Updated by Ernie Bert 8 months ago

Ernie Bert wrote:

Manufacturer

#11

Updated by Marc Postema 8 months ago

Hi,
Yes that's me.

Well I have a Vu+ FBC dvb-s2 and C tuners. I have tried first the S2 variant which has this option in Tvheadend but for some reason for the C variant this option is not present.

The strange thing is older version of Tvheadend is working which I used initially.

The problem is the Vu is taking more time to produce the PID data used for initial scanning. So Tvheadend times out before data is available on the subsequent PID request.

I am trying to figure out what is going wrong.

#12

Updated by Marc Postema 8 months ago

During scanning lowering the PID max to the minimum as PMT PIDS that are in the PAT, will not be scanned.

So in other words: I have a PAT with 38 PMT PIDs and need to set the 'Maximum PIDs' amount to 20. Now for some reason the last are never requested. So my understanding is that the PID split-up is not working correctly?

#13

Updated by Marc Postema 8 months ago

Marc Postema wrote:

The strange thing is older version of Tvheadend is working which I used initially.

This is not try what I wrote, because the 'Parent disable' is added at some point after my build version.

The PMT PIDs are initially never read correctly in this version as well, but it lets you map them and add first tune it will read the PMT and update the data.

This is my understanding at the moment.

#14

Updated by Marc Postema 8 months ago

Here is the traffic capture between Tvheadend and SatPI

Here are the PMT pid requests and and send by SatPI (The long delay is not the problem as the 'Grace period' is set to 50)
But this still results in 'Parent disable' services.

#15

Updated by Ernie Bert 8 months ago

On my site all problems were solved by setting 'Grace period' to 50. (thanks to Marc Postema) All missing muxes can be scanned now and services are mapable afterwards. But I've heared already that I must be almost the only one being lucky in scanning dvb-c channels with SatPI.
My equipment is SatPI 1.6.2.26~g3730645 and TVheadend Version 4.3-2010~g3b1d7a928

#16

Updated by Marc Postema 8 months ago

It is not only that SatPI is affected see #6041. And that it is more luck that it works out. The "Grace period" is (mostly) only needed for FBC tuners as it takes longer time to produce data from the drivers.

I have added a tcpdump showing that Tvheadend receives the PMT but discards them.

It has something to do with the version in the mpegts table (PMT) that it is discarded by Tvheadend. This problem is introduced when "parent disable" is "turned on" in the code. Before it was possible to map services without correct PMT parsing. Makes you think why this "parent disable" was put in comment, because it did not work correctly.

#17

Updated by Marc Postema 8 months ago

Sorry, I think I made a mistake here with testing. During testing I changed a lot of things. But now with a clean setup I can not see the behavior that I show before and is described in this issue.

I will keep my I on this, one big problem with Vu+ FBC tuners is that it takes some time with 'low' bitrate PID (mostly during scanning) to receive data from the driver. That is why the 'Grace period' etc. should be increased.

#18

Updated by D B 5 months ago

Hey, I opened #6041....Still having the issue having come back after many months.

How do I go about increasing the 'Grace Period' I can't find that setting on DVB-T

#19

Updated by Marc Postema 5 months ago

Hi @ D B

You are only using TvHeadend with your setup?

There were some changes made to TvHeadend in the past. That I found a bit strange and to comment in the code was saying: to prevent 'Parent Disabled' Services this...and this.. (not sure what it was exactly)

I am not complexly convinced it is not a TvHeadend issue. But in my case I did not observe this at the moment I last checked this.

#20

Updated by D B 5 months ago

Well. I'm currently using NextPVR, without issues.

I run in a docker, so I kill one docker and boot up the TVHeadEnd docker. I'm able to do the scans etc but with 'parent disabled'

Where is the 'Grace Period' setting...?

#21

Updated by Marc Postema 5 months ago

My comments were more related to SatPI in combination with Tvheadend.

I am not very sure we're this 'Grace Period' is for dvb-t tuners. But dvb-s2 it is somewhere in the frontend config page in tvheadend.

Also available in: Atom PDF