Project

General

Profile

Bug #6021

libssl-dev conflict when building packages

Added by saen acro about 1 month ago. Updated 16 days ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2021-03-12
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3.xxxx
Affected Versions:

Description

OS Ubuntu 18.04 x64
Lot of newer software ex. NPM depend on libssl1.0-dev and remove older libssl-dev
But building TVHeadend package need libssl-dev

History

#1

Updated by saen acro about 1 month ago

dpkg-checkbuilddeps: error: Unmet build dependencies: libssl-dev
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)

Will be removed:
  libssl1.0-dev node-gyp nodejs-dev npm
Will be installed:
  libssl-dev

#2

Updated by saen acro about 1 month ago

Problematic dependency found but solution not!

Any idea how to update
https://github.com/tvheadend/tvheadend/blob/736ac427b1934832aab23391f5ce35f687c999c6/debian/control#L5
to allow use newer library without to broke older one?

#3

Updated by Flole Systems about 1 month ago

libssl-dev | libssl1.0-dev

#4

Updated by Flole Systems 16 days ago

  • Status changed from New to Fixed

Also available in: Atom PDF