Project

General

Profile

Bug #5997

Continuity counter error and failed to decode PMT

Added by Norbert E. 6 months ago. Updated 5 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-01-31
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1923~gaaca05cc1
Affected Versions:

Description

I can't play certain channels. Debug output (see below) says continuity counter error and failed to decode PMT. What is the issue here?

2021-01-31 18:33:11.778 mpegts: 11303H in DVB-S Network - tuning on TBS 5580 CI USB2.0 DVB-S/S2/S2X #0 : DVB-S #1
2021-01-31 18:33:11.780 subscription: 016E: "epggrab" unsubscribing
2021-01-31 18:33:12.059 subscription: 0170: "192.168.178.34 [ user | Kodi Media Center ]" subscribing on channel "ServusTV HD Oesterreich", weight: 150, adapter: "TBS 5580 CI USB2.0 DVB-S/S2/S2X #0 : DVB-S #1", network: "DVB-S Network", mux: "11303H", provider: "ServusTV", service: "ServusTV HD Oesterreich", profile="htsp", hostname="192.168.178.34", username="user", client="Kodi Media Center" 
2021-01-31 18:33:12.359 en50221: failed to decode PMT
2021-01-31 18:33:13.340 TS: DVB-S Network/11303H/ServusTV HD Oesterreich: H264 @ #3583 Continuity counter error (total 1)
2021-01-31 18:33:23.524 TS: DVB-S Network/11303H/ServusTV HD Oesterreich: H264 @ #3583 Continuity counter error (total 8)
2021-01-31 18:33:35.288 TS: DVB-S Network/11303H/ServusTV HD Oesterreich: H264 @ #3583 Continuity counter error (total 14)
2021-01-31 18:33:45.700 TS: DVB-S Network/11303H/ServusTV HD Oesterreich: H264 @ #3583 Continuity counter error (total 19)
2021-01-31 18:33:49.988 subscription: 0170: "192.168.178.34 [ user | Kodi Media Center ]" unsubscribing from "ServusTV HD Oesterreich", hostname="192.168.178.34", username="user", client="Kodi Media Center" 
2021-01-31 18:33:49.993 en50221: failed to decode PMT

History

#1

Updated by Flole Systems 6 months ago

  • Status changed from New to Invalid

Bug reports for old versions are no longer accepted. Please use the latest version.

#2

Updated by Norbert E. 6 months ago

Thanks for the fast response, but what do you mean with "old version"?
According to https://tvheadend.org/projects/tvheadend/wiki/Releases version 4.2 is latest release.

#3

Updated by Flole Systems 6 months ago

Latest version is 4.3. 4.2 is so old and there have been many fixes and improvements since then, it's not a proper release though (at least not yet)

#4

Updated by Norbert E. 6 months ago

Since 4.3 is not an official release (yet), how to I upgrade my RPI4 to this version?

#5

Updated by Norbert E. 6 months ago

I can't finde 4.3 on github. Following command returns:

fatal: Remote branch release/4.3 not found in upstream origin

$ git clone -b release/4.3 https://github.com/tvheadend/tvheadend.git
#6

Updated by saen acro 6 months ago

Norbert Essl wrote:

I can't finde 4.3 on github. Following command returns:

just clone master until Flole Systems put new tag sometime in feature.

git clone https://github.com/tvheadend/tvheadend.git

#7

Updated by Flole Systems 6 months ago

It's not just the new tag (which would be 4.4 by the way) but also the entire changes on the build system which are needed I think. Creating that tag and branch is not an issue, but making sure that there are proper 4.4 build created and uploaded to the repository then is more difficult. I don't want everything to stay in a broken state for weeks so I want to make sure I have enough time to go through that process from the beginning to the (sucessfull) end (including any issues I will experience while doing so). I will also contact some of the old maintainers who previously made releases when I am ready and ask for help, they are all super nice people and if they can somehow help I am sure many will do that. Also currently something with the nvidia transcoding is broken and that regression should be fixed aswell before a release.

Long story short: Many excuses to not create the tag right now ;)

#8

Updated by Norbert E. 6 months ago

Well, following didn't work either:

$ git clone https://github.com/tvheadend/tvheadend.git
$ sudo apt install build-essential git libpcre2-dev pkg-config libssl-dev bzip2 wget libavahi-client-dev zlib1g-dev libavcodec-dev libavutil-dev libavformat-dev libswscale-dev libavresample-dev gettext cmake libiconv-hook-dev liburiparser-dev debhelper libcurl4-gnutls-dev 
$ cd tvheadend
$ ./Autobuild.sh

Last line (./Autobuild.sh) provide following results:

[email protected]:~/tvheadend $ ./Autobuild.sh
On branch master
Your branch is up to date with 'origin/master'.

nothing to commit, working tree clean
dpkg-buildpackage: info: source package tvheadend
dpkg-buildpackage: info: source version 4.3-1923~gaaca05cc1
dpkg-buildpackage: info: source distribution unstable
dpkg-buildpackage: info: source changed by Andreas Ă–man <[email protected]>
dpkg-buildpackage: info: host architecture armhf
 dpkg-source --before-build .
dpkg-checkbuilddeps: error: Unmet build dependencies: libdvbcsa-dev
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)

#9

Updated by saen acro 6 months ago

https://tvheadend.org/boards/4/topics/24116

simple searching allways help

#10

Updated by Norbert E. 6 months ago

I've followed the instructions there, and following errors still show up after Autobuild:

make[5]: *** [Makefile:200: vpx_dsp/arm/intrapred_neon_asm.asm.S.o] Error 1
make[4]: *** [Makefile:17: .DEFAULT] Error 2
make[4]: Leaving directory '/home/pi/tvheadend/build.linux/ffmpeg/libvpx-1.9.0'
make[3]: *** [Makefile.ffmpeg:330: /home/pi/tvheadend/build.linux/ffmpeg/libvpx-1.9.0/.tvh_build] Error 2
make[3]: Leaving directory '/home/pi/tvheadend'
make[2]: *** [Makefile:853: /home/pi/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libavcodec.a] Error 2
make[2]: Leaving directory '/home/pi/tvheadend'
make[1]: *** [debian/rules:15: override_dh_auto_build] Error 2
make[1]: Leaving directory '/home/pi/tvheadend'
make: *** [debian/rules:6: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

Wasn't able to find anything how to fix it in the MANUAL mentioned above.

#11

Updated by g siviero 6 months ago

I usually disable static_ffmpeg on the PI (I don't use transcoding on the PI):

sudo AUTOBUILD_CONFIGURE_EXTRA=--disable-libx265\ --disable-pie\ --disable-libvpx\ --disable-ffmpeg_static ./Autobluid.sh

#12

Updated by Norbert E. 6 months ago

Strange, it says autobuild command not found:

[email protected]:~ $ sudo AUTOBUILD_CONFIGURE_EXTRA=--disable-libx265\ --disable-pie\ --disable-libvpx\ --disable-ffmpeg_static ./Autobuild.sh
sudo: ./Autobuild.sh: command not found
#13

Updated by saen acro 6 months ago

Norbert Essl wrote:

Strange, it says autobuild command not found:

[...]

Go to directory where clone tvh repo.

#14

Updated by Norbert E. 6 months ago

Autobuild finished wihtout major errors. But I'm still on version 4.2.8
Any idea why that might be? (I did reboot after Autobild was finished)

[email protected]:~ $ tvheadend -v
tvheadend: version 4.2.8-34~g24a2f59e9
#15

Updated by g siviero 6 months ago

Did you install the package (sudo dpkg -i ...)?

#16

Updated by Norbert E. 6 months ago

How should the command look exactly? Where do I get the name of the package from? (The one mentioned in the manual (see below) looks to be for an old version(4.1))

sudo dpkg -i tvheadend_4.1-2398~gc38af4c_amd64.deb

#17

Updated by Norbert E. 6 months ago

I guess I figured it out. Last part of ./Autobuild.sh provides:

doozer-versioned-artifact:/home/pi/tvheadend/../ *tvheadend_4.3-1923~gaaca05cc1_armhf.deb* :deb:application/x-deb:tvheadend_4.3-1923~gaaca05cc1_armhf.deb
doozer-versioned-artifact:/home/pi/tvheadend/../tvheadend-dbg_4.3-1923~gaaca05cc1_armhf.deb:deb:application/x-deb:tvheadend-dbg_4.3-1923~gaaca05cc1_armhf.deb
doozer-versioned-artifact:/home/pi/tvheadend/../tvheadend_4.3-1923~gaaca05cc1_armhf.changes:changes:text/plain:tvheadend_4.3-1923~gaaca05cc1_armhf.changes

But still when using this version, I get an error:

[email protected]:~/tvheadend $ sudo dpkg -i *tvheadend_4.3-1923~gaaca05cc1_armhf.deb*
*dpkg: error: cannot access archive 'tvheadend_4.3-1923~gaaca05cc1_armhf.deb': No such file or directory*
#18

Updated by Norbert E. 5 months ago

Any idea anyone?

#19

Updated by Norbert E. 5 months ago

I managed to upgrade to new version:

[email protected]:~ $ tvheadend -v
tvheadend: version 4.3-1923~gaaca05cc1

But now Tvheadend log gives following error message every second:

2021-02-19 19:43:01.344 tvhpoll: epoll del failed [No such file or directory]
#20

Updated by Flole Systems 5 months ago

  • Status changed from Invalid to New
  • Found in version changed from 4.2.8-34 to 4.3-1923~gaaca05cc1
#21

Updated by Norbert E. 5 months ago

Also:

When switching to certain channels, I get continuity counter errors (examples see below) and channel does not start playing. When stopping channel and turning it on again, it works without errors most of the time.

2021-02-20 10:19:48.269 TS: DVB-S Network/11303H/ORF1 HD: AC3 #1921 Continuity counter error (total 1)
...
2021-02-20 10:21:08.235 TS: DVB-S Network/11303H/ServusTV HD Oesterreich: H264
#3583 Continuity counter error (total 1)
...
2021-02-20 10:33:39.658 TS: DVB-S Network

#22

Updated by Flole Systems 5 months ago

  • Status changed from New to Invalid

This is a tuner issue and not a Tvheadend issue. Either find some workaround settings (like skipping TS packets) or get a tuner that doesn't send garbage at the beginning.

Also available in: Atom PDF