Project

General

Profile

Bug #5992

Run away process after recorded output goes past 1GB - 100% CPU

Added by Brian Beardmore 11 days ago. Updated 9 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
PVR / DVR
Target version:
-
Start date:
2021-01-13
Due date:
% Done:

0%

Estimated time:
Found in version:
4.2.8
Affected Versions:

Description

When recording a channel the CPU used goes to max after the output of the recorded channel goes past 1GB in size.


Files

TVHead-after1GB.JPG (342 KB) TVHead-after1GB.JPG Brian Beardmore, 2021-01-13 01:05
TVHead-under1GB.JPG (358 KB) TVHead-under1GB.JPG Brian Beardmore, 2021-01-13 01:05

History

#1

Updated by Flole Systems 11 days ago

  • Status changed from New to Invalid

Bug reports for version 4.2 are no longer accepted. Please use latest master.

#2

Updated by Brian Beardmore 11 days ago

Version 4.2.8 is the newest package available for FreeBSD

#3

Updated by Flole Systems 11 days ago

Then you need to contact the maintainer of that package anyways if you are using an unofficial build as they know best what kind of changes they made and what issues that might cause. Maybe they decide to build latest versions aswell then. Or you can always compile from source.

#4

Updated by Brian Beardmore 9 days ago

I am unable to reproduce the problem with a similar setup and the same hardware. Both Debian10 and Ubuntu20 where setup with TVheadend v4.2.8~g5bdcfd8ac, and neither caused the CPU to max out when recording a file past 1GB in size.

An attempt to build TVheadend on FreeBSD was not successful. No guidance was found for the build on FreeBSD OS, and many dependences source files are missing and needed dependences libraries are also not found for FreeBSD OS.

Also available in: Atom PDF