Project

General

Profile

Bug #5991

Tvheadend broken by upgrade on Raspberry Pi 3

Added by David Rayner 12 days ago. Updated 12 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-01-12
Due date:
% Done:

0%

Estimated time:
Found in version:
4.2.8-34~g24a2f59e9
Affected Versions:

Description

Last December I had Tvheadend running flawlessly on a Raspberry Pi 3 running Raspberry Pi OS Lite (Release date: December 2nd 2020, Kernel version: 5.4). The Tvheadend version was 4.2.8-34~g24a2f59e9, downloaded using apt from the Rasberry repository. Tvheadend stopped working last week, the primary symptom being an inability to play live TV fed from an HDhomerun OTA tuner. I tried resetting Tvheadend by deleting the config in /home/hts/. hts/tvheadend and later by reinstalling from scratch. In both cases the set up fails at the point where the the tuner is scanned for available channels. The scan jumps from 0% to 100% in a few seconds and reports no channels found. Suspecting the problem may have been related to an upgrade I made through the repository to the Raspberry OS I started from the beginning again by reinstalling the December 2 Raspberry Pi OS release and installing Tvheadend without applying any upgrades. Under these conditions Tvheadend installs, configures and performs perfectly. I have since reconfirmed that if I apply the upgrade to a fresh OS installation before installing Tvheadend, Tvheadend does not find any channels.
The packages that the upgrade applies to are:
apt apt-utils base-files distro-info-data libapt-inst2.0 libapt-pkg5.0
libjpeg62-turbo libp11-kit0 libpam-systemd libpolkit-agent-1-0
libpolkit-backend-1-0 libpolkit-gobject-1-0 libraspberrypi-bin
libraspberrypi-dev libraspberrypi-doc libraspberrypi0 libsqlite3-0 libssl1.1
libsystemd0 libudev1 libxml2 openssl policykit-1 python-apt-common
python-rpi.gpio python3-apt raspberrypi-bootloader raspberrypi-kernel
rpi-eeprom rpi.gpio-common systemd systemd-sysv tzdata udev

History

#1

Updated by Flole Systems 12 days ago

  • Status changed from New to Invalid

Bug reports for 4.2 are no longer accepted. Use latest master.

Also available in: Atom PDF