Project

General

Profile

Bug #5944

crash against latest media-tree?

Added by th0ma7 ^ about 2 months ago. Updated about 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Crashes
Target version:
-
Start date:
2020-08-25
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3~ce09077
Affected Versions:

Description

I've been hitting a crash with the latest snapshot of the media-tree (for details see thread at https://www.spinics.net/lists/linux-media/msg175724.html)

Interestingly the bug is triggerred "by" tvheadend while not necessarely being the root-cause neither:
[42655.375808] kernel tried to execute NX-protected page - exploit attempt? (uid: 276776)
[42655.384655] BUG: unable to handle kernel paging request at ffff8803f8e18000
...
[42658.950335] note: tvheadend[21050] exited with preempt_count 1

Today tvheadend crashed for apparently no reason on my box and generated a 2.5Gb dump. Interestingly, I'm exclusively running TVH against dual/quad hdhomerun but I had a few high-level media-tree kernel modules loaded in memory, although nothing related tuners or dvbs (e.g. only had rc-core.ko, mc.ko, videodev.ko, tveeprom.ko, videobuf2-*.ko).

I'm running the latest TVH github snapshot (4.3~ce09077) provided through SynoCommunity on apollolake Intel 64-bit arch (and I'm the SynoCommunity package maintainer as wel) and has been really stable for me in the past months up until playing with the media-tree in the last two days.

Question is: I'm seeking advice as to could tvheadend have an incompatibility of some sort with OR trigering an existing flaw/flacky code from the latest media-tree snapshot.

Thnx in advance.

History

#1

Updated by Flole Systems about 2 months ago

You are using a third party repository/unofficial build. All issue reports should be made to the maintainer of that repository. As you are the maintainer you should make sure there is a bug tracker or another way to report issues. We are often getting reports here from unofficial builds. Unfortunately we don't have the time and resources to provide support for those builds as there are way to many and some of those contain changes that are just begging for issues.

That means for this case: Reproduce it on a clean install from the latest master, then this can be properly tracked as a bug.

#2

Updated by th0ma7 ^ about 2 months ago

The download page recommends 3rd party builds for Synology NAS pointing syno.dierkse.nl (who didn't released anything in years) and SynoCommunity which is exactly the version I now maintain since over a year (previous maintainer left since). Issues found by our SynoCommunity users are generally being reported on the spksrc official github project page. When I'm unable to find answers, I tried, as package maintainer, to reach out to you for help & advices but I now understand there is no intention at providing support due to lack of time & resources, and I get that. What would be missing or is there any way to make SynoCommunity builds to becomes officially supported? I believe this provides great visibility and benefits to the tvheadend project & community.

Otherwise, for greather clarity, another suggestion is to slightly reword the sentence in the download page "For other systems we don't currently maintain official packages... " or removing Synology NAS references all together.

Advices/guidance/thoughts welcomed.

#3

Updated by Flole Systems about 2 months ago

In order to get it supported (or in general to actually make progress) we need developers. If we get more developers there will be more resources and we can support more targets, right now not even for the official builds bugs are found and easily fixed.

Of course you can report issues that you found in some 3rd party build in here aswell (as you might've noticed I didn't close this issue) but unfortunately there is nobody actively looking into issues here (and just a few people who are providing help/support). So if we can send someone to another place to report issues that is helpful and chances that someone looks into an issue there are higher (plus they are familiar with whatever changes they might've done).

If we get more developers all of that is going to change obviously, but I don't know how we can attract more people who are willing to get familiar with the codebase and want to help move this project forward.

Also available in: Atom PDF