Project

General

Profile

Bug #5941

weird satip behavior on ATSC-T channels

Added by catalin toda 3 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-08-15
Due date:
% Done:

0%

Estimated time:
Found in version:
ce09077056f9c6558c188d135cec3be85cc9c200
Affected Versions:

Description

Support for minisatip and tvheadend for ATSC-T was added a while back. While playing directly from tvheadend works good, while using satip there is strange behavior: tvh keeps switching between pids=all and adding individual pids while continuously playing a channel.

The log resulted from the command:
./build.linux/tvheadend -d --trace all 2>&1 | tee /tmp/tvh.log

is attached here. Basically check for pids=all and pids=0,1,48,49,52,53 which should not happen.

I am using the master from today:
commit ce09077056f9c6558c188d135cec3be85cc9c200 (HEAD -> master, origin/master, origin/HEAD)


Files

tvh.log (4.7 MB) tvh.log catalin toda, 2020-08-15 21:56
tvh1.log (16.2 MB) tvh1.log catalin toda, 2020-08-15 22:00
tvh_satip.log (53 KB) tvh_satip.log catalin toda, 2020-08-21 08:40
m.log (814 KB) m.log catalin toda, 2020-08-21 08:40

History

#1

Updated by catalin toda 3 months ago

This seems consistent actually with the behavior without satip. Log for dvb only attached here.

#2

Updated by Flole Systems 2 months ago

You are using a satip client and then it's switching between pids=all and a range of pids? Also your logs contain many unnecessary categories, it's super hard to read those. Only enable the satip client and server trace please (assuming that my assumption in my first sentence is correct).

#3

Updated by catalin toda 2 months ago

Attached are minisatip logs and tvh satip trace.

Also available in: Atom PDF