Project

General

Profile

Bug #5902

TVH crash if htsp client (KODI) connects

Added by Nihil Baxter 14 days ago. Updated 9 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Crashes
Target version:
-
Start date:
2020-05-20
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1875~g1c67c04c8
Affected Versions:

Description

I have strange behavior with latest builds while Kodi connecting with server. If Kodi tries to connect, tvh crashes everytime (tvheadend.service: Failed with result 'signal'). In system log i see Kodi client connecting, nothing more.
I could get it working again, if i delete all files from /logs directory, after restart all my future recordings (with autorecord) are set again, so not a big problem, but older recordings are not listed after that. After installing newer build the problem is back and i have to delete logs again.
Never seen that before, so maybe latest builds changed something in log format?


Files

gdb.txt (106 KB) gdb.txt Nihil Baxter, 2020-05-22 23:50

Related issues

Is duplicate of Bug #5844: Invalid value in duration field of recording will crash TVHNew2020-01-13

Actions

History

#1

Updated by Flole Systems 14 days ago

Provide a stacktrace, otherwise there is no way to investigate the issue.

#2

Updated by Nihil Baxter 14 days ago

OK, maybe i try to manage that with next build, for now i'm happy to get it running again. I'm not very familiar with getting debug traces and have to check out what to do ;-)
But maybe someone is able to reproduce that issue...otherwise it could be my setup (btw., i did a fresh config before i found whats causing crash and workaround)

#3

Updated by Flole Systems 13 days ago

It should dump a stacktrace straight into syslog if you are using that. The wiki contains more information about all that.

#4

Updated by Nihil Baxter 12 days ago

OK, i was able to get a trace after upgrade to new build, used wiki, set all debug-subsystems i could get, looked at the logfile.....and found this last columns:

...
2020-05-22 14:56:34.181 [   INFO]:htsp: 192.168.0.1: Welcomed client software: Kodi Media Center (HTSPv34)
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 3218c82355658a04802d09a193360626 class profile
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node c6611e651920fd622363de3d8fbdfc3c class profile
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node aa57fd652c999e0754a5c74464e64e6b class profile
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node e0779d505330f09a6110c03d21c53cb5 class profile
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 6cf4acb291baec681b984374aef8ca1d class profile
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node e82b169ffb3bed7caeaec516bff69f7e class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node fbda283dfa2fe3e971df67fe510eb3b4 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 34f02d185e320d413e60fd9a9e3c3e96 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 29d2f986f78309a3f9d2f2dde03c3f31 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 00733bb4c392e179fc1213cfde2a40c7 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node dfc0ac9d5c9d6bf9a8d87b8d828df901 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 924ef5add59f14dc5186d2167fbf2a07 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node f4b05afbd2e27787801e1e5422c5f854 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node b17aae7274099455d171bea38acb2d86 class dvrconfig
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node b8a7295b7c879d14455a7190e5372ab6 class channeltag
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 6165746fd48c020e9284ad1832702a4f class channeltag
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 75d8fe882df089c7eb46149004a459cf class channeltag
2020-05-22 14:56:34.184 [  TRACE]:idnode: find node 7203425bca3c1314779fa793c4fb4ec5 class channeltag
2020-05-22 14:56:34.184 [   INFO]:htsp: 192.168.0.1 [ Kodi Media Center ]: Identified as user 'xxx'
2020-05-22 14:56:34.184 [  TRACE]:htsp: 192.168.0.1 [ xxx | Kodi Media Center ] - method authenticate
2020-05-22 14:56:34.191 [  TRACE]:htsp: 192.168.0.1 [ xxx | Kodi Media Center ] - method enableAsyncMetadata

Btw, after last row TVH crashes and is not working with kodi, until i delete all last dvr logs.
Did i miss something? Maybe there is some debugging option i needed or some other method to give you needed data?
Cant help with getting bugs if i don't know why ;-)

#5

Updated by Flole Systems 12 days ago

You need to get the stacktrace of the crash, see the Wiki for details.

#6

Updated by Nihil Baxter 12 days ago

So its not enough to install dbg package, set logfile, Debug- and Trace subsystems within web gui and reproduce the crash?
Thats what i did...

#7

Updated by Flole Systems 12 days ago

No, you need to find the backtrace which is somewhere else, probably in syslog. You can also use gdb to start tvheadend and then reproduce the crash and then type "bt full" to get it.

#8

Updated by Nihil Baxter 12 days ago

So here it is, gdb did it...i hope that is what you need...

#9

Updated by Flole Systems 10 days ago

Yes thats the right stacktrace.

The crash is an "expected" abort caused by an invalid value that shouldn't be there.

Does it only occur when you use the old files or also when you have a recording create new files?

#10

Updated by Nihil Baxter 10 days ago

Seems it only occurs if installing new build.
Start>record>start kodi >ok
Install new build with old recording present>fail
Delete all in dvr/logs>restart tvh>works.
will test with more recordings... New build will not installed as i'm on buster now, older build of tvh but same problem

#11

Updated by Flole Systems 9 days ago

  • Is duplicate of Bug #5844: Invalid value in duration field of recording will crash TVH added
#12

Updated by Flole Systems 9 days ago

  • Status changed from New to Invalid
#13

Updated by Flole Systems 9 days ago

Duplicate, please follow the other Issue Report for more details.

Also available in: Atom PDF