Project

General

Profile

Bug #5878

Playlist downloaded through proxy server contains wrong URL

Added by Łukasz Dymek 10 months ago. Updated 10 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2020-04-24
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1857~g221c29b
Affected Versions:

Description

Hi,

I have nginx with Tvheadend 4.3-1857~g221c29b, but TVH version did not matter, on 4.2 situation is the same. I have checked Proxy setting in TVH, and setup correct name for the origin. But when I download m3u playlist via proxy server wrong URL's are inside:

http://backend_tvh/stream/channelid....

backend_tvh variable is showing up instead of correct hostname

History

#1

Updated by saen acro 10 months ago

This is not a bug of TVH, it's something wrong with NGINX configuration.
Use forum to ask how to fix it.

#2

Updated by Łukasz Dymek 10 months ago

yes, found it, the bug in cofiguration was:

@ upstream upstream_tvh -- this should be changed to domain name { # the Netdata server
server 127.0.0.1:9981;
keepalive 64;
}

server { # nginx listens to this

  1. the virtual host name of this
    server_name gate.coric.pl;
location / {
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection "upgrade";
proxy_pass http://backend_tvh -- this should be changed also ;
proxy_http_version 1.1;
proxy_pass_request_headers on;
proxy_store off;
}

@

thanks, shouldn't create ticket for this...

#3

Updated by Flole Systems 10 months ago

  • Status changed from New to Invalid

Also available in: Atom PDF