Bug #5858

Some services are hidden when hide: "parent disabled" option selected, but there's no reason for it (no mux, no network disabled)

Added by Petr D. over 1 year ago. Updated about 1 month ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Found in version:
HTS Tvheadend 4.3-1857~g221c29b40
Affected Versions:


I have HTS Tvheadend 4.3-1857~g221c29b40 in docker container build by Its running on Pi4 1GB inside LibreElec 9.2.
After installation I've added a network, selected predefined muxes (all-Czech republic). Asigned tuner to network and let it scan.
There is 80 muxes (none disabled, none hidden by "parent disabled" selection).
About 10 services is "scan result: ok", services found. Rest is "scan result: failed" (normal result so far)
Some of the services however are marked as "parent disabled", so they are hidden in default services view.
If I select hide:none, they are shown.
I guess this services are evaluated wrong as "parent disabled".
These services are ignored by automatic mapper.
These services cannot be played, result in a log:

2020-02-16 19:47:55.761 http: using ticket 0b235dd4e4ab91d767ecf3bb5394bdb87d0b0d3f for /stream/service/1f876f1a618c1a656bdb4d98059ddb3d
2020-02-16 19:47:57.761 subscription: 0131: No input source available for subscription "HTTP" to service "cz/594MHz/CT 1 HD T2" in mux "594MHz in cz" 
2020-02-16 19:47:57.761 webui: Couldn't start streaming /stream/service/1f876f1a618c1a656bdb4d98059ddb3d?ticket=0b235dd4e4ab91d767ecf3bb5394bdb87d0b0d3f, No service enabled

In HTS Tvheadend v. 4.2... running as a native Libreelec addon there's no such problem.



Updated by g siviero over 1 year ago

I also have a similar problem, a similar issue (Bug #4929) should already be open.
At the moment my workaround is to (temporarily) reduce the value "Maximum PIDs" from configuration-> DVB Inputs -> TV Adapters and rescan the frequencies.
Reduce to which value? Until the scan shows correctly all missing services.


Updated by Petr D. over 1 year ago

Thanks for the hint! It worked, I've decreased max PID value somewhere to 26 and now it works.


Updated by Flole Systems about 1 year ago

  • Status changed from New to Invalid

Updated by D B about 1 month ago

This is still an issue.

I had to decreased my PID from 32 > 20 to stop weird behavior, services not mapping and 'parent disabled'


Updated by D B about 1 month ago

The PID i think is a red herring.

It seems to randomly decide when a service parent is hidden and therefore mappable.

I seem to get more success from restarts and re-scanning than I do any of the settings. Plenty still unavailable to map

Also available in: Atom PDF