Project

General

Profile

Bug #5857

Aspect Ratio issue using Video Codec h264_omx

Added by David G 11 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Category:
Transcoding
Target version:
-
Start date:
2020-02-15
Due date:
% Done:

0%

Estimated time:
Found in version:
HTS Tvheadend 4.2.8-36~g5bdcfd8ac
Affected Versions:

Description

I am using stable "HTS Tvheadend 4.2.8-36~g5bdcfd8ac" on a Raspberry PI4, Buster OS.

I am trying to use the hardware accelerated video codec "h264_omx: OpenMAX IL H.264 video encoder" with DVB-T/2 output from the RPI Top Hat, but experience problems with aspect ratio on all SD channels.

For example, these channels playback in 4:3 rater than 16:9;

2020-02-15 08:14:56.763 transcode: 001F: 1:MPEG2VIDEO 544x576 ==> H264 544x576 (h264_omx) ----- (4MUSIC)
2020-02-15 08:18:32.380 transcode: 0020: 1:MPEG2VIDEO 704x576 ==> H264 704x576 (h264_omx) ----- (BBC ONE)
2020-02-15 08:20:00.663 transcode: 0021: 1:MPEG2VIDEO 720x576 ==> H264 720x576 (h264_omx) ----- (Channel 4)
2020-02-15 08:21:11.520 transcode: 0022: 1:MPEG2VIDEO 720x576 ==> H264 720x576 (h264_omx) ----- (Channel 4+1)
2020-02-15 08:27:19.572 transcode: 0023: 1:MPEG2VIDEO 544x576 ==> H264 544x576 (h264_omx) ----- (Sky News)
2020-02-15 08:29:24.930 transcode: 0024: 1:MPEG2VIDEO 720x576 ==> H264 720x576 (h264_omx) ----- (ITV)

How can this codec be changed to display correctly at 16:9 please?

By the way, if I use the Video codec "libx264: libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10", the aspect ratio is correct.

For completeness, I attach the TVH log.


Files

TVH Log.txt (6.68 KB) TVH Log.txt David G, 2020-02-15 12:32

History

#1

Updated by Flole Systems 11 months ago

You should upgrade to the latest master and not use some old version that is lacking many fixes when you file a bug report.

#2

Updated by David G 11 months ago

I agree and have tried the latest master from the apt, and even compiling my own, (tvheadend_4.3-1801_g7f952c2ed) before raising this issue. Unfortunately the unstable RPI builds do not have any working video codecs and so I have to use the latest master stable build.

#3

Updated by saen acro 11 months ago

4.3.1857 is latest.

#4

Updated by David G 11 months ago

Apologies, my typo, my post above should have said 4.3.1857 which as no RPI Video Codecs.

#5

Updated by Flole Systems 11 months ago

Are you sure that the requirements were satisfied during compilation and did you use the necessary flags to enable them?

If they were indeed removed there is probably a good reason for that...

#6

Updated by saen acro 11 months ago

https://tvheadend.org/boards/4/topics/24116
if there is more decency packages post there

#7

Updated by David G 11 months ago

Flole Systems, I believe your right, there must be a good reason why the RPI build has had this functionality removed. Yes, I have spent literally days, with saen's help also, trying the options to get transcoding working in my own builds, all without success. I've even tried builds compiled by others, same negative result. From reading other messages, it seems to have been this way for awhile now with the unstable master, which is a shame. I hope it gets resolved soon.

Until then, I'm stuck using the master stable version which works well apart from this issue raised, to improve the h264_omx Video codec.

#8

Updated by Andreas Fornberg 2 months ago

I have same problem here with my MiBox 3 but that's probably a driver issue or maybe Kodi version for Android?
On my RPi3 & RPi4 it works as it should.
An option to change 4:3 or other ratios to 16:9 on TVheadend server would be nice for channels.

#9

Updated by Flole Systems 2 months ago

You are running Tvheadend on a MiBox3 and are using h264_omx for encoding on that? I didn't know that was possible. And on a raspberry it works? That's really weird....

Anyways, you should use the Tvheadend HTSP Kodi addon, then there's no transcoding and it should work.

Also available in: Atom PDF