Project

General

Profile

Bug #5854

Tuner LNA cannot be turned off

Added by Marek Czerski 10 months ago. Updated 10 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-02-10
Due date:
% Done:

0%

Estimated time:
Found in version:
master
Affected Versions:

Description

Hi all,

this is my first post on this forum :)

So I'm using Tvheadend 4.2.7-44 installed from KODI LibreELEC addons. And I'm trying to turn on/off the lna on my dvb-t tuner through web interface.

Turning on works, but the behaviour is not very intuitive because to actually apply the new settings of the LNA I need to re-tune by changing currently viewed channel. And this I figured out by looking at the source code of the tvheadend so at least some sort of information how to apply those settings should be visible.

The big problem is with turning off because there is no way to do that. I need to restart the tuner driver which disables LNA at initialisation. Looking at the tvheadend code there is:

   if (lfe->lfe_lna)
      S2CMD(DTV_LNA, 1);

and there is no else branch. So there is nothing in the code that handles lfe->lfe_lna == 0 case.

History

#1

Updated by Flole Systems 10 months ago

This is not a Forum but a bug tracker.

I'm a little confused about your versions: You wrote master but mentioned 4.2 (which is as far away from master as it could possibly be).

#2

Updated by Marek Czerski 10 months ago

Confusing in deed :)

I'm using 4.2 for testing, The code I pasted is in 4.2 and on master. Nothing changed in this matter between 4.2 and master. So I guess that it should be Found in version: 4.2, Affected Versions:>=4.2 ?

Also available in: Atom PDF