Project

General

Profile

Bug #5762

Crash when subscribing to two HD channels simultaneously

Added by Dennis Luxen 7 months ago. Updated 18 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Crashes
Target version:
-
Start date:
2019-10-31
Due date:
% Done:

0%

Estimated time:
Found in version:
v4.3-1850-g912078267
Affected Versions:

Description

happens on current master as of writing, i.e. v4.3-1850-g912078267, when subscribing to two HD channels and transcoding them.

2019-10-31 19:40:48.632 [WARNING]:epggrab: EIT: EPG Grabber - data completion timeout for 130MHz in Unitymedia
2019-10-31 19:40:48.632 [   INFO]:subscription: 0020: "epggrab" unsubscribing
2019-10-31 19:40:49.633 [   INFO]:mpegts: 434MHz in Unitymedia - tuning on SAT>IP DVB-C Tuner #2 ([email protected])
2019-10-31 19:40:49.633 [   INFO]:subscription: 0022: "epggrab" subscribing to mux "434MHz", weight: 4, adapter: "SAT>IP DVB-C Tuner #2 ([email protected])", network: "Unitymedia", service: "Raw PID Subscription" 
2019-10-31 19:40:57.535 [   INFO]:mpegts: 114MHz in Unitymedia - tuning on SAT>IP DVB-C Tuner #2 ([email protected])
2019-10-31 19:40:57.535 [   INFO]:subscription: 0022: "epggrab" unsubscribing
2019-10-31 19:40:57.535 [   INFO]:subscription: 0024: "HTTP" subscribing on channel "PHOENIX HD", weight: 100, adapter: "SAT>IP DVB-C Tuner #2 ([email protected])", network: "Unitymedia", mux: "114MHz", provider: "Unitymedia", service: "PHOENIX HD", profile="webtv-h264-aac-matroska", hostname="192.168.179.24", username="dennis", client="TvhClient/883 LibVLC/3.0.7" 
2019-10-31 19:40:57.919 [   INFO]:transcode: 0004: 01:H264: ==> Using profile webtv-h264vaapi
2019-10-31 19:40:57.919 [   INFO]:transcode: 0004: 02:MPEG2AUDIO: ==> Using profile webtv-aac
2019-10-31 19:40:57.919 [   INFO]:transcode: 0004: 03:MPEG2AUDIO: ==> Filtered out
2019-10-31 19:41:15.378 [  ALERT]:CRASH: Signal: 11 in PRG: /usr/bin/tvheadend (4.3-1850~g912078267) [619794756dd8ce66625493a1beedc9258e47df53] CWD: /  
2019-10-31 19:41:15.378 [  ALERT]:CRASH: Fault address 0x20 (Address not mapped)
2019-10-31 19:41:15.378 [  ALERT]:CRASH: Loaded libraries: linux-vdso.so.1 /usr/lib/x86_64-linux-gnu/libdvbcsa.so.1 /usr/lib/x86_64-linux-gnu/libssl.so.1.1 /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 /lib/x86_64-linux-gnu/libz.so.1 /usr/lib/x86_64-linux-gnu/libpcre2-8.so.0 /usr/lib/x86_64-linux-gnu/liburiparser.so.1 /usr/lib/x86_64-linux-gnu/libavahi-common.so.3 /usr/lib/x86_64-linux-gnu/libavahi-client.so.3 /usr/lib/x86_64-linux-gnu/libva.so.2 /lib/x86_64-linux-gnu/libdbus-1.so.3 /lib/x86_64-linux-gnu/libdl.so.2 /lib/x86_64-linux-gnu/libpthread.so.0 /lib/x86_64-linux-gnu/libm.so.6 /lib/x86_64-linux-gnu/libmvec.so.1 /lib/x86_64-linux-gnu/libbz2.so.1.0 /usr/lib/x86_64-linux-gnu/libstdc++.so.6 /usr/lib/x86_64-linux-gnu/libnuma.so.1 /usr/lib/x86_64-linux-gnu/libva-drm.so.2 /lib/x86_64-linux-gnu/libc.so.6 /lib/x86_64-linux-gnu/libsystemd.so.0 /lib64/ld-linux-x86-64.so.2 /lib/x86_64-linux-gnu/libgcc_s.so.1 /usr/lib/x86_64-linux-gnu/libdrm.so.2 /lib/x86_64-linux-gnu/librt.so.1 /lib/x86_64-linux-gnu/liblzma.so.5 /usr/lib/x86_64-linux-gnu/liblz4.so.1
2019-10-31 19:41:15.378 [  ALERT]:CRASH: Register dump [23]: 000000000000014000000000000002d00000000000000140000000000000024600000000000001400000000000000000000000000000000000007fd6e8468a00000000000000000000007fd7079fb16800000000000002d000007fd74010ce7000007fd7079fb16c00000000000002d0000000000000000000007fd7079fb14800007fd78400b9e40000000000010206002b0000000000330000000000000004000000000000000efffffffe7ffbba130000000000000020
2019-10-31 19:41:15.378 [  ALERT]:CRASH: STACKTRACE
2019-10-31 19:41:15.441 [  ALERT]:CRASH: ??:0 0x5621a217df01 0x5621a1f50000
2019-10-31 19:41:15.501 [  ALERT]:CRASH: ??:0 0x7fd785c63540 0x7fd785c4e000
2019-10-31 19:41:15.501 [  ALERT]:CRASH: drm_intel_bo_get_tiling+0x4  (/usr/lib/x86_64-linux-gnu/libdrm_intel.so.1)
2019-10-31 19:41:15.562 [  ALERT]:CRASH: ??:0 0x7fd776cb8342 0x7fd776c38000
2019-10-31 19:41:15.621 [  ALERT]:CRASH: ??:0 0x7fd776cbcf67 0x7fd776c38000
2019-10-31 19:41:15.681 [  ALERT]:CRASH: ??:0 0x7fd776cb73a8 0x7fd776c38000
2019-10-31 19:41:15.742 [  ALERT]:CRASH: ??:0 0x7fd776cbdcb0 0x7fd776c38000
2019-10-31 19:41:15.742 [  ALERT]:CRASH: vaEndPicture+0x45  (/usr/lib/x86_64-linux-gnu/libva.so.2)
2019-10-31 19:41:15.807 [  ALERT]:CRASH: ??:0 0x5621a22a0297 0x5621a1f50000
2019-10-31 19:41:15.872 [  ALERT]:CRASH: ??:0 0x5621a2293485 0x5621a1f50000
2019-10-31 19:41:15.932 [  ALERT]:CRASH: ??:0 0x5621a229e9dd 0x5621a1f50000
2019-10-31 19:41:15.996 [  ALERT]:CRASH: ??:0 0x5621a228e4b0 0x5621a1f50000
2019-10-31 19:41:16.060 [  ALERT]:CRASH: ??:0 0x5621a228e6ff 0x5621a1f50000
2019-10-31 19:41:16.121 [  ALERT]:CRASH: ??:0 0x5621a226909c 0x5621a1f50000
2019-10-31 19:41:16.187 [  ALERT]:CRASH: ??:0 0x5621a2269181 0x5621a1f50000
2019-10-31 19:41:16.247 [  ALERT]:CRASH: ??:0 0x5621a2269ecb 0x5621a1f50000
2019-10-31 19:41:16.306 [  ALERT]:CRASH: ??:0 0x5621a22672a5 0x5621a1f50000
2019-10-31 19:41:16.366 [  ALERT]:CRASH: ??:0 0x5621a226a96c 0x5621a1f50000
2019-10-31 19:41:16.430 [  ALERT]:CRASH: ??:0 0x5621a21c2cfe 0x5621a1f50000
2019-10-31 19:41:16.493 [  ALERT]:CRASH: ??:0 0x5621a219d6dc 0x5621a1f50000
2019-10-31 19:41:16.552 [  ALERT]:CRASH: ??:0 0x5621a213c962 0x5621a1f50000

Anything else I could provide to debug/fix this issue?

History

#1

Updated by Dennis Luxen 7 months ago

Using the debug package:

2019-10-31 19:52:36.834 [  ALERT]:CRASH: Signal: 11 in PRG: /usr/bin/tvheadend (4.3-1850~g912078267) [619794756dd8ce66625493a1beedc9258e47df53] CWD: /  
2019-10-31 19:52:36.834 [  ALERT]:CRASH: Fault address 0x20 (Address not mapped)
2019-10-31 19:52:36.834 [  ALERT]:CRASH: Loaded libraries: linux-vdso.so.1 /usr/lib/x86_64-linux-gnu/libdvbcsa.so.1 /usr/lib/x86_64-linux-gnu/libssl.so.1.1 /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 /lib/x86_64-linux-gnu/libz.so.1 /usr/lib/x86_64-linux-gnu/libpcre2-8.so.0 /usr/lib/x86_64-linux-gnu/liburiparser.so.1 /usr/lib/x86_64-linux-gnu/libavahi-common.so.3 /usr/lib/x86_64-linux-gnu/libavahi-client.so.3 /usr/lib/x86_64-linux-gnu/libva.so.2 /lib/x86_64-linux-gnu/libdbus-1.so.3 /lib/x86_64-linux-gnu/libdl.so.2 /lib/x86_64-linux-gnu/libpthread.so.0 /lib/x86_64-linux-gnu/libm.so.6 /lib/x86_64-linux-gnu/libmvec.so.1 /lib/x86_64-linux-gnu/libbz2.so.1.0 /usr/lib/x86_64-linux-gnu/libstdc++.so.6 /usr/lib/x86_64-linux-gnu/libnuma.so.1 /usr/lib/x86_64-linux-gnu/libva-drm.so.2 /lib/x86_64-linux-gnu/libc.so.6 /lib/x86_64-linux-gnu/libsystemd.so.0 /lib64/ld-linux-x86-64.so.2 /lib/x86_64-linux-gnu/libgcc_s.so.1 /usr/lib/x86_64-linux-gnu/libdrm.so.2 /lib/x86_64-linux-gnu/librt.so.1 /lib/x86_64-linux-gnu/liblzma.so.5 /usr/lib/x86_64-linux-gnu/liblz4.so.1
2019-10-31 19:52:36.834 [  ALERT]:CRASH: Register dump [23]: 000000000000014000000000000002d00000000000000140000000000000024600000000000001400000000000000000000000000000000000007f5e3456cc30000000000000000000007f5e6cde7cb800000000000002d000007f5e340c2de000007f5e6cde7cbc00000000000002d0000000000000000000007f5e6cde7c9800007f5e6c1a69e40000000000010206002b0000000000330000000000000004000000000000000efffffffe7ffbba130000000000000020
2019-10-31 19:52:36.834 [  ALERT]:CRASH: STACKTRACE
2019-10-31 19:52:37.030 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/trap.c:176 0x5589ebe4ef01 0x5589ebc21000
2019-10-31 19:52:37.234 [  ALERT]:CRASH: ??:0 0x7f5e7f02a540 0x7f5e7f015000
2019-10-31 19:52:37.234 [  ALERT]:CRASH: drm_intel_bo_get_tiling+0x4  (/usr/lib/x86_64-linux-gnu/libdrm_intel.so.1)
2019-10-31 19:52:37.439 [  ALERT]:CRASH: ??:0 0x7f5dff0bd342 0x7f5dff03d000
2019-10-31 19:52:37.643 [  ALERT]:CRASH: ??:0 0x7f5dff0c1f67 0x7f5dff03d000
2019-10-31 19:52:37.846 [  ALERT]:CRASH: ??:0 0x7f5dff0bc3a8 0x7f5dff03d000
2019-10-31 19:52:38.051 [  ALERT]:CRASH: ??:0 0x7f5dff0c2cb0 0x7f5dff03d000
2019-10-31 19:52:38.051 [  ALERT]:CRASH: vaEndPicture+0x45  (/usr/lib/x86_64-linux-gnu/libva.so.2)
2019-10-31 19:52:38.249 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/build.linux/ffmpeg/ffmpeg-4.1.1/libavfilter/vaapi_vpp.c:319 0x5589ebf71297 0x5589ebc21000
2019-10-31 19:52:38.448 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/build.linux/ffmpeg/ffmpeg-4.1.1/libavfilter/vf_deinterlace_vaapi.c:303 0x5589ebf64485 0x5589ebc21000
2019-10-31 19:52:38.648 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/build.linux/ffmpeg/ffmpeg-4.1.1/libavfilter/avfilter.c:1071 0x5589ebf6f9dd 0x5589ebc21000
2019-10-31 19:52:38.846 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/build.linux/ffmpeg/ffmpeg-4.1.1/libavfilter/buffersrc.c:181 0x5589ebf5f4b0 0x5589ebc21000
2019-10-31 19:52:39.044 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/build.linux/ffmpeg/ffmpeg-4.1.1/libavfilter/buffersrc.c:170 0x5589ebf5f6ff 0x5589ebc21000
2019-10-31 19:52:39.240 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/transcoding/transcode/context.c:364 0x5589ebf3a09c 0x5589ebc21000
2019-10-31 19:52:39.434 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/transcoding/transcode/context.c:418 0x5589ebf3a181 0x5589ebc21000
2019-10-31 19:52:39.631 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/transcoding/transcode/context.c:433 0x5589ebf3aecb 0x5589ebc21000
2019-10-31 19:52:39.829 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/transcoding/transcode/stream.c:125 0x5589ebf382a5 0x5589ebc21000
2019-10-31 19:52:40.025 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/transcoding/transcode/transcoder.c:94 0x5589ebf3b96c 0x5589ebc21000
2019-10-31 19:52:40.220 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/plumbing/tsfix.c:318 0x5589ebe93cfe 0x5589ebc21000
2019-10-31 19:52:40.416 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/parsers/parsers.c:138 0x5589ebe8443d 0x5589ebc21000
2019-10-31 19:52:40.609 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/parsers/parsers.c:1488 0x5589ebe87416 0x5589ebc21000
2019-10-31 19:52:40.803 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/parsers/parsers.c:428 0x5589ebe866c5 0x5589ebc21000
2019-10-31 19:52:40.997 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/parsers/message.c:217 0x5589ebe83763 0x5589ebc21000
2019-10-31 19:52:41.197 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/input/mpegts/tsdemux.c:305 0x5589ebed8fc4 0x5589ebc21000
2019-10-31 19:52:41.392 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/input/mpegts/tsdemux.c:78 0x5589ebed9422 0x5589ebc21000
2019-10-31 19:52:41.587 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/input/mpegts/tsdemux.c:216 0x5589ebed9525 0x5589ebc21000
2019-10-31 19:52:41.786 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/input/mpegts/mpegts_input.c:1526 0x5589ebed6690 0x5589ebc21000
2019-10-31 19:52:41.983 [  ALERT]:CRASH: /home/dennis/Coding/tvheadend/src/tvh_thread.c:91 (discriminator 3) 0x5589ebe0d962 0x5589ebc21000
2019-10-31 19:52:42.186 [  ALERT]:CRASH: ??:0 0x7f5e7f01e669 0x7f5e7f015000
2019-10-31 19:52:42.187 [  ALERT]:CRASH: clone+0x43  (/lib/x86_64-linux-gnu/libc.so.6)
#2

Updated by Luis Alves 7 months ago

This seems to be an issue on libva and not tvheadend.

Can you print here the output of "vainfo" (from the tvheadend host machine)?

#3

Updated by Dennis Luxen 7 months ago

$ vainfo
error: can't connect to X server!
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_4
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.5 (libva 2.5.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Ivybridge Desktop - 2.3.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :    VAEntrypointVLD
      VAProfileMPEG2Simple            :    VAEntrypointEncSlice
      VAProfileMPEG2Main              :    VAEntrypointVLD
      VAProfileMPEG2Main              :    VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:    VAEntrypointEncSlice
      VAProfileH264Main               :    VAEntrypointVLD
      VAProfileH264Main               :    VAEntrypointEncSlice
      VAProfileH264High               :    VAEntrypointVLD
      VAProfileH264High               :    VAEntrypointEncSlice
      VAProfileH264StereoHigh         :    VAEntrypointVLD
      VAProfileVC1Simple              :    VAEntrypointVLD
      VAProfileVC1Main                :    VAEntrypointVLD
      VAProfileVC1Advanced            :    VAEntrypointVLD
      VAProfileNone                   :    VAEntrypointVideoProc
      VAProfileJPEGBaseline           :    VAEntrypointVLD

The system is based on a core i7-3770 (Ivy Bridge) CPU.

#4

Updated by Flole Systems 7 months ago

Seems to be a duplicate of #4764

#5

Updated by Luis Alves 7 months ago

The bug reported on #4764 also uses the "Ivy Bridge", maybe a bug on that platform.
I can easily transcode several streams at the same time but my cpu is a "Coffee Lake".

#6

Updated by Dennis Luxen 7 months ago

Is there a way to limit hardware acceleration to one stream and fall back to software-based encoding for other streams as a workaround?

#7

Updated by Flole Systems 18 days ago

  • Status changed from New to Invalid

Also available in: Atom PDF