Project

General

Profile

Bug #5720

Possible typo in xmltv.c episode-num output

Added by Petr Janda 3 months ago. Updated 22 days ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
EPG
Target version:
-
Start date:
2019-08-23
Due date:
% Done:

0%

Estimated time:
Found in version:
HTS Tvheadend 4.3-1804~gebb096804
Affected Versions:

Description

Hi all,

I've been trying to find out why neither Plex or Emby is showing episode/season numbers in their EPG - which is sourced from localhost:8891/xmltv and it seems that there is a typo in xmltv.c line 204.

htsbuf_append_str(hq, " <episode-num system=\"xmltv-ns\">");

should read

htsbuf_append_str(hq, " <episode-num system=\"xmltv_ns\">");

Note the underscore instead of hyphen in xmltv_ns. I think underscore is correct.

Thanks
Peter

History

#1

Updated by Petr Janda 3 months ago

Hi all,

I've been trying to find out why neither Plex or Emby is showing episode/season numbers in their EPG - which is sourced from localhost:8891/xmltv and it seems that there is a typo in webui/xmltv.c line 204.

htsbuf_append_str(hq, " <episode-num system=\"xmltv-ns\">");

should read

htsbuf_append_str(hq, " <episode-num system=\"xmltv_ns\">");

Note the underscore instead of hyphen in xmltv_ns. I think underscore is correct.

Thanks
Peter

#2

Updated by Em Smith 23 days ago

You are correct.
https://github.com/XMLTV/xmltv/blob/master/xmltv.dtd#L367
Everything else uses a hyphen except for this one field that should use an underscore.

Does Emby/Plex work when you change the line? If so, can you submit a pull request on github with your change? It's an ideal fix for your first commit.

#3

Updated by Petr Janda 22 days ago

Em Smith wrote:

You are correct.
https://github.com/XMLTV/xmltv/blob/master/xmltv.dtd#L367
Everything else uses a hyphen except for this one field that should use an underscore.

Does Emby/Plex work when you change the line? If so, can you submit a pull request on github with your change? It's an ideal fix for your first commit.

Yes It works fine after fixing the typo. I don't know how to do any of that pull request stuff sorry.

#4

Updated by Pablo R. 22 days ago

Petr Janda wrote:

Yes It works fine after fixing the typo. I don't know how to do any of that pull request stuff sorry.

https://github.com/tvheadend/tvheadend/pull/1313

#5

Updated by Jaroslav Kysela 22 days ago

  • Status changed from New to Fixed

Applied to master.

Also available in: Atom PDF