Project

General

Profile

Bug #5641

EMM not being sent to Oscam server using CCCAM

Added by Lukáš Hofťa 5 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2019-05-27
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1792~g466a014~jessie
Affected Versions:

Description

Hello, I have upgraded recently and EMM stopped being sent to Oscam server using CCCAM protocol. Newcamd works fine. Attached log from cccam subsystem


Files

cccam.log (61 KB) cccam.log Lukáš Hofťa, 2019-05-27 11:29
tvheadend-cccam.log (97.9 KB) tvheadend-cccam.log Lukáš Hofťa, 2019-06-19 13:48
tvh-log.zip (14.4 MB) tvh-log.zip Lukáš Hofťa, 2019-06-21 11:29
tvh.log (5.02 MB) tvh.log Lukáš Hofťa, 2019-08-15 08:43

History

#1

Updated by Lukáš Hofťa 4 months ago

Lukáš Hofťa wrote:

Hello, I have upgraded recently and EMM stopped being sent to Oscam server using CCCAM protocol. Newcamd works fine. Attached log from cccam subsystem

Apparently after further testing, EMM stops working after some time using newcamd too. This is causing quite a lot of issues when using irdeto card as it only start descrambling after first EMM received

#2

Updated by Lukáš Hofťa 4 months ago

Lukáš Hofťa wrote:

Lukáš Hofťa wrote:

Hello, I have upgraded recently and EMM stopped being sent to Oscam server using CCCAM protocol. Newcamd works fine. Attached log from cccam subsystem

Apparently after further testing, EMM stops working after some time using newcamd too. This is causing quite a lot of issues when using irdeto card as it only start descrambling after first EMM received. Restarting tvheadend service makes it working again

#3

Updated by Jaroslav Kysela 4 months ago

Add trace for 'descrambler' subsystem, too.

#4

Updated by Lukáš Hofťa 4 months ago

new logfile with descrambler subsystem

#5

Updated by Jaroslav Kysela 4 months ago

Thanks, unfortunately, reading logs with multiple channel reception is not really nice. Please, send the complete log (do not cut it) for one channel and describe the times when EMMs are not forwarded.

#6

Updated by Lukáš Hofťa 4 months ago

Hello Jaroslav,

the behaviour is really strange. EMM is not being sent even using newcamd - no single EMM entry in the log. When I restart tvheadend, it start to work for some time and then suddenly stops (OSCAM report 0 EMM received). Using CCCAM its not working at all, even I can see a lot of EMM filter messages, but only for cryptoworks card, nothing for irdeto and oscam also report 0 emm received on irdeto card. I hope these log files will be enough to find whats happening.

It started to happen after I switched to the new apt repo, the last version available on bintray worked fine for months. Unfortunately if I want to switch back, the packages are not available anymore…

Many thanks

#7

Updated by Lukáš Hofťa 3 months ago

I am looking for a Debian stretch version of tvheadend, which was last available on bintray - 4.3-1468~g3f74523. This version did not have this problem. Why all Debian packages disappeared and there are only centos packages left?

Since I have updated from new repo, I am facing the issue described above. I need to constantly restart tvheadend to get EMM updates to my cards. It prevents me using this version and there is no way to revert back to 4.3-1468~g3f74523 without compiling from source, which I am trying to keep away from. Stable 4.2.8 does not have cccam support so I rely on 4.3 unstable. Are any other trace logs required to get this fixed please?

Thank you

#8

Updated by Tim Bremer 3 months ago

Lukáš Hofťa wrote:

I am looking for a Debian stretch version of tvheadend, which was last available on

What about the Debian buster version?
[[https://apt.tvheadend.org/unstable/dists/]]

#9

Updated by Lukáš Hofťa 3 months ago

Because I use jessie on my tvh server. Buster was not out at the time when 4.3-1468~g3f74523 was published on Bintray repo. Cccam is working fine in that version. Now with the latest version I had to switch back to newcamd, which stops working after some time. Cccam is not sending EMM at all. I dont think Buster version will work, but I will try to install test environment to see.

Thanks

#10

Updated by Lukáš Hofťa 2 months ago

Buster is the same as I expected. Compiled the build 4.3-1468~g3f74523 and cccam is working fine. Current build is not sending EMM for 0D97 at all, using cccam or newcamd. 0624 works with newcamd but for a limited time, after that it stops sending EMM and I need to restart TVH. When used the old build, 0D97 started to work immediately with cccam. It even has to be killed, because "systemctl restart tvheadend" does not stop the daemon. This is a major problem, because Irdeto mode of ICE card start descrambling only after 1st EMM is received, so without an EMM update, TVH is not able to descramble.

#11

Updated by Jaroslav Kysela 2 months ago

Add descrambler-emm to traces : --trace descrambler,descrambler-emm,cccam,cwc . Also, please, do not cut the log lines between channel subscribe / unsubscribe . I need to verify which PIDs are subscribed in all layers. And only one active channel, please. It should be enough to capture only 10 seconds of the log.

#12

Updated by Lukáš Hofťa 2 months ago

Jaroslav Kysela wrote:

Add descrambler-emm to traces : --trace descrambler,descrambler-emm,cccam,cwc . Also, please, do not cut the log lines between channel subscribe / unsubscribe . I need to verify which PIDs are subscribed in all layers. And only one active channel, please. It should be enough to capture only 10 seconds of the log.

Hello Jaroslav,
I have attached the log as requested. I had to revert back to 4.3-1466~g0b8d903f2, where EMMs are working fine and stable, starting from 4.3-1468, EMM stops being sent after about 2 days, then I need to restart tvheadend to get it working again. Current build does not send EMM to oscam using cccam at all, newcamd has the "2 days problem".

Not sure if it is related, but I have to add ca stream filter to my configuration to force CAID 0624, without that tvheadend is trying to use 0D96 by default and cannot descramble.

Also available in: Atom PDF