Project

General

Profile

Bug #5627

linuxdvb: FE_READ_STATUS error Input/output error

Added by Bernd Nebendahl 3 months ago. Updated 2 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
DVB
Target version:
-
Start date:
2019-05-07
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1774
Affected Versions:

Description

I'm running tvheadend on libreelec 9.0.1 on a headless PC (Mainboard: ASRock J3455M, Memory: 4 GB, Disk: 240 GB SSD, Tuner: Digital Devices Max S8x, LNB: Kathrein UAS 584, Network: Astra 19.2E, no switch). Kodi is not running on that machine, it's a pure tv server. Kodi clients are connecting throug 1 Gbit/s LAN, recordings are directly stored on a Synology DS413j NAS, also connected through 1 Gbit/s LAN. Timeshift goes to the SSD. Inital setup went through an I have all channels I need and EPG seems to work. However from time to time (I did not recognize a pattern so far, CPU load on the tv server increases and in the status window of tvheadend the streams don't show any transmitted data. I enabled debug logging in the configuration (linuxdvb, mpegts, subscription). Attached a log file that was created when the situation showed up.

I noticed that there are warnings every hour saying (the actual service differs fo cours):

[WARNING]:epggrab: EIT: DVB Grabber - data completion timeout for 12246V in Astra 19.2E

After more than 12 hours after rebooting the machine I start to see many warnings (line 3777 of the logfile):

2019-05-06 20:47:00.016 [WARNING]:linuxdvb: DVB-S/S2X #7 - FE_READ_STATUS error Input/output error

I believe that this is the time, when Kodi does complain about having lost connection to the server.

Please let me know if and what additional information you might need to find the root cause and whether this is something I can find a work-around for e.g. using a different configuration or whether this is a real bug.

Thank you,
Bernd


Files

tvh201905060827.log (475 KB) tvh201905060827.log debug output of tvheadend Bernd Nebendahl, 2019-05-07 07:28
syslog_20190518.txt (432 KB) syslog_20190518.txt last 4000 lines of /var/log/syslog Bernd Nebendahl, 2019-05-18 09:00

History

#1

Updated by Jaroslav Kysela 3 months ago

You should also look to the kernel log. It appears that the DVB driver hangs for a reason.

#2

Updated by Bernd Nebendahl 3 months ago

I appologize for my ignorance. Are you referring to the output of "dmesg" or is there a specific file that contains the information you are referring to? If so, what file should I look at/post in order to find the problem?

#3

Updated by Bernd Nebendahl 3 months ago

Sorry for the long delay. After researching and trying to get the kernel log files working in libreelec I finally decided that I would be better off with moving to ubuntu server 18.04. I installed the latest stable version of tvheadend (4.2.8) and had a couple of the above descibed situations. However when looking at kern.log or syslog I did not find anything that looked very specific. I will do some more testing and logging and upload the results here. However I do have some more questions, that might help me to collect the right information.
Is there anything I need to enable in tvheadend or in the kerel to collect all relevant information? Would you recommend to upgrade tvheadend to the latest (unstable) version?

One more piece of information: Once I experience the situation described above I noticed that tvheadend does not report any incoming data from the streams, at the same time I have many processes (one per each of the 8 receivers) that each creates a high CPU load of 20-40% on each. How can I clearly identify if the kernel driver is really causing the problem and if so, should I then get into contact with Digital Devices?

Right now the situation is quite frustrating because the problem happened while trying to do recordings I only noticed that it did not work afterwards. I also did not find a solution to "reanimate" things other than rebooting. Stopping and starting the tvheadend service is not sufficient. Even unloading and reloading the tv card kernel modules (ddbridge cxd2099 dvb_core) after and before stoping and starting tvheadend does not resove the problem as far as I can tell. Does that help to find the location of the problem. Since I'm traveling right now I cannot currently send or upload any log files.

#4

Updated by Flole Systems 3 months ago

Definitely upgrade to unstable, at this point that's actually very stable and might already solve your problem.

#5

Updated by Bernd Nebendahl 3 months ago

Flole Systems wrote:

Definitely upgrade to unstable, at this point that's actually very stable and might already solve your problem.

I upgraded to the latest version of Tvheadend (4.3-1789~g6bfeca6c0) and also upgraded ubuntu server 18.04. In addition I made a clean install of the Digital Devices drivers version (0.9.36). The problem persists. Attached is the syslog file that contains (as I think) all relevant output. The problem starts at line 1523:

May 17 22:40:28 tvserver tvheadend[951]: linuxdvb: DVB-S/S2X #7 : DVB-S #0 - FE_READ_STATUS error Input/output error

I hope someone can gain more insight from the log file. As of today the system is too unreliable to be of any use.

Bernd

#6

Updated by Flole Systems 3 months ago

Most likely you're encountering a driver issue or the card crashed. If a restart of tvheadend doesn't fix the issue you can be almost 100% sure it's not a tvheadend issue.

#7

Updated by Bernd Nebendahl 2 months ago

Hello,

here is a short update to how things progressed. After a lot of debugging (big thanks to Andreas McPherson from the Digital Devices Support Team) Digital Devices offered to look into the tuner card for a potential HW defect. In parallel I also talked to the seller of the mainboard and replaced it with a new one (still the same type though). As Digital Devices didn't want me to wait even longer for a working system they replaced my card with a brand new one!!!
The new card on the new mainboard now work without any issue! I don't know though whether the problem was caused by the tuner card or the mainboard, nevertheless I'm now very happy in particular Digital Devices offered great support!

Bernd

#8

Updated by Jaroslav Kysela 2 months ago

  • Status changed from New to Invalid

Also available in: Atom PDF