Project

General

Profile

Bug #5602

No connection to the Tvheadend

Added by Alister Kunga about 3 years ago. Updated about 3 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
PVR / DVR
Target version:
-
Start date:
2019-04-13
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-1789
Affected Versions:

Description

Since update on TVHeadend / 4.3-1789 ~ g6bfeca6c0 have the following problems hope someone can help me further

Problem exists with dvr folder /home/hts/.hts/tvheadend/dvr
if I delete dvr folder and restart tvheadend works

As soon as I start a recording the pvr.hts - Command getDiskSpace failed: No response received

now how should that be solved?

Tvheadend log
2019-03-25 10:59:34.077 htsp: Got connection from 192.168.178.21
2019-03-25 10:59:34.077 htsp: 192.168.178.21: Welcomed client software: Kodi Media Center (HTSPv34)
2019-03-25 10:59:34.085 htsp: 192.168.178.21 [ Kodi Media Center ]: Identified as user 'admin'
2019-03-25 10:59:34.085 htsp: 192.168.178.21 [ admin | Kodi Media Center ]: Privileges updated
2019-03-25 10:59:41.962 htsp: 192.168.178.21 [ admin | Kodi Media Center ]: Disconnected

Kodi log
2019-03-25
10:31:48.794 T:3416601456 ERROR: AddOnLog: Tvheadend HTSP Client:
pvr.hts - Command getDiskSpace failed: No response received
2019-03-25 10:31:48.795 T:3416601456 ERROR: GetDriveSpace: Add-on 'Tvheadend:zbox-id91:9982' returned an error: server error
2019-03-25 10:31:49.285 T:3919573872 ERROR: GetDirectory - Error getting
2019-03-25
10:31:49.744 T:3366245232 ERROR: AddOnLog: Tvheadend HTSP Client:
pvr.hts - Command getEvents failed: No response received
2019-03-25
10:31:49.744 T:3366245232 ERROR: GetEPGForChannel: Add-on
'Tvheadend:zbox-id91:9982' returned an error: server error
2019-03-25 10:31:49.745 T:3366245232 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - failed to write (Invalid argument)
2019-03-25 10:31:49.745 T:3366245232 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - failed to transmit

History

#1

Updated by Flole Systems about 3 years ago

What Kodi plugin version are you using?

#2

Updated by Alister Kunga about 3 years ago

I use this version Tvheadend HTSP Client 4.4.16.1

#3

Updated by Flole Systems about 3 years ago

Can't reproduce here.

Also your log times don't match, like this it's hard to see what exactly caused what and where the disconnect occured.

What architecture is tvheadend running on? What operating system?

#4

Updated by Alister Kunga about 3 years ago

Tvheadend runs on Debian 9.8 and Kodi runs on odroid c2 Coreelec

#5

Updated by Flole Systems about 3 years ago

Debian 9.8 on x86, x64 or some arm CPU?

I think you might have to use gdb to look into this issue, create a breakpoint in the htsp stuff and then you can step through and see if something is odd somewhere.

Also available in: Atom PDF