Project

General

Profile

Bug #5529

Not updating viaccess card

Added by Jacko Hanzo 9 days ago. Updated 5 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2019-02-07
Due date:
% Done:

0%

Estimated time:
Found in version:
4.2.8-4~g9f7ab681a
Affected Versions:

Description

Hi im running HTS Tvheadend 4.2.8-4 that are connected to a oscam running Oscam-1.20_svn-r11494 both serveres are running ubuntu 18.04

the problem is that tvheadend is not sending any emm to oscam server and therefore manually update the cards by putting them in a TV with CI module

i have tried both with a newcamd user and dvbabi.

the weird part is that when dvbapi is used no emm in the trace log, but wiht newcamd i get a lot of emm but gives:
TRACE]:cwc: emm filter : Viaccess - len 47 mux 0x5600d8d799c0

tvheadend.log (4.35 MB) tvheadend.log Tvhead_newcamd.log Jacko Hanzo, 2019-02-08 08:12

History

#1 Updated by saen acro 9 days ago

how is configured dvbapi in oscam/tvh?
Update to actual version.

#2 Updated by Jacko Hanzo 8 days ago

saen acro wrote:

how is configured dvbapi in oscam/tvh?
Update to actual version.

in Oscam this is what i have:
oscam.conf

[dvbapi]
enabled = 1
au = 1
pmt_mode = 4
listen_port = 9000
user = tvhead
boxtype = pc

oscam.user
@
[account]
user = local
pwd = local
caid = 0500
monlevel = 4
au = 1
allowedprotocols = newcamd
group = 1
ident = 0500:040210
max_connections = 99

[account]
user = tvhead
pwd = tvhead
description = tvheaddvbapi
caid = 0500
monlevel = 4
au = 1
emmreassembly = 1
group = 1
ident = 0500:040210
@

In tvheadend i have to CA settoing. one for newcamd and one for dvbapi.
dvbapi
Client name: tvhead
Mode:OSCam net protocol (rev >=10389
Camd.socket filename / IP Address (TCP mode): 127.0.0.1
Listen / Connect port: 9000
@

The reason why i have 2 is that i did some testing to see which one send the EMM, most people says that i need DVBAPI, but when debug and trace there are no emm sendt.
but when i use newcamd i can see emm i the log from tvheadned. but OScam doenst catch them..

#3 Updated by Jacko Hanzo 8 days ago

theres the log when newcamd is enabled

#4 Updated by saen acro 8 days ago

oscam.dvbapi
is there a priority or ignore lines ?
something as
P: 0500:040210

to be clear is this provider or other?
*0500:040210 = YouSee/TDC Denmark (DVB-C)

oscam.conf

[dvbapi]
enabled = 1
pmt_mode = 6
delayer = 60
user = dvbapi
read_sdt = 1
write_sdt_prov = 1
extended_cw_api = 2
boxtype = pc-nodmx

try this.

#5 Updated by Jacko Hanzo 8 days ago

saen acro wrote:

oscam.dvbapi
is there a priority or ignore lines ?
something as
P: 0500:040210

to be clear is this provider or other?
*0500:040210 = YouSee/TDC Denmark (DVB-C)

oscam.conf
[...]

try this.

yes thats correct is 0500:040210 = YouSee/TDC Denmark (DVB-C) but with a different ATR number.

the boxtype - all the guides that i found wrote that it should be pc and not nodmx, do you know the different between those two.?

If i change the value in oscam, i then also need to change the value from tvheadend, right?

#6 Updated by saen acro 8 days ago

yes

#7 Updated by Jacko Hanzo 8 days ago

okay heres an update. it seem to work now with these values:
read_sdt = 1
write_sdt_prov = 1
extended_cw_api = 2
boxtype = pc

#8 Updated by saen acro 8 days ago

so to mark it as fixed (/)

#9 Updated by Mark Clarkstone 8 days ago

  • Status changed from New to Invalid

So if I'm reading this correctly, the problem isn't Tvheadend but Oscam. Marking as invalid.

#10 Updated by Andreas Fornberg 8 days ago

Jacko Hanzo wrote:

okay heres an update. it seem to work now with these values:
read_sdt = 1
write_sdt_prov = 1
extended_cw_api = 2
boxtype = pc

What does those values do when you have to use that?
Seems to be same update problem with a Conax card here.
Never had this problems earlier.

#11 Updated by Andreas Fornberg 8 days ago

Andreas Fornberg wrote:

Jacko Hanzo wrote:

okay heres an update. it seem to work now with these values:
read_sdt = 1
write_sdt_prov = 1
extended_cw_api = 2
boxtype = pc

What does those values do when you have to use that?
Seems to be same update problem with a Conax card here.
Never had this problems earlier.

I am using newcamd protocol and latest version of TVheadend so something must have changed there.
mgcamd on my old Dreambox had no problem to update it.

#12 Updated by Jacko Hanzo 5 days ago

Andreas Fornberg wrote:

Jacko Hanzo wrote:

okay heres an update. it seem to work now with these values:
read_sdt = 1
write_sdt_prov = 1
extended_cw_api = 2
boxtype = pc

What does those values do when you have to use that?
Seems to be same update problem with a Conax card here.
Never had this problems earlier.

read_sdt and write_sdt_pro - reads and stores the channels name in the oscam.srvid2 but i dont think that this could be the "thing" that got it to work
extended_cw_api - i could not find any info on this so i dont know if this value did the job. :(

#13 Updated by Jacko Hanzo 5 days ago

Andreas Fornberg wrote:

Andreas Fornberg wrote:

Jacko Hanzo wrote:

okay heres an update. it seem to work now with these values:
read_sdt = 1
write_sdt_prov = 1
extended_cw_api = 2
boxtype = pc

What does those values do when you have to use that?
Seems to be same update problem with a Conax card here.
Never had this problems earlier.

I am using newcamd protocol and latest version of TVheadend so something must have changed there.
mgcamd on my old Dreambox had no problem to update it.

Yes same here, when i add a dreambox as a client with same user login as for tvheadend, the card then updates..
same user login used with tvheadend did not update the card no emm.. so something did change..

Also available in: Atom PDF