Project

General

Profile

Bug #5504

building error

Added by Ricardo Rocha 3 months ago. Updated about 1 month ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
Packaging
Target version:
-
Start date:
2019-01-19
Due date:
% Done:

100%

Estimated time:
Found in version:
v4.3.1731
Affected Versions:

Description

/usr/bin/ld: /root/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libavutil.a(hwcontext_vaapi.o): undefined reference to symbol 'XDisplayName'
//usr/lib/x86_64-linux-gnu/libX11.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:709: recipe for target '/root/tvheadend/build.linux/tvheadend' failed
make2: * [/root/tvheadend/build.linux/tvheadend] Error 1
make2: Leaving directory '/root/tvheadend'
debian/rules:15: recipe for target 'override_dh_auto_build' failed
make1:
[override_dh_auto_build] Error 2
make1: Leaving directory '/root/tvheadend'
debian/rules:6: recipe for target 'build' failed
make: *
* [build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

Associated revisions

Revision d250c184 (diff)
Added by jebos about 1 month ago

Update to newest ffmpeg to fix libX11 compile issue "DSO missing from commandline"

Fixes #5504

History

#1 Updated by saen acro 3 months ago

Ricardo Rocha wrote:

 /usr/bin/ld: /root/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libavutil.a(hwcontext_vaapi.o): undefined reference to symbol 'XDisplayName'
 //usr/lib/x86_64-linux-gnu/libX11.so.6: error adding symbols: DSO missing from command line
 collect2: error: ld returned 1 exit status
 Makefile:709: recipe for target '/root/tvheadend/build.linux/tvheadend' failed
 make[2]: *** [/root/tvheadend/build.linux/tvheadend] Error 1
 make[2]: Leaving directory '/root/tvheadend'
 debian/rules:15: recipe for target 'override_dh_auto_build' failed
 make[1]: *** [override_dh_auto_build] Error 2
 make[1]: Leaving directory '/root/tvheadend'
 debian/rules:6: recipe for target 'build' failed
 make: *** [build] Error 2
 dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

What os/version?

#2 Updated by Ricardo Rocha 3 months ago

ubuntu 18.04

sorry!

#3 Updated by Ricardo Rocha 3 months ago

anyone else with this problem?

#4 Updated by saen acro 3 months ago

What command for compilation you use?

#5 Updated by Ricardo Rocha 3 months ago

AUTOBUILD_CONFIGURE_EXTRA="--enable-ccache --enable-ffmpeg_static --enable-hdhomerun_static" ./Autobuild.sh -t bionic-amd64

#6 Updated by saen acro 3 months ago

Ricardo Rocha wrote:

> -t bionic-amd64

this can be removed it's autodetected, when local build used

cat buildtvh.sh
#!/bin/bash

BASE=$(dirname "$0")
(
  if [ -d "$BASE/tvheadend" ]; then
    cd "$BASE/tvheadend" 
    git pull
  else
    cd "$BASE" 
    git clone https://github.com/tvheadend/tvheadend.git tvheadend
    cd "$BASE/tvheadend" 
  fi
  time AUTOBUILD_CONFIGURE_EXTRA="–-disable-bintray_cache --disable-hdhomerun_client --disable-hdhomerun_static " ./Autobuild.sh -j$(nproc)
) | tee "$BASE/build.log" 

in my script, build without any problem on 18.04

#7 Updated by saen acro 3 months ago

Is make distclean was been used?

#8 Updated by Ricardo Rocha 3 months ago

saen acro wrote:

Is make distclean was been used?

yes....

even deleted all build directory manually and make a new git clone!

#9 Updated by Ricardo Rocha 3 months ago

@Jaroslav it seens like -lX11 flag is missing somewhere could you point the right direction?

#10 Updated by Bastian Kleinschmidt 3 months ago

hi, i can confirm

CC              tvheadend
/usr/bin/ld: /apps/tvheadend/tvheadend-master/build.linux/ffmpeg/build/ffmpeg/lib/libavutil.a(hwcontext_vaapi.o): undefined reference to symbol 'XDisplayName'
//usr/lib/x86_64-linux-gnu/libX11.so.6: error adding symbols: DSO aus der Kommandozeile fehlt
collect2: error: ld returned 1 exit status
Makefile:709: recipe for target '/apps/tvheadend/tvheadend-master/build.linux/tvheadend' failed
make[1]: *** [/apps/tvheadend/tvheadend-master/build.linux/tvheadend] Error 1
make[1]: Verzeichnis „/apps/tvheadend/tvheadend-master“ wird verlassen
Makefile:107: recipe for target 'ffmpeg_all' failed
make: *** [ffmpeg_all] Error 2

build in ubuntu 18.04 with
./configure --enable-bundle --enable-ffmpeg_static --enable-libffmpeg_static --enable-libx264 --enable-libx265 --enable-vaapi --extra-libs=-lpthread

#11 Updated by saen acro 2 months ago

confirming error inside Windows Subsystem for Linux
no video devices inside container

/usr/bin/ld: /opt/tvheadend/build.linux/ffmpeg/build/ffmpeg/lib/libavutil.a(hwcontext_vaapi.o): undefined reference to symbol 'XDisplayName'
//usr/lib/x86_64-linux-gnu/libX11.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:709: recipe for target '/opt/tvheadend/build.linux/tvheadend' failed
make[2]: *** [/opt/tvheadend/build.linux/tvheadend] Error 1
make[2]: Leaving directory '/opt/tvheadend'
debian/rules:15: recipe for target 'override_dh_auto_build' failed
make[1]: *** [override_dh_auto_build] Error 2
make[1]: Leaving directory '/opt/tvheadend'
debian/rules:6: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

#12 Updated by Bastian Kleinschmidt 2 months ago

Reverting back to ffmpeg 4.0 (makefile.ffmpeg) fix the problem for me.

#13 Updated by saen acro 2 months ago

Any one have idea how to solve problem with Ubuntu 18.04?

#14 Updated by Anonymous about 1 month ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Also available in: Atom PDF