Project

General

Profile

Bug #5386

Failed to start Tvheadend - a TV streaming server and DVR

Added by Chris master over 2 years ago. Updated over 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-12-02
Due date:
% Done:

0%

Estimated time:
Found in version:
last
Affected Versions:

Description

i updates to last version i now tvheadend dont start

i got this error

Dez 02 16:48:07 TV-Head-End systemd1: Failed to start Tvheadend - a TV streaming server and DVR.
Dez 02 16:48:07 TV-Head-End systemd1: tvheadend.service: Unit entered failed state.
Dez 02 16:48:07 TV-Head-End systemd1: tvheadend.service: Failed with result 'timeout'.

History

#1

Updated by Chris master over 2 years ago

Version 4.3-1610~g79ea2a4~xenial

#2

Updated by Pablo R. over 2 years ago

Chris master wrote:

Version 4.3-1610~g79ea2a4~xenial

Could you look sytemctl log // service tvheadend status

or

/var/log/syslog too look for a crash or whatever happens.

#3

Updated by Chris master over 2 years ago

Pablo R. wrote:

Chris master wrote:

Version 4.3-1610~g79ea2a4~xenial

Could you look sytemctl log // service tvheadend status

or

/var/log/syslog too look for a crash or whatever happens.

Dez 02 20:01:54 TV-Head-End systemd1: Starting Tvheadend - a TV streaming server and DVR...
[email protected]:~$ sudo service tvheadend status
● tvheadend.service - Tvheadend - a TV streaming server and DVR
Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled; vendor preset: enabled)
Active: activating (start) since So 2018-12-02 20:04:18 CET; 1min 13s ago
Control: 1283 (tvheadend)
Tasks: 1
Memory: 1.5M
CPU: 4ms
CGroup: /system.slice/tvheadend.service
└─1283 /usr/bin/tvheadend -f -p /var/run/tvheadend.pid -u hts -g video

Dez 02 20:04:18 TV-Head-End systemd1: tvheadend.service: Service hold-off time over, scheduling restart.
Dez 02 20:04:18 TV-Head-End systemd1: Stopped Tvheadend - a TV streaming server and DVR.
Dez 02 20:04:18 TV-Head-End systemd1: Starting Tvheadend - a TV streaming server and DVR...
[email protected]:~$ sudo service tvheadend status
● tvheadend.service - Tvheadend - a TV streaming server and DVR
Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled; vendor preset: enabled)
Active: activating (start) since So 2018-12-02 20:04:18 CET; 1min 22s ago
Control: 1283 (tvheadend)
Tasks: 1
Memory: 1.5M
CPU: 4ms
CGroup: /system.slice/tvheadend.service
└─1283 /usr/bin/tvheadend -f -p /var/run/tvheadend.pid -u hts -g video

Dez 02 20:04:18 TV-Head-End systemd1: tvheadend.service: Service hold-off time over, scheduling restart.
Dez 02 20:04:18 TV-Head-End systemd1: Stopped Tvheadend - a TV streaming server and DVR.
Dez 02 20:04:18 TV-Head-End systemd1: Starting Tvheadend - a TV streaming server and DVR...

#4

Updated by Pablo R. over 2 years ago

That does not apport much.

try executing tvheadend directly on terminal.

/usr/bin/tvheadend -f -u hts -g video

Also look for an ouput for

cat /var/log/syslog | grep CRASH

#5

Updated by Pablo R. over 2 years ago

Pablo R. wrote:

That does not apport much.

try executing tvheadend directly on terminal.
[...]

Sorry,

/usr/bin/tvheadend -u hts -g video

#6

Updated by Chris master over 2 years ago

Pablo R. wrote:

Pablo R. wrote:

That does not apport much.

try executing tvheadend directly on terminal.
[...]

Sorry,
[...]

tvheadend run for some minutes then it stops.
i cant connect to webif.
after some minutes it runs aigain for some minutes

#7

Updated by Pablo R. over 2 years ago

But it crashes?

#8

Updated by Chris master over 2 years ago

Pablo R. wrote:

But it crashes?

no, but its hanging

● tvheadend.service - Tvheadend - a TV streaming server and DVR
Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled; vendor preset: enabled)
Active: active (running) since So 2018-12-02 21:02:46 CET; 5min ago
Process: 4543 ExecStart=/usr/bin/tvheadend -f -p /var/run/tvheadend.pid $OPTIONS (code=exited, status=0/SUCCESS)
Main PID: 4545 (tvheadend)
Tasks: 62
Memory: 63.2M
CPU: 43.383s
CGroup: /system.slice/tvheadend.service
└─4545 /usr/bin/tvheadend -f -p /var/run/tvheadend.pid -u hts -g video

Dez 02 21:05:54 TV-Head-End tvheadend4545: tvhdhomerun: tuner_vstatus (0)
Dez 02 21:05:54 TV-Head-End tvheadend4545: tvhdhomerun: tuner_vstatus (0)
Dez 02 21:06:23 TV-Head-End tvheadend4545: htsp: 192.168.115.219 [ eg | Kodi Media Center ]: Disconnected
Dez 02 21:06:35 TV-Head-End tvheadend4545: htsp: Got connection from 192.168.115.219
Dez 02 21:06:35 TV-Head-End tvheadend4545: htsp: 192.168.115.219: Welcomed client software: Kodi Media Center (HTSPv29)
Dez 02 21:06:35 TV-Head-End tvheadend4545: htsp: 192.168.115.219 [ Kodi Media Center ]: Identified as user 'eg'
Dez 02 21:06:35 TV-Head-End tvheadend4545: htsp: 192.168.115.219 [ eg | Kodi Media Center ]: Privileges updated
Dez 02 21:06:38 TV-Head-End tvheadend4545: mpegts: 11493.75H in Astra 19,2 - tuning on SAT>IP DVB-S Tuner #2 ([email protected])
Dez 02 21:06:38 TV-Head-End tvheadend4545: subscription: 0012: "epggrab" unsubscribing
Dez 02 21:06:38 TV-Head-End tvheadend4545: subscription: 0057: "192.168.115.219 [ eg | Kodi Media Center ]" subscribing on channel "Das Erste HD", weight: 100,

#9

Updated by Pablo R. over 2 years ago

Did you tried last? v4.3-1616~g39b74cbd8

Some bugs where fixed.

#10

Updated by Chris master over 2 years ago

Pablo R. wrote:

Did you tried last? v4.3-1616~g39b74cbd8

Some bugs where fixed.

ok after update it runs
i hope that it will not be haning again

#11

Updated by Chris master over 2 years ago

system is running now, but if i enable the satip server. tvheadend will crash

#12

Updated by Pablo R. over 2 years ago

Chris master wrote:

system is running now, but if i enable the satip server. tvheadend will crash

I will check that this evening. Are you using 4.3-1617?

What is the way to reproduce the crash? Simply activate the server while it is disabled?

#13

Updated by Chris master over 2 years ago

Pablo R. wrote:

Chris master wrote:

system is running now, but if i enable the satip server. tvheadend will crash

I will check that this evening. Are you using 4.3-1617?

What is the way to reproduce the crash? Simply activate the server while it is disabled?

yes last version

#14

Updated by Pablo R. over 2 years ago

Chris master wrote:

yes last version

I just tried but it does not hang or crash. Maybe export tunners is needed? I currently doesnt have tuners to export/test.

Also available in: Atom PDF