Project

General

Profile

Bug #5349

After Redmine update ATOM RRS return wrong url

Added by saen acro 8 months ago. Updated 5 months ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
-
Start date:
2018-11-26
Due date:
% Done:

0%

Estimated time:
Found in version:
current
Affected Versions:

Description

After Redmine update ATOM return wrong url

before

http://tvheadend.org/boards/5/topics/35225?r=35227#message-35227

after
https://127.0.0.1:8080/boards/5/topics/35225?r=35226#message-35226

History

#1 Updated by saen acro 8 months ago

It's RSS not RRS :(

#2 Updated by Mark Clarkstone 8 months ago

saen acro wrote:

It's RSS not RRS :(

Atom links appear to be working ok here, is this still the case?

#3 Updated by saen acro 8 months ago


still same

#4 Updated by saen acro 8 months ago

curl https://tvheadend.org/issues/5349.atom?key=b9339c2xxxxxxxxxxxxxxxxxxf5d84369
<?xml version="1.0" encoding="UTF-8"?>
<feed xmlns="http://www.w3.org/2005/Atom">
  <title/>
  <link rel="self" href="https://127.0.0.1:8080/issues/5349.atom?key=b9339c2a19f30be89f4c8a0f9c1d15f9f5d84369"/>
  <link rel="alternate" href="https://127.0.0.1:8080/"/>
  <id>https://127.0.0.1:8080/</id>
  <icon>https://127.0.0.1:8080/favicon.ico?1528612569</icon>
  <updated>2018-11-26T08:00:24Z</updated>
  <author>
    <name>Tvheadend</name>
  </author>
  <entry>
    <title>Tvheadend - Bug #5349: After Redmine update ATOM RRS return wrong url</title>
    <link rel="alternate" href="https://127.0.0.1:8080/issues/5349"/>
    <id>https://127.0.0.1:8080/issues/5349?journal_id=28085</id>
    <updated>2018-11-26T08:00:24Z</updated>
    <author>
      <name>saen acro</name>
      <email>[email protected]</email>
    </author>
    <content type="html">
&lt;ul&gt;&lt;/ul&gt;&lt;p&gt;It's RSS not RRS &lt;img src="/plugin_assets/redmine_wiki_extensions/images/sad.png" alt=":("&gt;&lt;/p&gt;    </content>
  </entry>
  <entry>
    <title>Tvheadend - Bug #5349: After Redmine update ATOM RRS return wrong url</title>
    <link rel="alternate" href="https://127.0.0.1:8080/issues/5349"/>
    <id>https://127.0.0.1:8080/issues/5349?journal_id=28086</id>
    <updated>2018-11-26T09:45:40Z</updated>
    <author>
      <name>Mark Clarkstone</name>
    </author>
    <content type="html">
&lt;ul&gt;&lt;/ul&gt;&lt;p&gt;saen acro wrote:&lt;/p&gt;

&lt;blockquote&gt;

        &lt;p&gt;It's RSS not RRS &lt;img src="/plugin_assets/redmine_wiki_extensions/images/sad.png" alt=":("&gt;&lt;/p&gt;

&lt;/blockquote&gt;

        &lt;p&gt;Atom links appear to be working ok here, is this still the case?&lt;/p&gt;    </content>
  </entry>
  <entry>
    <title>Tvheadend - Bug #5349: After Redmine update ATOM RRS return wrong url</title>
    <link rel="alternate" href="https://127.0.0.1:8080/issues/5349"/>
    <id>https://127.0.0.1:8080/issues/5349?journal_id=28088</id>
    <updated>2018-11-26T11:13:20Z</updated>
    <author>
      <name>saen acro</name>
      <email>[email protected]</email>
    </author>
    <content type="html">
&lt;ul&gt;&lt;/ul&gt;&lt;p&gt;&lt;img src="https://cdn.pbrd.co/images/HOWxA2L.png" alt="" /&gt;&lt;br /&gt;still same&lt;/p&gt;    </content>
  </entry>
</feed>

#5 Updated by saen acro 8 months ago

Thunderbird also return https://127.0.0.1:8080

#6 Updated by Andreas Smas 8 months ago

saen acro wrote:

Thunderbird also return https://127.0.0.1:8080

I'll look into this.

#7 Updated by saen acro 8 months ago

I can test ;)

p.s. branding is also gone
https://tvheadend.org/themes/a1/images/logo.png

#8 Updated by Pablo R. 8 months ago

Is it possible to implement the Redmine API? To connect from Android apps, for example. :P

#9 Updated by saen acro 8 months ago

Pablo R. wrote:

Is it possible to implement the Redmine API? To connect from Android apps, for example. :P

I have 27" 3K PC screen :D

#10 Updated by saen acro 8 months ago

Any update on case?

#11 Updated by Dave H 8 months ago

Pablo R. wrote:

Is it possible to implement the Redmine API? To connect from Android apps, for example. :P

This is a bug tracker, not a discussion forum. Please open a separate enhancement request.

#12 Updated by Dave H 8 months ago

saen acro wrote:

Any update on case?

It's a very annoying and presumably fairly simple bug to fix. Any progress to report,please?

#13 Updated by saen acro 8 months ago

Just guessing but,
website is behind NGINX and RSS read not described DNS but localhost=127.0.0.1
That's why links inside RSS are wrong and on site are correct.

#14 Updated by Dave H 7 months ago

Andreas Smas wrote:

I'll look into this.

There hasn't been any update since this statement, and according to https://tvheadend.org/users/1 Andreas hasn't logged in since.

Is anybody in contact with him that could ask whether there is any progress, or if there is some change in his circumstances could somebody else take a look at this annoying problem, please?

#15 Updated by Andreas Smas 7 months ago

  • Status changed from New to Fixed

This should be fixed now.

#16 Updated by saen acro 7 months ago

(/) fixed

#17 Updated by Andreas Smas 5 months ago

This issue is unfortunately temporarily back.

I'm trying out different rails servers for redmine.

It will be resolved before the end of the day.

#18 Updated by Andreas Smas 5 months ago

Should be OK again.

Also available in: Atom PDF