Project

General

Profile

Bug #5220

EPG recording won't stop

Added by Uwe Hey almost 3 years ago. Updated almost 3 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
PVR / DVR
Target version:
-
Start date:
2018-09-25
Due date:
% Done:

0%

Estimated time:
Found in version:
HTS Tvheadend 4.2.1
Affected Versions:

Description

I'm tracking this issue down for a while and finally I can provide some more information:

tvh activates EPG running state check, even if "USE EPG running state" is set to Disabled for channel.
To reproduce that, an EPG update need to run while recording of particular channel.

Please find attached channel config and tvheadend.log snippet.

PS:

Maybe you find my configuration uncommon ;-)

Every channel has two services assigned: One is an IPTV provided by DSL provider (Telekom) and another from an DVB-C to IPTV converter (AVM Fritz repeater). DSL IPTV sadly does not provide EPG, but provides very reliable bandwidth, and therefore EPG is pulled from DVB-C converter. DVB-C tvh network has lower priority, so recording uses always stable DSL.

Thanks to clever tvh this works very well and stable, just this little thing with EPG is nagging me.


Files

Channel.png (27.9 KB) Channel.png Uwe Hey, 2018-09-25 18:43
tvheadend.snip (257 KB) tvheadend.snip Uwe Hey, 2018-09-25 18:43
tvheadend.log (2.47 KB) tvheadend.log Uwe Hey, 2018-09-27 20:01
tvheadend.log (45.2 KB) tvheadend.log Uwe Hey, 2018-09-30 10:08

History

#1

Updated by Jaroslav Kysela almost 3 years ago

Please, upgrade to latest 4.2 and retest.

#2

Updated by Uwe Hey almost 3 years ago

Retested with HTS Tvheadend 4.2.6-42~g406ba887c:
Same behavior :-(

#3

Updated by Jaroslav Kysela almost 3 years ago

I don't see 'EPG stop' log line for the DVR entry. The starting log lines are just informal without any influence to the behaviour.

#4

Updated by Uwe Hey almost 3 years ago

I think entry f8e0c9b1a6090ea1251e5483b780d21d 'SAT.1 Nachrichten' shows quite well what's going on.
I started recording manually while the program was running and was scheduled to stop at 20:44. Shortly after start, I triggered EPG update and this set "EPG marking start".
Later, regular EPG update 2am set "EPG marking stop" and then recording stopped, finally.

Hope this helps..

Also available in: Atom PDF