Project

General

Profile

Bug #5093

Autorefresh don't work after remove records from upcoming record list

Added by s j about 3 years ago. Updated over 1 year ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
User Interface
Target version:
-
Start date:
2018-05-01
Due date:
% Done:

0%

Estimated time:
Found in version:
4.2.6-7~g5613551
Affected Versions:

Description

I have update from tvheadend 4.0 to 4.2.6-7~g5613551 on a Debian Jessie system.
After that Autorefresh function in upcoming recordlist no more works.
See screen shots.
I delete 2 items (autorefresh is enabled).
After deleting items always see.
I wait 10 minutes, items always see.
I uncheck and check the autorefresh box, after then the cleaning the items.

If I use the manual refresh button, then also cleaning the deleted items.

At the first I think, its a migration failure.
Thats why I do follow on debian system
apt-get purge tvheadend
rm -rf /home/hts/.hts
apt-get install tvheadend
And I start with a new cleaning Tvheadend installation.
But the problem is the same. No Autorefresh after remove an item from record list.

Thats why I also check the new unstable tvheadend version 4.3-1251 but also the same problem.


Files

tvheadendNoAutoRefresh1.png (134 KB) tvheadendNoAutoRefresh1.png Select to upcoming records and remove it s j, 2018-05-01 10:49
tvheadendNoAutoRefresh2.png (135 KB) tvheadendNoAutoRefresh2.png After deleting records always see s j, 2018-05-01 10:49
tvheadendNoAutoRefresh3.png (135 KB) tvheadendNoAutoRefresh3.png wait more then 10 minutes, recors always see s j, 2018-05-01 10:49
tvheadendNoAutoRefresh4.png (135 KB) tvheadendNoAutoRefresh4.png deselecting the autorecord flag s j, 2018-05-01 10:49
tvheadendNoAutoRefresh5.png (134 KB) tvheadendNoAutoRefresh5.png select the autorecord flag, now refresh the side and delete the removed items s j, 2018-05-01 10:49
tvheadendNoAutoRefresh6.png (53.9 KB) tvheadendNoAutoRefresh6.png Version is 4.2.6-7~g5613551 s j, 2018-05-01 11:06
tvheadendNoAutoRefreshBrowser.png (64.4 KB) tvheadendNoAutoRefreshBrowser.png Firefox 32bit 52.7.3 Debian Jessie 8.1 s j, 2018-05-02 11:25
Tvheadend_050.png (255 KB) Tvheadend_050.png konsole: Select the record for deleting s j, 2019-12-09 01:32
Tvheadend_051.png (255 KB) Tvheadend_051.png konsole: Delete the selected record, and wait 5 minutes, record always view s j, 2019-12-09 01:32
Tvheadend_052.png (256 KB) Tvheadend_052.png konsole: press the manual refresh button, then the delete record no more seeing s j, 2019-12-09 01:32
Tvheadend_053.png (206 KB) Tvheadend_053.png network: Select the record for deleting s j, 2019-12-09 01:32
Tvheadend_054.png (210 KB) Tvheadend_054.png network: Delete the selected record, in networking output you see the delete action s j, 2019-12-09 01:32
Tvheadend_055.png (205 KB) Tvheadend_055.png network: wait 5 minutes after delete record, in the meantime the recording has started, the record symbol has changed s j, 2019-12-09 01:32
Tvheadend_056.png (206 KB) Tvheadend_056.png network: press the manual refresh button, then the delete record no more seeing s j, 2019-12-09 01:32

History

#1

Updated by s j about 3 years ago

I have check the other lists.
The "Timer", "Autorecs", "Removed recording", "Failed recording" lists have same problem as the "Upcoming/Current recordings" list.

But the "Finished Recordings" list don't have this problem. The Autorefresh function of it running fine.

#2

Updated by Joe User about 3 years ago

In your png descriptions, I assume you meant "auto-refresh" instead of "autorecord"...

What browser are you using (and what client OS)? Have you tried others?

As I understand it, auto-refresh has to do with updates to the list due automatic type changes (time changing, autorecs added, etc) and NOT manually deleting entries. I am using 4.3, so I cannot test, but whenever I delete something it is immediately removed.

#3

Updated by s j about 3 years ago

In your png descriptions, I assume you meant "auto-refresh" instead of "autorecord"...

Sorry, my mistake. In the png description, I meant "AutoRefresh" not "Autorecord"

What browser are you using (and what client OS)? Have you tried others?

The client also a Debian Jessie 8.1 system on two other computers. One of this is an 32bit system, the other a 64bit system.
The problem exist on both computers.

With the tvheadend 4.0 on both computers the auto refresh feature work fine.

As I understand it, auto-refresh has to do with updates to the list due automatic type changes (time changing, autorecs added, etc) and NOT manually deleting entries. I am using 4.3, so I cannot test, but whenever I delete something it is immediately removed.

both
If I delete items with the "RemoveButton", then no auto refresh working.
If start or end a new record automaticly from recordlist, I only see that if I change the page or click manual the "RefreshButton". "AutoRefresh" also don't work.

I have also tested the unstable version 4.3. with the same problem.

#4

Updated by Max Max almost 3 years ago

You could take a look into the "Console" and "Network" tab of Firefox' developer tools (press F12 to open them). Do any entries come up in the console after you've deleted the entry? What appears in the network tab?

#5

Updated by s j over 1 year ago

I controlled the console and the network.
Details see in screenshots and screenshot description.

#6

Updated by s j over 1 year ago

At time I work debian 64 buster with tvheadend version 4.2.8-36~g5bdcfd8ac from the source http://apt.tvheadend.org/stable/dists/stretch/main/binary-amd64/
I browser with Firefox 68.2.0esr 64-Bit on debian buster 64bit from an other system
also I have tested browsing with Firefox 70 from windows 10, also no "Auto-refresh" working

#7

Updated by Flole Systems over 1 year ago

I've never experienced that on latest master, you might want to try with that one.

Also available in: Atom PDF