Bug #5065

EPG is not collected for viasat_baltic channels

Added by p k 7 months ago. Updated 24 days ago.

Status:NewStart date:2018-04-08
Priority:NormalDue date:
Assignee:Adam Sutton% Done:

0%

Category:EPG - Grabbers
Target version:-
Found in version:4.3-1037~ga1c5c5a7e Affected Versions:

Description

EPG is not collected for viasat_baltic channels any more.
I tried different versions, last working version is 4.3-1036~g4d1955080 (commit 4d1955080d55da8b43599eff8bcd4dadc2dc38cd).

How can I help to debug this issue?

tvh.log.gz - trace log (1.13 MB) p k, 2018-04-08 15:31

Screen Shot 2018-04-08 at 16.23.04.png (161 KB) p k, 2018-04-08 15:31

History

#1 Updated by p k 7 months ago

I removed all the channels except Viasat Explore. Enabled --trace tbl-eit,epggrab.
Started tvheadend, epggrab was running some time, once it finished only 2 records are shown in epg page. Version 4.3-1036 had much more rows. Also, next epggrab won't add new records, this means that once those 2 records expire there will be no more EPG data.

Apr  8 16:11:46 localhost tvheadend[18172]: mpegts: 11823V in astra 4.9E - tuning on Technisat SkyStar USB HD (DVB-S/S2) : DVB-S #0
Apr  8 16:11:47 localhost tvheadend[18172]: subscription: 0001: "epggrab" subscribing to mux "11823V", weight: 4, adapter: "Technisat SkyStar USB HD (DVB-S/S2) : DVB-S #0", network: "astra 4.9E", service: "Raw PID Subscription" 
..
Apr  8 16:21:57 localhost tvheadend[18172]: epggrab: EIT: DVB Grabber - data completion timeout for 11823V in astra 4.9E
Apr  8 16:21:57 localhost tvheadend[18172]: epggrab: VIASAT: Baltic - data completion timeout for 11823V in astra 4.9E
Apr  8 16:21:57 localhost tvheadend[18172]: subscription: 0001: "epggrab" unsubscribing

#2 Updated by Jaroslav Kysela 7 months ago

It seems that EIT events are seen, but skipped for a reason:

2018-04-08 16:11:51.629 [  TRACE]:tbl-eit: viasat_baltic: sid 1320 tsid 001f onid 0056 seg 01
2018-04-08 16:11:51.629 [  TRACE]:tbl-eit: viasat_baltic: pid 12 tableid 4F extraid 00000000001f0528 len 493
2018-04-08 16:11:51.629 [  TRACE]:tbl-eit: viasat_baltic:  section 0 last 1 ver 4 (ver 255 st 0 incomp 2 comp 0)

Suspicious line: https://github.com/tvheadend/tvheadend/blob/master/src/epggrab/module/eit.c#L995

Attach .TS (30 seconds) or investigate the problem in the code.

#3 Updated by p k 7 months ago

Attached 30s sample

#4 Updated by p k 7 months ago

Edit:

For some reason file upload gives error (tried multiple times). Anyway, I have uploaded it to onedrive, file can be downloaded using:

wget "https://onedrive.live.com/download?cid=F79C3A33AD71C0A9&resid=F79C3A33AD71C0A9%2125834&authkey=AI7A-moyrOPTQYk" -O sample.ts

md5 is
40237da442d7a76511d241bf6a225dba  sample.ts

#5 Updated by p k 5 months ago

Today I tried version 4.3-1288~g66d6161c5 and I noticed that other channels (beside viastat baltic stuff) have also similar issue. Eg. MTV Hits (thor 0.8w 12226V ServiceID 508), after tvheadend restart only 2 records are collected.

#6 Updated by hanza hanza 24 days ago

data/conf/epggrab/eit/config needs to be corrected to:
"viasat_baltic": {
"name": {
"eng": "VIASAT: Baltic"
},
"nit": {
"AMB": { "nbid": 85 },
"Viasat": { "nbid": 86 }
},
"pid": 57,
"prio": 5
},

details:
pid is 57, in source code its 37 which is developers typo error
nbid:85 now network name has chaged to "AMB".
This fix solves EPG problems. (EPG sits on 11785V freq)

#7 Updated by p k 24 days ago

Confirmed, it works. :)

@hanza hanza, can you create a pull request?

Also available in: Atom PDF