Project

General

Profile

Bug #4875

Bug #4851: TVH freezes: mpegts: too much queued table input data (over 2MB), discarding new

[WARNING] mpegts: too much queued table input data (over 2MB), discarding new

Added by Igor Mokrushin about 2 years ago. Updated almost 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
EPG - Grabbers
Target version:
-
Start date:
2018-01-19
Due date:
% Done:

0%

Estimated time:
Found in version:
4.2 commit 1665c355cb14c210fbe647cd2c911d9083061bd0
Affected Versions:

Description

After commit 1665c355cb14c210fbe647cd2c911d9083061bd0(release/4.2) there were problems:

  1. Logs have messages like:
    [WARNING] mpegts: too much queued table input data (over 2MB), discarding new
  2. Does not respond web interface.
  3. CPU usage > 53% after restart...

P.S. Testing was conducted on boards MIPS MT7621 with 256MB memory and DVB-T2 USB dongle. With previous commit these problems are not observed.


Files

bad_tvheadend.log (30.5 KB) bad_tvheadend.log current commit 1665c355cb14c210fbe647cd2c911d9083061bd0 Igor Mokrushin, 2018-01-19 19:57
ok_tvheadend.log (214 KB) ok_tvheadend.log previous commit 31d5854ccd73fde028fdbbcedd3ad23e13f8d124 Igor Mokrushin, 2018-01-19 19:57
om_retry_time.patch (764 Bytes) om_retry_time.patch Igor Mokrushin, 2018-01-19 23:02
new_om_retry_time.patch (777 Bytes) new_om_retry_time.patch Igor Mokrushin, 2018-01-21 23:19

Associated revisions

Revision 945e1d5f (diff)
Added by Jaroslav Kysela about 2 years ago

otamux: set the retry time for all muxes from the temporary failed network, issue #4875

Revision 951777a5 (diff)
Added by Jaroslav Kysela about 2 years ago

otamux: set the retry time for all muxes from the temporary failed network, issue #4875

History

#1

Updated by Mark Clarkstone about 2 years ago

  • Parent task set to #4851
#2

Updated by Igor Mokrushin about 2 years ago

New int64_t om_retry_time in structure epggrab_ota_mux causes race condition....
In src/epggrab/otamux.c om_retry_time is not initialized anywhere. If the condition (r! = SM_CODE_NO_ADAPTERS) is not fulfilled, then om->om_retry_time = 0 always!
This condition is almost always satisfied: if (networks_count < ARRAY_SIZE(networks) && om && om->om_retry_time < mclk()) goto next_one;
If set om->om_retry_time > mclk(), then the problem disappears. I made a fix that solves this problem, it's almost like the previous variant...

#3

Updated by Jaroslav Kysela about 2 years ago

Could you show me really bad traces ? It seems that your uploaded bad_tvheadend.log is ok . Your assumption is incorrect - the zero value in om->om_retry_time is fine, the condition means to not do fast retry for already tried muxes. You changed the condition to 'retry only if the mux failed in 60 seconds'.

#4

Updated by Jaroslav Kysela about 2 years ago

Does this change help?

--- a/src/epggrab/otamux.c
+++ b/src/epggrab/otamux.c

       if (net->failed) {
         TAILQ_INSERT_TAIL(&epggrab_ota_pending, om, om_q_link);
         om->om_q_type = EPGGRAB_OTA_MUX_PENDING;
+        om->om_retry_time = mclk() + mono2sec(60);
         goto done;
       }
       break;
     }
   }
#5

Updated by saen acro about 2 years ago

cannot send any log because there is UI restart continuously,
(only UI sub process main stay alive)
but I disable all EPG modules and all go near perfect

#6

Updated by Pim Zandbergen about 2 years ago

I was seeing the same problem.
Revision 945e1d5f appears to have fixed it.

Thanks!

#7

Updated by Anonymous about 2 years ago

I normally experience the problem 2-3 times a day but 14 hours after applying the patch, I've not yet experienced the problem.

#8

Updated by Igor Mokrushin about 2 years ago

Hi, Jaroslav!

In bad_tvheadend.log not hited lines:
[WARNING] mpegts: too much queued table input data (over 2MB), discarding new
As system used 100% CPU and I had to turn off the power. This is all that was saved in the file...
I use branch 4.2, applied patches to it from revision 945e1d5f, I do not observe this problem any more. Thanks!

#9

Updated by Igor Mokrushin about 2 years ago

New patch from revision 945e1d5f....

#10

Updated by Jaroslav Kysela about 2 years ago

  • Status changed from New to Fixed
#11

Updated by Paul M about 2 years ago

should this fix be in the latest releases and the unstable version in the tvh repo for ubuntu?

#12

Updated by Paul M almost 2 years ago

someone raised bug 4925
https://tvheadend.org/issues/4925

same problem. I've ended up reverting to 4.2.5, which is the first version I ever installed, in the hope that I can get something useable at all.

Also available in: Atom PDF