Project

General

Profile

Bug #4813

TVH does not support DVN jet (4A30)use NEWCAMD decryption.

Added by shengkun zang almost 2 years ago. Updated almost 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2017-12-25
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-710~g41624278b
Affected Versions:

Description

My CAID is a new version of 4A30 (DVN JET) TVH that has supported DVB-API mode decryption.
but TVH use newcamd mode to decrypt DVN JET system (4A30) failure. From oscam log and TVH log, it should be TVH problem. Please view log information by developers, thank you!


Files

log (1).txt (44.9 KB) log (1).txt oscam log shengkun zang, 2017-12-25 14:57
tvh-cwc.log (8.49 KB) tvh-cwc.log tvh log shengkun zang, 2017-12-25 14:58
tvheadend.log (49.7 KB) tvheadend.log tvh log shengkun zang, 2017-12-26 07:44
log (1).txt (7.17 KB) log (1).txt oscam log shengkun zang, 2017-12-26 07:44
log (2).txt (21.3 KB) log (2).txt oscam log shengkun zang, 2017-12-26 15:34
tvh-dvn.log (84.4 KB) tvh-dvn.log tvh log shengkun zang, 2017-12-26 15:34
tvheadend.log (35.7 KB) tvheadend.log shengkun zang, 2017-12-27 07:34
tvheadend.log (104 KB) tvheadend.log shengkun zang, 2017-12-27 07:43
tvheadend.log (133 KB) tvheadend.log tvh log new~ shengkun zang, 2017-12-27 12:30
log (4).txt (7.57 KB) log (4).txt oscam log shengkun zang, 2017-12-27 13:26
tvheadend.log (81.9 KB) tvheadend.log tvh log shengkun zang, 2017-12-27 13:27

Associated revisions

Revision c69368ba (diff)
Added by Jaroslav Kysela almost 2 years ago

cwc, newcamd: add detection for DVN ECM message, issue #4813

Revision 62d2ce6f (diff)
Added by Jaroslav Kysela almost 2 years ago

cwc, cccam: remove early ECM/EMM filter, issue #4813

Revision f152eb0c (diff)
Added by Jaroslav Kysela almost 2 years ago

cwc: fix typo, issue #4813

Revision 398bdb6c (diff)
Added by Jaroslav Kysela almost 2 years ago

Revert "cwc: fix typo, issue #4813"

This reverts commit f152eb0cf41a82a07a8c4bf1507d730616f71f98.

History

#1

Updated by Jaroslav Kysela almost 2 years ago

Retest with latest - v4.3-848-gc69368bae .

#2

Updated by shengkun zang almost 2 years ago

Jaroslav Kysela wrote:

Retest with latest - v4.3-848-gc69368bae .

Build: 4.3-710~g41624278b (2017-11-24T22:55:27+0800) Toggle details
The decryption failed, the screen is black screen, can hear the sound, the network can also see traffic, oscam without any request information. The log file is attached, thank you.

#3

Updated by Jaroslav Kysela almost 2 years ago

There's something different in your configuration. I don't see 'cwc:' lines in log (except the first login). You should see lines like:

2017-12-25 21:49:19.846 [  TRACE]:descrambler: cwc-219.219.0.46-15000-4A30: key state changed from INIT to READY for "SuQian/754MHz/黑龙江卫视高清" 
2017-12-25 21:49:19.846 [  TRACE]:descrambler: service "SuQian/754MHz/黑龙江卫视高清": 1 descramblers (0 ok 0 failed 0 fatal)
2017-12-25 21:49:19.846 [  TRACE]:descrambler: mux 0x55b8cc48f6b0 open pid 18DF (6367) (flags 0x0100) for 0x7fd47400c500
2017-12-25 21:49:19.846 [  DEBUG]:cwc: SuQian/754MHz/黑龙江卫视高清 using CWC 219.219.0.46:15000
#4

Updated by shengkun zang almost 2 years ago

Jaroslav Kysela wrote:

There's something different in your configuration. I don't see 'cwc:' lines in log (except the first login). You should see lines like:

[...]

#5

Updated by Jaroslav Kysela almost 2 years ago

v4.3-851-g62d2ce6f5

#6

Updated by shengkun zang almost 2 years ago

Jaroslav Kysela wrote:

v4.3-851-g62d2ce6f5

still not work!

#7

Updated by shengkun zang almost 2 years ago

shengkun zang wrote:

Jaroslav Kysela wrote:

v4.3-851-g62d2ce6f5

still not work!

#8

Updated by Jaroslav Kysela almost 2 years ago

Use '--trace descrambler,cwc'. Also it would be good to check why the non-standard ECM data are rejected in cwc_table_input(). I have no more ideas.

#9

Updated by shengkun zang almost 2 years ago

Jaroslav Kysela wrote:

Use '--trace descrambler,cwc'. Also it would be good to check why the non-standard ECM data are rejected in cwc_table_input(). I have no more ideas.

#10

Updated by Jaroslav Kysela almost 2 years ago

TVH now sends ECM to oscam. What oscam says on this?

2017-12-27 19:27:08.978 [  DEBUG]:cwc: ECM state INIT
2017-12-27 19:27:08.978 [  DEBUG]:cwc: Insert new ECM (PID 6987) for service "CCTV-8高清" 
2017-12-27 19:27:08.978 [  TRACE]:cwc: sending message sid 698 len 170 enq 1
2017-12-27 19:27:08.978 [  TRACE]:cwc: 00 00 B7 00 ED E8 D1 4E 2C 6F 8F 35 4A E0 CD EF .......N,o.5J...
2017-12-27 19:27:08.978 [  TRACE]:cwc: 00 A0 30 73 AE AF 58 9B C1 3D 42 2D 2E 00 95 90 ..0s..X..=B-....
2017-12-27 19:27:08.978 [  TRACE]:cwc: 7C 73 C5 73 F0 85 C7 3A 92 E4 7C B6 68 41 24 48 |s.s...:..|.hA$H
2017-12-27 19:27:08.978 [  TRACE]:cwc: E2 48 15 67 78 03 5F 62 ED 08 FA 91 02 B0 83 E8 .H.gx._b........
2017-12-27 19:27:08.978 [  TRACE]:cwc: 8A CC 31 A0 3E EA 27 72 8A 99 57 41 92 52 EB AF ..1.>.'r..WA.R..
2017-12-27 19:27:08.978 [  TRACE]:cwc: 6D 92 58 3F 48 0E 49 FD 67 3C 52 18 F6 CD DB 0F m.X?H.I.g<R.....
2017-12-27 19:27:08.978 [  TRACE]:cwc: 43 F4 59 F7 68 A0 CF 98 3A 4E C6 14 52 33 31 84 C.Y.h...:N..R31.
2017-12-27 19:27:08.978 [  TRACE]:cwc: 49 63 34 7C 21 A6 9E 3D 38 7B BB 29 E8 EC CB 8F Ic4|!..=8{.)....
2017-12-27 19:27:08.978 [  TRACE]:cwc: 5F 23 F1 7B FF 5A 17 1D D1 D6 6C 40 29 35 B4 64 _#.{[email protected])5.d
2017-12-27 19:27:08.978 [  TRACE]:cwc: EA CB F9 49 A0 7B BA 00 47 E4 C4 37 5A AC 24 44 ...I.{..G..7Z.$D
2017-12-27 19:27:08.978 [  TRACE]:cwc: 5D 23 31 D5 27 AB 38 D8 84 AF                   ]#1.'.8...      
2017-12-27 19:27:08.978 [  DEBUG]:cwc: Sending ECM (PID 6987) section=0/0, for service "CCTV-8高清" (seqno: 14)
2017-12-27 19:27:08.978 [  TRACE]:descrambler: ECM message 50:00 (section 0, len 144, pid 6987) for service "CCTV-8高清" 
#11

Updated by shengkun zang almost 2 years ago

Jaroslav Kysela wrote:

TVH now sends ECM to oscam. What oscam says on this?

[...]

Oscam has no any information, except for the information of the account connection, and there is no hint. Please look at the log file.

#12

Updated by Jaroslav Kysela almost 2 years ago

If you use oscam from https://github.com/nx111/oscam/blob/master/module-newcamd.c#L1379 the newcamd code is not patched for DVN there.

#13

Updated by shengkun zang almost 2 years ago

Jaroslav Kysela wrote:

If you use oscam from https://github.com/nx111/oscam/blob/master/module-newcamd.c#L1379 the newcamd code is not patched for DVN there.

Yes, I'm using this version. Where is the newcamd module code of patched for DVN ? thanks

#14

Updated by Andreas Fornberg almost 2 years ago

I don't know if it's another issue or if it is related but i have big problems with a Conax card too here with latest 4.3 git version.
Sometimes it doesn't decrypt the channel and when it does it stops decrypting with 30-60 sec intervals.

With 4.2.x stable versions i have no problems.

#15

Updated by Christian Eiden almost 2 years ago

Got errors when using TVH which includes commits for this ticket:

2017-12-27 19:34:33.315 cwc: Got unexpected ECM reply (seqno: 13)
2017-12-27 19:34:34.208 TS: ASTRA/12574.25H/DMAX HD: H264 @ #767 Continuity counter error (total 1400)
2017-12-27 19:34:34.208 TS: ASTRA/12574.25H/DMAX HD: AC3 @ #771 Continuity counter error (total 864)
2017-12-27 19:34:34.208 TS: ASTRA/12574.25H/DMAX HD: TELETEXT @ #34 Continuity counter error (total 744)
2017-12-27 19:34:34.208 descrambler: cannot decode packets for service "DMAX HD" 
2017-12-27 19:34:36.616 tsfix: transport stream H264, DTS discontinuity. DTS = 8139423, last = 7905423
2017-12-27 19:34:36.617 tsfix: transport stream TELETEXT, DTS discontinuity. DTS = 8059135, last = 7826587
2017-12-27 19:34:36.627 tsfix: transport stream AC3, DTS discontinuity. DTS = 8064000, last = 7816320
#16

Updated by saen acro almost 2 years ago

Test situation with NCAM (Fork of Oscam)

#17

Updated by Andreas Fornberg almost 2 years ago

I removed the commits from this ticket and recompiled and now my Conax card works again.

#18

Updated by Christian Eiden almost 2 years ago

Andreas Fornberg wrote:

I removed the commits from this ticket and recompiled and now my Conax card works again.

after going back to tvheadend_4.3-846~g9538b1c_amd64.deb, my HD+ card works as well without issue, with the commit I got glitches every 30-60s

#19

Updated by Jaroslav Kysela almost 2 years ago

Could you try to revert only commit 62d2ce6f5c8005c4bae147d45042c777244a0b74 (cwc, cccam: remove early ECM/EMM filter) ?

#20

Updated by Christian Eiden almost 2 years ago

I reverted commit 62d2ce6f5c8005c4bae147d45042c777244a0b74 but got the same result, glitches every 30-60s on HD+

#21

Updated by Jaroslav Kysela almost 2 years ago

I fixed this issue in v4.3-861-g715a4a844 . See the last associated commit to this bug.

#22

Updated by Mark Clarkstone almost 2 years ago

Jaroslav Kysela wrote:

I fixed this issue in v4.3-861-g715a4a844 . See the last associated commit to this bug.

Working here :)

#23

Updated by Christian Eiden almost 2 years ago

confirmed, working again in v4.3-861-g715a4a844

#24

Updated by Jaroslav Kysela almost 2 years ago

  • Status changed from New to Fixed

I'm closing this. TVH's has code for 4A30, but until oscam is not fixed, it won't work.

#25

Updated by shengkun zang almost 2 years ago

Jaroslav Kysela wrote:

I'm closing this. TVH's has code for 4A30, but until oscam is not fixed, it won't work.

OK Thanks!

Also available in: Atom PDF