Project

General

Profile

Bug #4746

Service not starting (systemd)

Added by David jrm about 2 years ago. Updated about 2 years ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Category:
Configuration
Target version:
-
Start date:
2017-11-27
Due date:
% Done:

0%

Estimated time:
Found in version:
From 4.3-683~gc201bd9 onwards
Affected Versions:

Description

Hi,

Since the last package updates for Ubuntu, tvheadend seems to be installed properly, however it doesn't start at all.
Launching tvheadend from console I saw it is installed on "/home/*user*/.hts/tvheadend" instead of "/home/*hts*/.hts/tvheadend" as was till few updates ago.
The last version Im able to upgrade and retain all configuration etc is 4.3-683~gc201bd9, so uninstalling the most recent and installing manually this version, it run as expected.

Could anyone check this?

Thanks

History

#1

Updated by Mark Clarkstone about 2 years ago

  • Status changed from New to Need feedback

David jrm wrote:

Hi,

Since the last package updates for Ubuntu, tvheadend seems to be installed properly, however it doesn't start at all.
Launching tvheadend from console I saw it is installed on "/home/*user*/.hts/tvheadend" instead of "/home/*hts*/.hts/tvheadend" as was till few updates ago.
The last version Im able to upgrade and retain all configuration etc is 4.3-683~gc201bd9, so uninstalling the most recent and installing manually this version, it run as expected.

Could anyone check this?

Thanks

What is the contents of /etc/default/tvheadend? And what version of Ubuntu?

What does

sudo systemctl status tvheadend
sudo journalctl -xe -t tvheadend
output?

#2

Updated by David jrm about 2 years ago

Mark Clarkstone wrote:

What is the contents of /etc/default/tvheadend? And what version of Ubuntu?

What does [...] output?

Thanks Mark! I didn't check the service status and this was the issue...
So looking to the systemctl status:
$ sudo systemctl status tvheadend
● tvheadend.service - Tvheadend - a TV streaming server and DVR
Loaded: loaded (/lib/systemd/system/tvheadend.service; disabled; vendor preset: enabled)
Active: inactive (dead)

I enabled the service with sudo systemctl enable tvheadend and now is working as expected.

Not sure why till some versions the service was always enabled and with the recent no...

Thx again

#3

Updated by Mark Clarkstone about 2 years ago

David jrm wrote:

Mark Clarkstone wrote:

What is the contents of /etc/default/tvheadend? And what version of Ubuntu?

What does [...] output?

Thanks Mark! I didn't check the service status and this was the issue...
So looking to the systemctl status:
$ sudo systemctl status tvheadend
● tvheadend.service - Tvheadend - a TV streaming server and DVR
Loaded: loaded (/lib/systemd/system/tvheadend.service; disabled; vendor preset: enabled)
Active: inactive (dead)

I enabled the service with sudo systemctl enable tvheadend and now is working as expected.

Not sure why till some versions the service was always enabled and with the recent no...

Thx again

Latest git master has a service file included. Did you already have one setup?

#4

Updated by Mark Clarkstone about 2 years ago

  • Subject changed from Ubuntu package not updating properly to Service not starting (systemd)
  • Status changed from Need feedback to Accepted

I've updated the title so that others don't open issues with a similar problem!

#5

Updated by David jrm about 2 years ago

Mark Clarkstone wrote:

I've updated the title so that others don't open issues with a similar problem!

Thanks, it does make sense :)

Also available in: Atom PDF