Project

General

Profile

Bug #464

Wrong filestructure of HD-Recordings (H264)

Added by B. J. over 11 years ago. Updated about 10 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Muxers
Target version:
Start date:
2011-04-19
Due date:
% Done:

0%

Estimated time:
Found in version:
2.12
Affected Versions:

Description

I'm not able to edit HD-Recordings created by tvheadend. All of known tools (Linux/Windows) fails in extract the video part of a recorded file obvisiously by presenting a message like "could not detect part of h264 stream". So there a demux/remux is'nt possible at the moment for hd-streams. ffmpeg/ffprobe run's over while demuxing with a message like:

[NULL @ 0xa864f60] This stream was generated by a broken encoder, invalid 8x8 inference
[NULL @ 0xa864f60] FMO not supported044425kB time=7666.02 bitrate=7527.8kbits/s
[NULL @ 0xa864f60] non-existing PPS referencedime=7858.78 bitrate=7519.1kbits/s
[NULL @ 0xa864f60] illegal POC type 4
[NULL @ 0xa864f60] non-existing PPS referencedime=7889.58 bitrate=7527.7kbits/s
    Last message repeated 1 times= 7472755kB time=8139.30 bitrate=7521.1kbits/s
[NULL @ 0xa864f60] missing picture in access unit
    Last message repeated 1 times= 7584912kB time=8351.36 bitrate=7440.2kbits/s
[NULL @ 0xa864f60] sps_id out of range
[NULL @ 0xa864f60] This stream was generated by a broken encoder, invalid 8x8 inference
[NULL @ 0xa864f60] illegal POC type 321982kB time=8448.32 bitrate=7410.1kbits/s
...

Files

LuxeHD-20110505-010856.raw (13.4 MB) LuxeHD-20110505-010856.raw Raw dump of the h264 Luxe HD IPTV stream Yura Scheglyuk, 2011-05-04 20:26
dump.mkv (9.77 MB) dump.mkv B. J., 2011-05-05 22:15

History

#1

Updated by Andreas Smas over 11 years ago

Tvheadend does not alter the contents of the h264 stream in any way so there must be something else that's fishy here...

#2

Updated by B. J. over 11 years ago

Maybe an issue with the muxer. See also here: https://www.lonelycoder.com/redmine/boards/5/topics/565
Demuxing of SD-Streams always works fine.

#3

Updated by Dimitris Kazakos over 11 years ago

I also have problems with h264 recordings (SD): most of the recordings cannot even be played back properly using any player I have tried. Some parts play ok, some just freeze and the image stutters for a few seconds and then it comes back to normal.
All my mpeg2 recordings work just fine, the problem is inly there for h264 streams (the audio on those streams is mpeg2 and plays fine throughout the recording, it's jus the video stream that has problems).
Since this matter is ruining my (perfect, apart from that) TvHeadend experience, I would appreciate it if the developer (or any other person who can help) could give us some instructions in order to (at least) debug the issue, so that maybe a solution can be found...

#4

Updated by Dimitris Kazakos over 11 years ago

One thing I noticed (and think that may be relevant to the issue) is that, although I know that the DVB-T h264 video stream has a resolution of 704x576, the recorded file (supposedly) has a resolution of 720x576 (this is seen both on the log when the recording starts and the mkv headers using mkvinfo).
Weird thing is that, even if I manually alter the resolution in the dvbtransports files, it is automatically set back to 720x576 after the first recording starts.

#5

Updated by Dimitris Kazakos over 11 years ago

Is the developer intending to spend any time with TvHeadend again? I am wondering, since there are numerous issues here (some of the quite important; eg. a DVR should be able to at least RECORD streams properly(!)) and there is no reply from him whatsoever...
I have even made a pull request on git with a feature 1 month ago and I never even got a reply about why it never got merged.
It is really important for me (and for the whole community I suppose) to know, since it would save us a lot of time switching to an actively developing dvr solution (dvr, mythtv, etc) instead of filing issues to a dead project.
It's a shame, though, since TvHeadend is the most straightforward solution and dushmaniac is trying hard to get it to work properly with xbmc.
PLEASE, at least inform us if you ever intend to look at the important matters.
Thanx in advance.

#6

Updated by Yura Scheglyuk over 11 years ago

Yes, I have the same problem. Tvheadend recordings not playing on some software and hardware players. I found that simple run of mkvmerge on recorded mkv's fix "wrong" mkv structure. But this is the partial solution because working on SD recordings only. HD channels not fixed by mkvmerge may be due h264 stream or something else.

#7

Updated by Dimitris Kazakos over 11 years ago

In my case, mkvmerge doesn't fix anything.
Actually, it seems like some parts of the video stream are dropped while recording, since while trying to play the file back, I get image freezing from time to time (for 1-2 seconds), while the audio is playing normally and then video resumes properly.
The point is that we have no directions for debugging the issue in order to find out where the problem really lies.

#8

Updated by Andreas Smas over 11 years ago

Dimitris Kazakos wrote:

Is the developer intending to spend any time with TvHeadend again? I am wondering, since there are numerous issues here (some of the quite important; eg. a DVR should be able to at least RECORD streams properly(!)) and there is no reply from him whatsoever...
I have even made a pull request on git with a feature 1 month ago and I never even got a reply about why it never got merged.
It is really important for me (and for the whole community I suppose) to know, since it would save us a lot of time switching to an actively developing dvr solution (dvr, mythtv, etc) instead of filing issues to a dead project.
It's a shame, though, since TvHeadend is the most straightforward solution and dushmaniac is trying hard to get it to work properly with xbmc.
PLEASE, at least inform us if you ever intend to look at the important matters.
Thanx in advance.

Hi, Sorry for not attending these matters. As I've lined out in the recent news entry I've spent a lot of time on Showtime recently.

But I really feel bad for not attending Tvheadend too and these types of commets makes it even "worse" in a way. I began developing Tvheadend many years ago because I was frustrated with how huge and user unfriendly Myth and VDR were (and part also because I wanted to learn more about DVB in general).

Well, obviously a project that is not maintained is also very user unfriendly. Therefore I've no decided to give attention to Tvheadend at least one day per week (or actually one-evening-after-the-family-have-gone-to-bed) so I can atelast merge and review patches and triage and fix critical bugs.

Sorry for letting you guys down. I never intended to.
'

#9

Updated by Andreas Smas over 11 years ago

  • Category set to PVR / DVR
  • Status changed from New to Need feedback
  • Assignee set to B. J.
  • Target version set to 2.13

I need a muxdump to be able to track this down.

#10

Updated by Yura Scheglyuk over 11 years ago

I have attached LuxeHD-20110505-010856.raw 13.3 Мb raw dump of the h264 Luxe HD IPTV stream.

#11

Updated by B. J. over 11 years ago

The file from Yura contains glitches in audio. If glitches are present there are issues with bad or low signal. Here is a coredump with a good redording

#12

Updated by Eric Valette about 11 years ago

See info on bug #555

#13

Updated by Hein Rigolo almost 11 years ago

  • Found in version set to 2.12

can this bug be closed now that bug #555 is fixed?

#14

Updated by Hein Rigolo almost 11 years ago

  • Category changed from PVR / DVR to Muxers
#15

Updated by Adam Sutton about 10 years ago

  • Status changed from Need feedback to Invalid

No update in 9 months, and stuff has and is changing.

Also available in: Atom PDF