Project

General

Profile

Bug #4583

Occasionally No Audio Stream while watching live IPTV during recording.

Added by Mike C about 3 years ago. Updated over 1 year ago.

Status:
New
Priority:
Normal
Category:
Streaming
Target version:
-
Start date:
2017-09-10
Due date:
% Done:

0%

Estimated time:
Found in version:
4.3-448
Affected Versions:

Description

Occasionally when watching a channel live that the DVR is recording, I will get no Audio. If I stop, and go back the missing Audio continues. Once it happens it always continues until the recording stops or I manually interrupt the pipe so the MPEGTS stream restarts. It can happen on a few different channels/muxes from the same source. However while I get no audio to my htsp client, the dvr records the audio perfectly in sync and can be played back later from kodi or directly with VLC. DVR is recording with pass. This also happens on many different devices and couple different clients

Im using streamlink 0.7 to pipe hls variant stream into TVH, as ffmpeg can't multi-tread grabbing segments and tends to get a lot of dropped streams because of that.

Im currently using 4.3-448 but I have noticed same thing in few past 4.3 builds.

This bug is impossible to reproduce on demand, just seams to randomly happen. However it seams more common when the dvr has been recording the channel for a long period of time. I am unsure if time is related or just the longer run time gives it a better chance of occurring.

I have been running debug all, and trace htsp log trying to catch it. I believe the line below is hinting at the problem as the only time I have seen it is when the problem happens, and is ALWAYS present when the problem is occurring.

2017-09-11 03:38:21.867 [ DEBUG]:globalheaders: gh disable stream 2 AAC-LATM und (PID 257) threshold 0 qd 0 qd_max 225630


Files

tvh1.log (94.2 KB) tvh1.log Debug + htsp trace log Mike C, 2017-09-10 17:43
tvh-trunc.log (23.4 KB) tvh-trunc.log Mike C, 2017-09-26 23:17

History

#1

Updated by Jaroslav Kysela about 3 years ago

Provide log for '--trace parser,globalheaders' when 'gh disable stream' problem is activated.

#2

Updated by Mike C about 3 years ago

I think i've found come across another bug. Ive tried parser,globalheaders traces, however it doesn't seam to show either unless I do traces all. running --debug all --traces all works just fine, except outputting everything.

I've tried:
tvheadend -f -u hts -g hts -l /media/n2/tvh.log --debug parser,globalheaders --trace parser,globalheaders
which has had no effect. No Trace lines or debug lines.
I have also tried to enable them in the debug tab both in debug and traces, as soon as I click apply they disappear. However I don't get an error message like this thou: "2017-09-20 08:42:17.283 config: uknown subsystem 'gh'"

I don't want to run with traces all as it makes HUGE log files in a short time, and it can takes days for the globalheaders bug to show up.

I will run all/all from the debug windows when the bug reoccurs.

#3

Updated by Mike C about 3 years ago

I finally was able to catch the bug in the log, it had to be with debug/trace all/all thou, so I truncated the log file a bit to help.

My wife was watching the stream and she said it just lost audio, so I started recording. I then stopped the stream from the current kodi device and started it again a few seconds later and it again wasn't producing audio. I checked the recording and it had full audio like other times in the past.

#4

Updated by Viktor Kuzmin over 1 year ago

Same happens at my place - no audio from time to time....

Also available in: Atom PDF