Project

General

Profile

Bug #4582

Tvheadend 4.4.20170707 doesn't load configuration after restart of Synology

Added by Mirko Soukup almost 5 years ago. Updated almost 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2017-09-10
Due date:
% Done:

0%

Estimated time:
Found in version:
4.4.20170707
Affected Versions:

Description

Hello,

I installed tvheadend-testing on my synology. It works really great but if I restart tvheadend or my synology I have to configurate tvheadend again. I don't have any idea why tvheadend does not keep the configuration.

I run tvheadend on DSM 6.1.3

Please help me.

Kind regards
Mirko

History

#1

Updated by Ludi K. almost 5 years ago

It is probably a problem of privileges; the tvheadend process is probably not able to write to the tvheadend-testing directory in the @appstore directory of the Synology.

On my Synology DS213j, the tvheadend-testing directory belongs to the user #166568, defined on my Synology as user "sc-tvheadend".

If it really is a problem of write privileges it is not a problem in tvheadend; it is a problem in the tvheadend package for the Synology. You should try to contact the person that created the package to have it fixed. (I remember also having such a problem and fixed it manually on the Synology by giving the tvheadend-testing directory the appropriate privileges.)

#2

Updated by Ludi K. almost 5 years ago

It might be related to the following issue of the framework to cross compile packages for the Synology:
https://github.com/SynoCommunity/spksrc/issues/2216

Also available in: Atom PDF