Project

General

Profile

Bug #4548

Package build fall on Ubuntu 17.04

Added by saen acro almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
General
Target version:
-
Start date:
2017-08-23
Due date:
% Done:

0%

Estimated time:
Found in version:
any after 4.3-347~g4a355237b
Affected Versions:

Description

Ubuntu 17.04 x64 is clean installed,
only installed is Digital Devices driver.
During compilation of FFMPEG compilation fall.
LOG of compilation LINK

compilation on 14.04 64bit and 16.04 32 bit pass without problem
except messages come after this commit
https://github.com/tvheadend/tvheadend/commit/0f31da36bf77db5c3946361f85d4b1d6d20f229c

WARNING: Option --enable-demuxer=mpeg did not match anything
WARNING: Option --enable-demuxer=mp4 did not match anything
WARNING: Option --enable-muxer=dvd did not match anything

History

#1 Updated by saen acro almost 2 years ago

Problem found INTEL GPU DRIVERS
Intel + software = mission impossible
Intel SandyBridge HD 3000 in my case P3000 from 01.org destroy ffmpeg building

#2 Updated by Jaroslav Kysela almost 2 years ago

Do you have libva devel package installed?

What's in the file /usr/include/va/va.h?

#3 Updated by saen acro almost 2 years ago

I even compile all from zero from intel git
if only drivers from ubuntu pool used all ok
this iSmarts broke something in his code with search someting not exist on hardware.
If installed desktop and want to remove packages from intel pool,
you need to remove 90% of GUI package real nightmare.

by the way this warnings

WARNING: Option --enable-demuxer=mpeg did not match anything
WARNING: Option --enable-demuxer=mp4 did not match anything
WARNING: Option --enable-muxer=dvd did not match anything

are staying

#4 Updated by Jaroslav Kysela almost 2 years ago

  • Status changed from New to Rejected

These warnings are harmless. Anyway, you should check libva installation or consult this on more appropriate place (intel code source?).

Also available in: Atom PDF