Project

General

Profile

Bug #4486

Can't compile ffmpeg

Added by Josef Schlehofer about 4 years ago. Updated about 4 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-07-18
Due date:
% Done:

0%

Estimated time:
Found in version:
master (4.3-295~ga9dffb7e9)
Affected Versions:

Description

Device: Turris 1.1 (PowerPC2020)
Operating system: Debian LXC container (probably SID)
Kernel: 3.18.58 (soon 4.4)

I tried even compile it with parameter: --disable-ffmpeg_static , but no-go

Here is log: https://pastebin.com/4fMEbWSD from terminal and here is log, which is located in: x264-snapshot there is config.log where is: https://pastebin.com/9evJjaQr

I know this doesn't help much, but this was working probably 3-4 months ago.
I tried latest version of x264, but it doesn't help me and there isn't new version of ffmpeg than 3.3.2. I will downgrade to 3.2.6 or 3.1.9 if it helps and will tell you result.

History

#1

Updated by Josef Schlehofer about 4 years ago

Full log is here: https://pastebin.com/jsnLX0Q3
I should have gcc compiler working.

#2

Updated by Josef Schlehofer about 4 years ago

From #IRC
btw: "AUTOBUILD_CONFIGURE_EXTRA=--disable-ffmpeg_static ./Autobuild.sh" this should be correct, right? because when I changed line 154 in file: "Makefile.ffmpeg" from enable(d) to disable then I could compile it even with fpie or fpic

it seems that it is working and I even installed it. I tried TV Nova and HBO and it's working.

I even tried to check diff from details in web ui https://www.diffchecker.com/T6p0a0YJ and it seems good ;-)

Maybe someone has (or will have) my issue, too.

Also available in: Atom PDF