Bug #4456

New recordings scheduled in webui don't show in Kodi anymore

Added by Hans Schneider almost 6 years ago. Updated almost 6 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Found in version:
Affected Versions:



when I use the EPG of the webui, the programmes record fine, I can access them from the webui afterwards, but there is no sign of them in the recordings listing in kodi. They're also not listed among "currently recording" in kodi. The account I use in the webui is the same account I use in kodi, and the user should have access to all recordings anyway. Tried with a newly created user as well. Same thing. This is true for timers based auto recordings and manually scheduled recordings.

When I schedule directly in kodi, the recordings also show up in the the recordings list in kodi. The recordings created by timers I created in the webui some time ago with an older version of tvheadend also keep showing up.

I first noticed this two to three weeks ago maybe, but can't say which version I used then. Maybe tvheadend_4.3-197~gf367aba, but it's still the same in 4.3-265~g9d32c67 that I built today.

The kodi and webui created timers look the same. Same owner, same creator, otherwise same settings as far as I see. Yet only the ones created directly in kodi and recordings created with the old timers show up in kodi.

I just installed an older build, tvheadend_4.3-103~g6a41689, that I had still saved. In a brief test with that one, webui created timers and recordings seem to work fine and recordings show up in kodi.



Updated by Jaroslav Kysela almost 6 years ago

Could you try to select a different priority for the recordings entered from webui?


Updated by Hans Schneider almost 6 years ago

That works. Even if the manually set priority is the same as my standard one. If I set manually scheduled recordings or auto-recordings to a different priority, all except standard/not set work, the recordings show up in kodi.

Setting the priority back to standard then makes the recordings vanish from kodi again. Different values set as standard in the default dvr profile don't make a difference.


Updated by Rich Lund almost 6 years ago

I'm seeing exactly this behaviour in 4.3-295~ga9dffb7e9 and changing the priority in the dvr log file also fixes it for me.


Updated by Kai Sommerfeld almost 6 years ago

tvh 4.3 introduced a new recording priority value which is not supported by Krypton's tvheadend PVR Addon (pvr.hts). That causes the problem described here.

The Kodi PVR addon has been adjusted in Kodi master branch already.

So, if you want to use unstable tvh (4.3) you must use Kodi master. Using unstabel tvh with Kodi Krypton is not supported.

Also available in: Atom PDF