Project

General

Profile

Bug #4402

Not all CAIDs used

Added by Rafal Kupiec over 5 years ago. Updated over 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
Descrambling
Target version:
-
Start date:
2017-05-29
Due date:
% Done:

100%

Estimated time:
Found in version:
4.3-173~gc4bba2902-dirty
Affected Versions:

Description

I have configured tvheadend with oscam and almost everything is working fine.
There are two new channels, with the following CAIDS available:

Index PID Type Language Details
8 0x00cc / 204 H264
7 0x0130 / 304 MPEG2AUDIO pol
1 0x01f8 / 504 CA CAIDS: 1803:000000
2 0x025c / 604 CA CAIDS: 1861:000000
3 0x05e0 / 1504 CA CAIDS: 186c:000000
4 0x02c0 / 704 CA CAIDS: 1813:000000, 0100:000068
5 0x0324 / 804 CA CAIDS: 1884:000000
6 0x0388 / 904 CA CAIDS: 0b01:000000

but in oscam logs I see that it tries all CAIDS available but 1803 and 1861. 1861 is CAID with rights to decode the channel, but looks like it is even not trying to use it.


Files

tvh_channel.png (68.1 KB) tvh_channel.png Service details Rafal Kupiec, 2017-05-29 17:20

History

#1

Updated by Rafal Kupiec over 5 years ago

OSCam net protocol (rev >= 10389) is configured.
In scam logs I can find only the following:

2017/05/29 17:16:36 3EA8991F c (ecm) tvheadend ([email protected]/0000/2908/6C:2E41E37E61A4AC7B2C23B6A51C9B085A): not found (39 ms) by XXX (F/3/3/3) - TENIS PREMIUM 1
2017/05/29 17:16:39 3EA8991F c (ecm) tvheadend ([email protected]/5C00/2908/64:36525766A60E65655486B12B561BDA76): not found (2537 ms) by XXX (F/6/6/6) - TENIS PREMIUM 1
2017/05/29 17:16:40 3EA8991F c (ecm) tvheadend ([email protected]/0000/2908/64:36525766A60E65655486B12B561BDA76): rejected (1 ms) by XXX (F/2/2/2) - TENIS PREMIUM 1
2017/05/29 17:16:40 3EA8991F c (ecm) tvheadend ([email protected]/0000/2908/8F:98E4633F29E13A3D667383347CCE620D): rejected (0 ms) by XXX (F/2/2/2) - TENIS PREMIUM 1

Why doesn't it tries 1803 & 1861? I'm especially interested in 1861 which can descramble this channel.

#2

Updated by Rafal Kupiec over 5 years ago

Rolled back to c8e1e63dec601756b6338a78359361c421838e3a.
Everything working fine. For sure one of last changes caused this bug.

#3

Updated by Jaroslav Kysela over 5 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Applied in changeset commit:tvheadend|d64bc8c0527bcd979ac1fc094513bdd5077ba639.

#4

Updated by Jaroslav Kysela over 5 years ago

Fixed in v4.3-178-gd64bc8c .

#5

Updated by Rafal Kupiec over 5 years ago

Its still not working after updating to gd64bc8c.

#6

Updated by Jaroslav Kysela over 5 years ago

Try to look to oscam verbose log what's going on. The only difference is that tvh sends all elementary stream PIDs to oscam which should be fine.

#7

Updated by Jaroslav Kysela over 5 years ago

One more fix is in v4.3-179-gab64f19 .

Also available in: Atom PDF