Project

General

Profile

Bug #4176

TVH Loses Sat>IP configuration after reboot

Added by Jon _ about 5 years ago. Updated over 4 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
SAT>IP
Target version:
-
Start date:
2017-01-12
Due date:
% Done:

0%

Estimated time:
Found in version:
4.0.9-16~g63c1034~trusty
Affected Versions:

Description

Hi

Referencing this post:

https://tvheadend.org/boards/5/topics/23227

It seems that when used with a Megasat Sat>IP 3 server, when the host machine is rebooted TVH loses all of the stored settings related to the Sat>IP device - so all tuners are marked disabled, all streaming / recording priorities and which network the devices are associated with are lost.

Please let me know if there are any relevant log files I can gather - I've had a look through syslog and there's nothing related to sat IP until I've re-enabled the tuner and then you see subscription requests. There doesn't appear to be anything related to sat IP discovery (although I can see my HD Homerun device being discovered...)

Thanks

Jon

History

#1

Updated by Jaroslav Kysela about 5 years ago

Is UUID of your device persistent ?

#2

Updated by Jon _ about 5 years ago

Jaroslav Kysela wrote:

Is UUID of your device persistent ?

Hi

Looking in the device info, the UUID appears to get changed every time the Megasat device reboots:

Previous UUID:

2e47f136-1dd2-11b2-8748-a2665716ec77

New UUID post reboot:

20e5d832-1dd2-11b2-b74e-f7304a068e5c

Are there any workarounds to stop TVH treating it as a new device every reboot?

#3

Updated by Jon _ about 5 years ago

I've logged this as an issue via Megasat support, but I've not heard anything back yet. Interesting the SatIP specifications say that the UUID should be static and not change ever...

Are there any workarounds from the TVH side that can help with this?

#4

Updated by g siviero about 5 years ago

But does the Megasat IP address remain the same (static IP or fixed via DHCP), or does it change also?

#5

Updated by Jon _ about 5 years ago

gabriele siviero wrote:

But does the Megasat IP address remain the same (static IP or fixed via DHCP), or does it change also?

Megasat IP is static (fixed DHCP reservation).

#6

Updated by Jaroslav Kysela about 5 years ago

TVH expects static UUID as in the SAT>IP specification - so you can migrate your device to another IP and the tuner config is preserved. The whole device discovery is based on UUID. Perhaps, we can allow to force user defined UUID based on IP address to not confuse the logic.

#7

Updated by Jon _ about 5 years ago

Jaroslav Kysela wrote:

TVH expects static UUID as in the SAT>IP specification - so you can migrate your device to another IP and the tuner config is preserved. The whole device discovery is based on UUID. Perhaps, we can allow to force user defined UUID based on IP address to not confuse the logic.

I've just had a look on the web to see if I can find alternative firmware etc for the device, and managed to find that SSH is open by default (with a static root password of 'admin' !!) so I'm having a poke around the device to see if it's possible to stop the UUID changing by changing the startup scripts...

#8

Updated by Jon _ about 5 years ago

Just had a look at how the box operates. When it boots up, if no device_description.xml file exists in /data, it symlinks to /opt/bin/sat2ip_server/device_description.xml.s

the device_description.xml.s appears to be generated from a template file in the same directory, which has blanks for things like UUID.

If you edit the generated file, you can replace the UUID with a previous one, restart the sat2ip service and you get your old UUID back (with some errors about UPNP ID's being invalid so regenerating them). Restart TVH and your tuner config is back again.

However, if you reboot the Megasat, the box is taken back to standard again, all changes made, files created etc are lost. I'm guessing the firmware is reloaded from scratch every boot? Filesystem is r/w so it must be being replaced at each boot..

Any ideas on how to update the firmware so the changes become persistent? :)

#9

Updated by g siviero about 5 years ago

If you use the "export server settings" function from the Megasat web interface what file do you obtain?
If you reboot and use the "import server settings" function from the Megasat web interface, does it reload the configuration from the file you previously saved and then uploaded?
Do you reboot from the web interface, by pressing the reset button on the back, or by unplugging and re-plugging the power cord?

#10

Updated by Jon _ about 5 years ago

g siviero wrote:

If you use the "export server settings" function from the Megasat web interface what file do you obtain?

You get a .settings file, contents don't have any reference to UUID:

#===============================================================================
#                         SAT>IP Server configuration
#===============================================================================

#---------------------------------------
#                Properties
#---------------------------------------

[Properties]
session_timeout = 60;        Time that server will keep session alive. Range is between 30 and 60 seconds.
lnb = 2;                    LNB configuration. 0 - Quattro; 1 - Quad/DiSEqC.
border_freq = 11700;        Border frequency of high and low band
hi_band_ol_freq = 10600;    High bald OL frequency
lo_band_ol_freq =  9750;    Low bald OL frequency

#---------------------------------------
#               Static configuration
#
#Example (opening static session on frontend 1):
#    [Static fe 1]
#    msys = dvbs;                Modulation system(dvbs, dvbs2)
#    src = 1;                    DiSEqC position (1, 2, ...,255)
#    freq = 10744;                Frequency in MHz
#    pol = h;                    Polarisation(h - horizontal, v - vertical, l - circular left, r - circular right)
#    sr = 22000;                    Symbol rate in kSymb/s.
#    fec = 56;                    FEC (12, 23, 34, 56, 78, 89, 35, 45, 910)
#    mtype = qpsk;                Modulation type(qpsk, 8psk)
#    pilot = none;                Pilot tones(on, off)
#    ro = none;                    Rol Off (0.35, 0.25, 0.20)
#    pids = 0,400,401,402;       List of PIDs
#    channel_name = arte;        Channel name
#    lcn = 0;                    Logical channel number
#---------------------------------------

If you reboot and use the "import server settings" function from the Megasat web interface, does it reload the configuration from the file you previously saved and then uploaded?

There's no reference to UUIDs in the file :(

Do you reboot from the web interface, by pressing the reset button on the back, or by unplugging and re-plugging the power cord?

From the web interface, reboot from SSH or physical power cut all result in a new UUID :(

#11

Updated by Jon _ about 5 years ago

There's new firmware posted on the megasat.tv site. UUIDs still change on device reboot though.. No changelog posted either :(

I had a look at the firmware files with some 'common' firmware extraction tools, but they don't seem to recognise it as being valid :(

#13

Updated by Knut Schleßelmann over 4 years ago

Hi there. Just an update for you guys.

I've been in contact with their support (that's not their best side :-/) and after a lot of complaining I got them to send me an updated firmware via email.

I haven't installed it here (no changelog, no words on the status of the build, etc) but "complained" again that they propably should fix their release workflow and publish an official release on their website. Sadly there's still no answer to my last mail again.

Don't loose hope and I'll keep you guys updated!

Regards

Knut

#14

Updated by Jon _ over 4 years ago

Knut Schleßelmann wrote:

I haven't installed it here (no changelog, no words on the status of the build, etc) but "complained" again that they propably should fix their release workflow and publish an official release on their website. Sadly there's still no answer to my last mail again.

Hi

Any news on the firmware - does it solve the UUID changing?

Your help and persistence is much appreciated with this!

Thanks

Jon

#15

Updated by Knut Schleßelmann over 4 years ago

Jon _ wrote:

Knut Schleßelmann wrote:

I haven't installed it here (no changelog, no words on the status of the build, etc) but "complained" again that they propably should fix their release workflow and publish an official release on their website. Sadly there's still no answer to my last mail again.

Hi

Any news on the firmware - does it solve the UUID changing?

Your help and persistence is much appreciated with this!

Thanks

Jon

Hi Jon,

as I said I refused to install such a release and told them to properly release it along with a changelog. Looks like it worked after all!

https://www.megasat.tv/support/downloads/download-info/satip-server-3-firmware/

Apparently the release is (still?) from 16th january but the version got bumped to 3.1.13 (they gave me 3.1.11 via email) and the changelog contains
UUID will not change after a reboot.
(2) Updates to WEBUI files will not use cached-copy from web browsers.
(2) Fixed some compatibility issues for web browsers running on MacOS.

So there you go! Let's try it out and give them feedback ;-)

Regards

Knut

#16

Updated by Jon _ over 4 years ago

Knut Schleßelmann wrote:

So there you go! Let's try it out and give them feedback ;-)

For some reason I didn't get the reply notification - I've just installed it so will see how it goes! :)

#17

Updated by cy clic over 4 years ago

Jon _ wrote:
I've just installed it so will see how it goes! :)

Hi Jon,
I have same issue.
I now have sw 3.1.15 & still has same problem
Did you get solution with your update?

#18

Updated by Jon _ over 4 years ago

cr c wrote:

I have same issue.
I now have sw 3.1.15 & still has same problem
Did you get solution with your update?

I'm using the 3.11.13 release referenced above and the UUID seems to be static across reboots - it changed on the first reboot after updating the FW but appears to have stuck after that (but to be honest, I've not tried rebooting the SatIP server recently to check!!)

#19

Updated by cy clic over 4 years ago

I would be interested if you could also try simulated power cuts?
"reboot" - seems ok but then we had a real power cut for 2 hours
and that was problematic.

#20

Updated by Jon _ over 4 years ago

cr c wrote:

I would be interested if you could also try simulated power cuts?
"reboot" - seems ok but then we had a real power cut for 2 hours
and that was problematic.

I'll give it a try later in the week...

I'm pretty sure we have had some power cuts since I installed the 3.11.13 release and it's come back up OK with the same UUID..

#21

Updated by Jon _ over 4 years ago

I still have the .13 firmware installer if it's of any use to you - I had a look at the .15 version and there doesn't appear to be a changelog :(

Also available in: Atom PDF